internet connection sharing

I have eventually got my wireless network running.  The computers see each other.   I am sharing printers and files.

When I set up the networking, using the wizzard I told one computer, this one in fact, that I would be connecting directly to the internet from it.  I told the other one that I would be connecting through another computer on the network.

BTW, I am on XP.

So, how do I actuially cause my internet connections on the second machine to actually go through the first?
LVL 8
jhurstAsked:
Who is Participating?
 
TannerManCommented:
the wizard should have set all this up for you, but try this on the machine NOT directly to the web.

from command prompt
ipconfig /all

See if the print shows that your remote machine's defatul gateway is the IP address of your ICS machine. If not, then edit your network card's TCP/IP settings manually and add a default gateway to that IP.

Give it a shot
0
 
JohnnyCanuckCommented:
Do you have one computer plugged directly into the hispeed modem?   If this is the case and you want to share the connection over wireless , you need to install a (in your case) wireless card in the same computer (ie: one computer needs 2 network cards).  Go to the control panel and select network connections.  Right click the connection that connects to the hispeed modem.  Click the Advanced tab and put a check in the box beside "Allow other network users to connect through this computers internet connection" under Internet connection sharing.  In the home networking connection box, select your wireless connection.  Go to each other computer in the network and make sure they have DHCP enabled (your connection sharing computer is now a DHCP server).  You may have to reboot the computers for the changes to take effect.  If you are using firewalls on the computers further configuration will be required.
0
 
alexch_xCommented:
Hello,

assume that the computer which connects directly to the Internet is the (A) with IP 192.168.0.1 and the other is (B) th IP 192.168.0.2. In the (A) pc you have to go to the settings of the Internet connection and check the Internet Connection Sharing. Now you have to go to the Properties of the Wireless Area Connection of the (B) pc and set the: Default Gateway is 192.168.0.1 and DNS Server is also 192168.0.1. That should do the job :-)

No, if you have installed Service Pack 2 for Windows XP you should check to see if in the Firewall Properties---> exceptions the File and Printer Sharing is UNCHECKED.

Another (last) thing is that many times the Wizards that came with a Access Point or a Wireless Network Card, installs a managing program. This program may Override the changes that you do directly from the Wireless Network Connection Properties. So be carefull of that. When you change all the gateway-dns settings open a cmd and type ipconfig /all and check if the default gateway is the right one.
 

Hope that helped.  
0
 
jhurstAuthor Commented:
The problem was exactly that I did not have the default gateway set.  As soon as I did that all worked fine.  In fact I am connected using this system right now.

Thanks.

And thanks to the others too
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.