Network connection from XP SP2 - Acquiring network address or Limited or no connection message

Hello,

I am currently having a problem with my XP SP2 connecting to my home network.  

This connection worked recently.  Currently I am getting either of these windows messages: Acquiring network address or Limited or no connection message.  This happens hardwire or wireless connections and I can connect through other machines.

I have reset the defaults for the firewall and checked the IP Settings to assign the settings from the D-Link router.

Any help will be greatly appreciated.
larryukeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sunray_2003Commented:
Can you check if this is what you are getting and the remedy
http://www.pchell.com/support/limitedconnectivity.shtml

SR
0
AbacusOnsiteCommented:
Have you tried WinSockFix.exe?  Personally, I have had really good luck with it... but, it doesn't work for everything.  It's best used to fix network problems caused by removing files accidentally with SpySweeper, SpyBot S&D, or Ad-Aware.  Give it a try, at least.

http://www.spychecker.com/program/winsockxpfix.html
0
larryukeAuthor Commented:
To AbacusOnsite:
Tried the WinSockFix.exe since I use SpySweeper from time to time.  Didn't work.  

To Other readers:
I have hard coded the IP address and other related information and the network line works OK (i.e. access to other network devices and the Internet).  The DHCP still will not assign an IP address from the router but other devices do get IP adresses assigned properly from the router.

My wireless connection sees my wireless router but will not connect even when I reenter the wireless WEP.  No problem with other devices on the network.

Any other ideas?
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

larryukeAuthor Commented:
To Sunray 2003:

Tried these things last night and I am still gettingt the same results as the WinSockFix.exe.

This is clearly a case where the OS refuses to assiign an IP Addess to the machine from the DHCP server on the router.

Any other suggestions?
0
AbacusOnsiteCommented:
A few more suggestions for you... before you try these, try saying a little prayer to Bill Gates.  It helps.

1. Make sure your DHCP service is started... sort of an easy one, but I thought I'd mention it anyway.  Right-Click on My Computer -> Manage -> Services and Applications -> Services

2. Also, check your registry to make sure that DHCP is actually being turned on when you check the radio button.  This one requires a little detective work in order to correctly identify your NIC in the registry (it's in HEX).  Point your favorite registry editor to HKLM -> SYSTEM -> CurrentControlSet -> Services -> {LONG HEX CODE} -> Parameters -> Tcpip.  Then, look for the key named EnableDHCP and make sure that it has a REG_DWORD value of 1.

A question:  Have you recently uninstalled any software at all?  Norton AntiVirus or anything else?  I know that sometimes Anti-virus programs have the tendency to break networking service dependencies.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sunray_2003Commented:
Have you tried to reset the router and see if that would help in assiging IP address
0
larryukeAuthor Commented:
The registry tip worked for the IP assignment from the hardwire connection, however, now the wireless connection will see my wireless network, but it won't connect. I have been uninstalling and re installing this device.  It's progress.  Thanks.
0
AbacusOnsiteCommented:
Is it saying that you are connected, but you still can't see the network (or internet)?  Or, is it saying that XP sees the network, but won't attach when you click the connect button?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.