Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Unable to ping through PIX 501 firewall

Posted on 2004-10-27
4
Medium Priority
?
607 Views
Last Modified: 2013-11-16
Hi Guys,

I am very much a PIX newbie but I have inherited this one at a client site.

I am unable to get a response to ping from the inside network. Ping works fine from the PIX itself.
Config is as follows:

PIX Version 6.1(4)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ArBRdD0hYbx encrypted
passwd 2KFQdI.2KYOU encrypted
hostname wh
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 1720
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names
access-list acl_out permit icmp any any echo-reply
access-list acl_out permit icmp any any time-exceeded
access-list acl_out permit icmp any any unreachable
access-list acl_out permit tcp any host "Replaced for Privacy" eq 85
access-list acl_out permit tcp any host "Replaced for Privacy" eq 5800
access-list acl_out permit tcp any host "Replaced for Privacy" eq 5900
access-list acl_out permit tcp any host "Replaced for Privacy" eq smtp
access-list vpn permit ip 192.168.1.0 255.255.255.0 172.16.254.0 255.255.255.0
access-list acl_in permit tcp any host "Replaced for Privacy" eq 85
access-list acl_in permit tcp any host "Replaced for Privacy" eq smtp
access-list acl_in deny ip 0.0.0.0 255.0.0.0 any
access-list acl_in deny ip 10.0.0.0 255.0.0.0 any
access-list acl_in deny ip 127.0.0.0 255.0.0.0 any
access-list acl_in deny ip 169.254.0.0 255.255.0.0 any
access-list acl_in deny ip 172.16.0.0 255.240.0.0 any
access-list acl_in deny ip 192.0.2.0 255.255.255.0 any
access-list acl_in deny ip 192.168.0.0 255.255.0.0 any
access-list acl_in deny ip 224.0.0.0 224.0.0.0 any
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
pager lines 24
interface ethernet0 10baset
interface ethernet1 10full
mtu outside 1500
mtu inside 1500
ip address outside "Replaced for Privacy" 255.255.255.248
ip address inside 192.168.1.199 255.255.255.0
ip verify reverse-path interface outside
ip verify reverse-path interface inside
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnaddress 172.16.254.1-172.16.254.254
pdm history enable
arp timeout 14400
global (outside) 1 "Replaced for Privacy"
global (outside) 1 "Replaced for Privacy"
nat (inside) 0 access-list vpn
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) "Replaced for Privacy" 192.168.1.10 netmask 255.255.255.255 0 0
access-group acl_in in interface outside
route outside 0.0.0.0 0.0.0.0 "Replaced for Privacy" 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si
p 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt ipsec pl-compatible
no sysopt route dnat
crypto ipsec transform-set myset esp-3des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup vpn3000 address-pool vpnaddress
vpngroup vpn3000 split-tunnel vpn
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
vpngroup vpn300 dns-server 192.168.1.1
vpngroup vpn300 wins-server 192.168.1.1
vpngroup vpn300 default-domain domain
vpngroup vpn300 idle-time 1800
telnet 192.168.1.10 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
terminal width 80
Cryptochecksum:7ae3c13b99af7203b3a7bc91
: end

As I understand the line access-list acl_out permit icmp any any echo-reply should be allowing me access.
Could there be anything else causing this?

Ping by name does resolve to ip but still get Request Timed Out

Please can you assist.

Regards

Mark
0
Comment
Question by:Mark_Lawson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 43

Assisted Solution

by:JFrederick29
JFrederick29 earned 1000 total points
ID: 12420562
acl_in is applied to the outside interface, not acl_out:

access-group acl_in in interface outside

Add this:

access-list acl_in permit icmp any any echo-reply
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12420999

access-list acl_in permit tcp any host "Replaced for Privacy" eq 85
access-list acl_in permit tcp any host "Replaced for Privacy" eq smtp

<== add (as JFrederick29 sugested):
 access-list acl_in permit icmp any any echo-reply

<== You don't need any of these explicit denies unless you want to log. EVERYthing is denied unless you explicitly PERMIT
no access-list acl_in deny ip 0.0.0.0 255.0.0.0 any
no access-list acl_in deny ip 10.0.0.0 255.0.0.0 any
no access-list acl_in deny ip 127.0.0.0 255.0.0.0 any
no access-list acl_in deny ip 169.254.0.0 255.255.0.0 any
no access-list acl_in deny ip 172.16.0.0 255.240.0.0 any
no access-list acl_in deny ip 192.0.2.0 255.255.255.0 any
no access-list acl_in deny ip 192.168.0.0 255.255.0.0 any
no access-list acl_in deny ip 224.0.0.0 224.0.0.0 any

Re-apply the acl any time you make changes:
   access-group acl_in in interface outside
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 1000 total points
ID: 12421013
You could just get rid of the acl_in and apply the acl_out since you already have the icmp allows in it...

no access-group acl_in in interface outside
no access-list acl_in
access-group acl_out in interface outside
0
 

Author Comment

by:Mark_Lawson
ID: 12476898
Thanks guys great help
0

Featured Post

Q2 2017 - Latest Malware & Internet Attacks

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out our latest Quarterly Internet Security Report!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Wikipedia defines 'Script Kiddies' in this informal way: "In hacker culture, a script kiddie, occasionally script bunny, skiddie, script kitty, script-running juvenile (SRJ), or similar, is a derogatory term used to describe those who use scripts or…
To setup a SonicWALL for policy based routing to be used with the Websense Content Gateway there are several steps that need to be completed. Below is a rough guide for accomplishing this. One thing of note is this guide is intended to assist in the…
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
Suggested Courses

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question