cannot make error reporting work - php.ini issues (error_reporting 2039)


I am having great difficulty making error-reporting work on a server. The server admin is adjusting the php.ini file for me, but nothing sems to work, i always get a blank screen when i get an error.

what i have had them change so far ir this

error_reporting 1
display_errors ON
display_startup_errors ON

I see this is done by veiwing the phpinfo file.

On the php page itself  I have tried these 4 things one at a time...
error_reporting(E_ALL ^ E_NOTICE);
error_reporting 1;
error_reporting (1);

it still wont display errors...

One thing worth mentioning, when i first viewed the phpinfo file. error_reporting was set to 2039 which I cannot find in the php manual, and when i asked her to change it tp 2047, it defaulted to 0 against her wishes.

what else can i do, what else should i chceck, the php version is 4.3.9

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Could be your syntax, there should be an = in the php.ini statements.

Here's what my php.ini has for error reporting:
  error_reporting = E_ALL
  display_errors = on

I use this in my php pages:

Instead of "error_reporting 1", try "error_reporting = E_ALL"
Also make sure the server admin restarts the server to reinitialize the ini file.
jblayneyAuthor Commented:
u know what

is the restart critical,

I dont know about the =, i a just reading the output when i run a phpinfo(), and as far as i can see, it looks good from there
If the admins know what they're doing they are either already restarting it, or if PHP is running in CGI mode it's not necessary to restart. (When run as a module the web servers needs to restart to read the new php.ini settings). But if phpinfo is telling you the setting is what it should be, then it's fine.
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

jblayneyAuthor Commented:

it is not in CGI mode i think, because if it was, i could add my own to the cgi-bin  which I cant do ..... correct?

since i see the changes in phpinfo(), does that mean the server has been restarted, or that only the file has been changed?

if it's not in cgi mode that the server needs restarting to show the changed parameters in php.ini, so if it's showing the new values it's been restarted.
jblayneyAuthor Commented:
thanks for the imput,

so then, it has been restarted, the setting say it is all good, but i still get blank sreens on error pages, what else needs to be changed?
Check this solution, perhaps it's similar to your problem :

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jblayneyAuthor Commented:
what happened is this...

Small erros like a missing semi-colon do not display, and that was what i set up for testing, when i had an sql error, the error was displayed.

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.