[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 668
  • Last Modified:

Sonicwall SOHO3 and High Speed Cable. Cannot connect.

Here is the rundown.

Sonicwall SOHO3 25 user.
Motorolla SB5100 cable modem
Comcast Home Cable (single ip by dhcp)
Linksys BEFSR41 Cable/DSL Router

I recently purchase the Sonicwall to replace my linksys for advanced security.  Up til now I have been runining with the Linksys online and have no connection problems.  The problem is, when I replace the linksys with my sonicwall , I cannot get connected.

I've tried NAT with DHCP client but I can never get a lease.

I've tried straight NAT and manually typing the settings but it is still a no go.  For some reason I just cannot get communication with the WAN.

I've tried just about everything except putting my linksys in between the firewall and the WAN which I do not want to do for performance issues.

Has anyone else had this problem or have any suggestions?



0
tsniff
Asked:
tsniff
  • 5
  • 5
1 Solution
 
idyllicsysCommented:
What firmware version are you using on the SOHO3?

If it less than 6.6.0.6, you should update it.
0
 
tsniffAuthor Commented:
I updated to the newest 6.6.0.6 firmware before trying to put it online so that's not the problem.
0
 
idyllicsysCommented:
Have you tried connecting it to something else, not the cable modem and seeing if it would route?

Also, have you checked the ARP table to see if it sees the MAC address of the cable modem? http://ipaddress/diag.html
0
Managing Security Policy in a Changing Environment

The enterprise network environment is evolving rapidly as companies extend their physical data centers to embrace cloud computing and software-defined networking. This new reality means that the challenge of managing the security policy is much more dynamic and complex.

 
tsniffAuthor Commented:
Internal routing through the lan seems to work fine.

The ARP table does not show the MAC of the modem.  Only the other systems on the network.  I'm not too familiar with these firewalls so do you have a suggestion of how to get it to see it?
0
 
idyllicsysCommented:
Look at the above comment. After you log into the firewall, change /management.html to diag.html

Click on ARP cache.

Try downgrading the firmware to 6.5.0.4. It is a very stable version and I still have many clients running it.

Have you tried this?

Turn off everything.

Turn on cable modem. Wait for the cable light to sync

TUrn on the SonicWall. Wait for the wrench light to turn off.

Turn on the computer.

Try connecting
0
 
tsniffAuthor Commented:
I might not have been clear enough with that last post.  I have already checked the ARP table but the modem is not shown.

I've tried turning everything off and back on in sequence.

I've tried shutting everything down overrnight.  Still a no go.

I did download the 6.5.0.4 the other night and had planned on trying it after I have exausted all my other options.
0
 
idyllicsysCommented:
Sorry about that. I didn't fully read the comment.

Only other option is to call SonicWall support 888.777.1476 and have them replace the unit.
0
 
tsniffAuthor Commented:
I might have to do that but I doubt it is a defective unit.  It has been used sucessfully on DSL at another location.  But then again, it could be just a problem wtih the cable modem side of it.
0
 
idyllicsysCommented:
Didn't even think of that, but due to the consumer grade of cable modems and the price, that may be the easiest solution to fix the problem
0
 
tsniffAuthor Commented:
I finally got back to working on this.  I did downgrade to the 6.5.0.4 but it was a still no go.

Now here is the wierd part.  When erasing and reloading the firmware, I didn't actually have the Sonicwall (SW) in place between my modem and my network.  I had the SW connected to a completely stand-alone system not connected to the network.  There I would erase and reload the firmware, run the configuration wizard and set everything up.  Once that was done, I would put the SW in place and try to grab a DHCP IP.  A no go.

Then, I decided to try something different.  I erased and reloaded the firmware.  Before running the setup wizard and configuring anything, I put the sonicwall in place.  I then ran the wizard and walla, it worked.

Just for the fun of it I decided to try something.  With the SW in place and properly working, I backed up my config and then removed the SW from the network.  I went ahead and connected it again to the stand-alone system and erased the firmware.  I reloaded the firmware, ran a quick configuration and then restored my backed-up working config.  Once that was done I put the sonicwall in place.  Nothing.

For some reason it just would not work unless I erased, reloaded and configured the sonicwall in place.  I've never seen this before.  I've configured many other sonicwalls outside of the actual network and they worked fine once I put them in place.  Wonder why this time it required to actually be in place before performing any kind of configuration.

I'm running 6.5.0.4 right now.  I'd like to upgrade the firmware but with all the troubles, I'm hesitant to.  Maybe I'll save that for a later date.

I don't know if your suggestion of downgrading the firmware had anything to do with it since I haven't tried the procedure using the newest firmware but since you were the only one to help, I'm giving you the points.
0

Featured Post

Will You Be GDPR Compliant by 5/28/2018?

GDPR? That's a regulation for the European Union. But, if you collect data from customers or employees within the EU, then you need to know about GDPR and make sure your organization is compliant by May 2018. Check out our preparation checklist to make sure you're on track today!

  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now