Reboot due to bugcheck 0x00000044, W2K Professional

I have three computers loaded with W2K Professional OS.  All computers are similiar, but not identical - sample configuration:

P4, 800
512 RAM
Intel Network Card
RAID Drives with 80GB HD

Systems are up and running 24 x 7, in production.  All three are experiencing reboot problems, some more than others.  Reboots usually happen at night and always create a dump file referencing bugcheck error 0x00000044 (MULTIPLE_IRP_COMPLETE_REQUESTS).  A sample of the parameters:

bugcheck code: 0x00000044
parameter 1: 0xff26609c
parameter 2: 0x00000cca
parameter 3: 0x00000000
parameter 4: 0x00000000

I have checked the bugcheck save dump files on 27 different reboot occassions and every parameter is exactly the same, except parameter 1 - it is always different.

I tried to run the debug through WinDbg - here are my results:

Microsoft (R) Windows Debugger  Version 6.3.0017.0
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\temp\Mini100604-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*c:\symbols\websymbols*
Executable search path is: C:\I386
Unable to load image ntoskrnl.exe, Win32 error 2
*** WARNING: Unable to verify timestamp for ntoskrnl.exe
*** ERROR: Module load completed but symbols could not be loaded for ntoskrnl.exe
Windows 2000 Kernel Version 2195 (Service Pack 4) UP Free x86 compatible
Kernel base = 0x80400000 PsLoadedModuleList = 0x8046e1b8
Debug session time: Wed Oct 06 00:45:36 2004
System Uptime: not available
Unable to load image ntoskrnl.exe, Win32 error 2
*** WARNING: Unable to verify timestamp for ntoskrnl.exe
*** ERROR: Module load completed but symbols could not be loaded for ntoskrnl.exe
Loading Kernel Symbols
Loading unloaded module list
Loading User Symbols
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 44, {ff293a9c, cca, 0, 0}

***** Kernel symbols are WRONG. Please fix symbols to do analysis.

Probably caused by : ntoskrnl.exe ( nt+1fcca )

Followup: MachineOwner

kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

A driver has requested that an IRP be completed (IoCompleteRequest()), but
the packet has already been completed.  This is a tough bug to find because
the easiest case, a driver actually attempted to complete its own packet
twice, is generally not what happened.  Rather, two separate drivers each
believe that they own the packet, and each attempts to complete it.  The
first actually works, and the second fails.  Tracking down which drivers
in the system actually did this is difficult, generally because the trails
of the first driver have been covered by the second.  However, the driver
stack for the current request can be found by examining the DeviceObject
fields in each of the stack locations.
Arg1: ff293a9c, Address of the IRP
Arg2: 00000cca
Arg3: 00000000
Arg4: 00000000

Debugging Details:

***** Kernel symbols are WRONG. Please fix symbols to do analysis.

IRP_ADDRESS:  ff293a9c




LAST_CONTROL_TRANSFER:  from 00000044 to 8041fcca

804739b4 00000044 ff293a9c 00000cca 00000000 nt+0x1fcca

8041fcca ??               ???


FOLLOWUP_NAME:  MachineOwner

SYMBOL_NAME:  nt+1fcca


IMAGE_NAME:  ntoskrnl.exe




Followup: MachineOwner

I appreciate any assistance, advice or direction you may have.  These are the things I have tried:

1.  I have added memory to the units.  Upto 1024MB and the problem still occurs.
2.  I have replaced the memory all together.  Problem still occurs.
3.  I have tried a different UPS as a backup power source.  Problem still occurs.
4.  I have reinstalled the OS on one unit, and the problem hasn't occurred yet - but I'm not sure this is a valid test.  I only loaded the base software back on and I'm concerned that once we load the big brother monitoring software and the veritas backup software the problem will start again OR I haven't waited long enough on the reinstall testing to see if that really was the solution.

All of my research points this to be a driver problem, but how do I find it?  I am not very technical, so advice in lay-man terms would be appreciated.

Thank you.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.


yes it's a driver problem, i would load the monitoring software on the fresh install and wait a couple of days, if no problem then load the veritas, looks like one or the other is trying to sieze a packet thats already used.

hope that this helps
Darrell PorterEnterprise Business Process ArchitectCommented:
Are you loading the Veritas Backup Remote Agent?;en-us;296734 - it is VERY possible some files are overwritten from the service pack when you install third-party applications.  After installing thrid-party applications, reapply the latest service pack and see if the problems continue.;en-us;867774;en-us;832212

I hope this helps,


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AnixonIMSAuthor Commented:
Thanks for the feedback.  We have reapplied SP4 to one of the units.  We are slowly adding back in the third party software on another.  We're monitoring both now.  I'll let you know how it goes.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.