Solved

javax.jms.JMSException: MQJMS2007: failed to send message to MQ queue

Posted on 2004-10-27
4,520 Views
Last Modified: 2013-12-10
Weblogic 8.1 Mq 5.3 using MQ configured as a foriegn JMS provider
javax.jms.JMSException: MQJMS2007: failed to send message to MQ queue
while deploying ear file.

Has anybody faced this error?
Is it due to the volume/size of the message to mq queue?
Any solution to this problem?
Thanks
Giri
0
Question by:protege_g
    3 Comments
     
    LVL 23

    Accepted Solution

    by:
    Hi,

    I have simulated the same with sample program. Intially I tried to send 10000 objects and it works fine. Then I tried to add 1 million String objects to vector and send the objectMessage and got the same exception.
    The solution to this problem as follows
    1) use the runmqsc utility to alter the MAXMSGL parameter of all of the appropriate objects like QMGR, QLOCAL etc.

    I have increased the MAXMSGL praramter size to 200000000 in the Qmanager and in the queue

    2) increase the max message size in channel definition.
    Created one server channel with MAXMSGL as 200000000 and attached the server channel to the connection queue factory.

    Follow the above two steps then the problem will be solved.

    R.K
    0
     

    Author Comment

    by:protege_g
    Thanks for your response.How are you so sure that it is the message size?
    It could also be transaction related!
    Bit of  background:
    In my ejb-jar.xml I have <trans-attribute>NotSupported</trans-attribute>.The connection factory to MQ setting is probably also is non XA.If I change to <trans-attribute>Required</trans-attribute> ,I get an error saying MDB cannot communicate with XA resource(i.eJMS Provider).So currently in ejb-jar.xml I have <trans-ttribute>NotSupported</trans-attribute>.
    This helped me deploy my ejb jar file and war file.During deployment ,it does create a huge message and seems to be
    a possible reason for the above mentioned MQJMS error.There were messages created and sent before this happend.

    Our MQ administrator has to effect the changes you suggested.So could not confirm your solution yet.

    Given this scenerio,would you still say it is the message size?
    Thanks
    protege

    0
     

    Author Comment

    by:protege_g
    I increased the message lenght size everywhere per your suggestion and also reduced the data load
    and this did this solve the problem
    Thanks
    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone. Privacy Policy Terms of Use

    Featured Post

    Highfive Gives IT Their Time Back

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Configure Web Service (server application) I. Configure security for Web Services methods First, we need to protect Session bean which implements the service: 1. Open EJB deployment descriptor (ejb-jar.xml) in the EJB project that contains you…
    This exercise is about for the following scenario: Dmgr and One node with 2 application server. Each application server contains it owns application. Application server name as follows server1 contains app1 server2 contains app1 Prereq…
    how to add IIS SMTP to handle application/Scanner relays into office 365.
    Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

    875 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    13 Experts available now in Live!

    Get 1:1 Help Now