Windows XP Pro Explorer slow menu display on right click of folder

Right clicking on a folder takes about 2 minutes to display. I have run Virus scans, AdAware, SpyBot, ShellExView (disabled all except MS) and in general reviewed all of the "slow" entries here.

Right clicking on a desktop icon is normal. Right clicking on My Documents in Explorer view is normal but right clicking on a subfolder is slow. Right clicking on a local drive letter is slow.

I have two XP Pro desktop machines (Micron & Dell)  and a laptop (eMachine)  and but it only happens on the Dell. These machines are networked but the problem is with local drives to the Dell. If I access the Dell from another machine, the response is normal for a network drive.

System Info:
OS Name      Microsoft Windows XP Professional
Version      5.1.2600 Service Pack 1 Build 2600
OS Manufacturer      Microsoft Corporation
System Name      DELL
System Manufacturer      Dell Computer Corporation
System Model      Dimension 8200
System Type      X86-based PC
Processor      x86 Family 15 Model 1 Stepping 2 GenuineIntel ~1894 Mhz
BIOS Version/Date      Dell Computer Corporation A09, 9/13/2002
SMBIOS Version      2.3
Windows Directory      C:\WINDOWS
System Directory      C:\WINDOWS\System32
Boot Device      \Device\HarddiskVolume1
Locale      United States
Hardware Abstraction Layer      Version = "5.1.2600.1106 (xpsp1.020828-1920)"
User Name      DELL\System Master
Time Zone      US Eastern Standard Time
Total Physical Memory      512.00 MB
Available Physical Memory      96.09 MB
Total Virtual Memory      1.72 GB
Available Virtual Memory      948.13 MB
Page File Space      1.22 GB
Page File      C:\pagefile.sys
LVL 1
OldSoftwareAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SheharyaarSaahilCommented:
Hello OldSoftware =)

Right-click is slow or weird behavior caused by context menu handlers
http://windowsxp.mvps.org/slowrightclick.htm
0
OldSoftwareAuthor Commented:
I've turned off all of the non-Microsoft context menu handlers, no effect.
0
SheharyaarSaahilCommented:
ok just tell me one more thing plzz.... same problem in safemode also ??
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

OldSoftwareAuthor Commented:
Yes, it happens in safe mode also.  It takes about 3-4 minutes to open the menu.

I counted over 20 choices. That seems excessive and some I certainly don't need. Guess I had never paid that much attention to them. One, as an example, is Browse with Paint Shop Pro 7. I don't need that for sure.
0
SheharyaarSaahilCommented:
hmmmm when u disconnect these machines from networking, same issue ??
this sometimes happens also when hard drive is highly fragmented or have bad clusters,,,, im sure its not the case with u :)

one last question(dont mind plzz)
u are the only user of ur system, or are there multiple users ??
if multiple then do others have same problem ??
and if single, then upon creating a new user and loggin with him,
do u encounter the same problem ?? :)
0
OldSoftwareAuthor Commented:
Network doesn't make a difference.

Drive are not fragmented.

Another userid has same problem.

ShellEx View doesn't show some of the items on the menu like "Browse with Paint Shop Pro 7" or "Bulk Rename". I also cannot find Jasac PSP on the Add/Remove programs.

0
SheharyaarSaahilCommented:
hmmmmm can u rememeber when this problem start happening ??
im asking coz i have just encountered a ditto same issue >> http://www.experts-exchange.com/Operating_Systems/WinXP/Q_21185381.html

so just thinking if its now casuing by any new malware or a windows update :-?
0
OldSoftwareAuthor Commented:
ShellEx is my problem.

I deleted several registry entries for ShellEx and everything seemed to work until I discovered that right clicking on START failed with the 4 minute wait. No problem, I thought, I'll use GoBack. Unfortunately, it only went back a couple of hours and didn't catch one of my deletes. Who knows which one since I was so sure that GoBack would restore my system.

Anyway, I think my solution was at:
http://www.tech-recipes.com/modules.php?name=Forums&file=viewtopic&t=358
and the module was ZFAdd that caused the problem.

My Explorer folders now work fine but the START menu right click fails and the OPEN option is gone.

Any suggestions on how to get it back?
0
SheharyaarSaahilCommented:
right click context menu entries are stored Per User..... so if u will create a new user, u will not have this problem there !!
then if u want u can export the context menu handlers registries from the new user to the old one using regedit !!
OR can move to the new user by moving ur data and settings to the new one >> http://support.microsoft.com/default.aspx?scid=kb;EN-US;811151

good luck :)
0
OldSoftwareAuthor Commented:
It will be a few days before I can try your suggestion. I'll let you know.
0
SheharyaarSaahilCommented:
not at all a porblem,,, take ur time, but just keep me informed... good luck :)
0
OldSoftwareAuthor Commented:
My problem is back. Deleting ZFAdd fixed it I thought but it didn't.

I tried ShellEx viewer and removed all that were not M$. I also tried logging on as a different user. Nothing has helped.

My ShellEx has:

[HKEY_CLASSES_ROOT\Folder\shellex\ContextMenuHandlers]

[HKEY_CLASSES_ROOT\Folder\shellex\ContextMenuHandlers\AVG Shell Extension]
@="{1E2CDF40-419B-11D2-A5A1-002018648BA7}"

[HKEY_CLASSES_ROOT\Folder\shellex\ContextMenuHandlers\WinZip]
@="{E0D79304-84BE-11CE-9641-444553540000}"

[HKEY_CLASSES_ROOT\Folder\shellex\ContextMenuHandlers\{969223c0-26aa-11d0-90ee-444553540000}]

[HKEY_CLASSES_ROOT\Folder\shellex\ContextMenuHandlers\{B9FAAF4F-DFFF-42a3-8FCE-FD36EDA387F6}]

Any suggestions?
0
SheharyaarSaahilCommented:
hmmmm this is ur old problem... means which was same for all users of the system ??
Did u create another user for solving the Startmenu right clcik problem,,, has it gone now ??

And those first two are for AVG and Winzip.... have u disabled them yet ??
and what are these two,

[HKEY_CLASSES_ROOT\Folder\shellex\ContextMenuHandlers\{969223c0-26aa-11d0-90ee-444553540000}]

[HKEY_CLASSES_ROOT\Folder\shellex\ContextMenuHandlers\{B9FAAF4F-DFFF-42a3-8FCE-FD36EDA387F6}]

I cannot recognise them, try backing them up first from the regedit, and then delete them one by one to check for the problem ??
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
OldSoftwareAuthor Commented:
HKCR\CLSID\{969223c0-26aa-11d0-90ee-444553540000}      "PGP Shell Extension"      
I don't know what {B9FAAF4F-DFFF-42a3-8FCE-FD36EDA387F6}] is. I put XX in front of each of them and will restart.

Using the Shellex prog. I disable all of them, restarted no luck.
0
SheharyaarSaahilCommented:
ZFAdd is by WinAce..... so have u yet tried uninstalling this program ??
and im not sure that if you have already mentioned it, but do u really have DivX installed or not :)
0
OldSoftwareAuthor Commented:
The system has been running just fine since I disabled the various progrs as you suggested. SheharyaarSaahil should get the points.
0
SheharyaarSaahilCommented:
good news.... :) but you can award the points yourself also..... :)
as you can see the Accept button infront of each comment which you got, you have to hit the button for that comment which solved your problem, and then assign a grade according to the quality of help you got,,, that's all :)
for more info. on how to close a Question, plzz refer here >> http://www.experts-exchange.com/help.jsp#hs5

Thanx & Cheers ^_^
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.