Solved

Cisco 1600/1750 can ping serial, but not ethernet

Posted on 2004-10-27
671 Views
Last Modified: 2008-02-01
I have a PTP T-1 between my office and a client.  I can ping the ethernet address on their side and they have internet traffic, but I can not ping directly from their router to the outside world.  I am also seeing several time out's when pinging their ethernet address.

The config on my side (1600 router):

interface Ethernet0
 description Local ethernet interface
 ip address 192.168.100.5 255.255.255.0
 no ip directed-broadcast
!
interface Serial1
 description point-to-point T
 ip address 192.168.255.1 255.255.255.252
 no ip directed-broadcast
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.100.1
ip route 199.224.122.104 255.255.255.248 192.168.255.2

On their side (Cisco 1750 router):

interface Serial0
 ip address 192.168.255.2 255.255.255.252
!
interface FastEthernet0
 ip address 199.224.122.105 255.255.255.248
 speed 100
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.255.1

All my traffic then passes to a 2600 series to the internet, in which
I have this statement:

ip route 199.224.122.104 255.255.255.248 192.168.100.5


When I telnet to their router I can not ping any address on my network.  I believe this might explain the delay they are seeing when trying to resolve any destination on their network.

Thank you!

0
Question by:scottparks
    11 Comments
     
    LVL 79

    Expert Comment

    by:lrmoore
    Post result of "show interface serial0" on the 1750
    I suspect it may be a timing issue on the circuit. You might have to provide clocking for the T1 on one end.
    You could also have a duplex mismatch on the LAN side of the 1750. You hard set the speed to 100 and that turns off the autonegotiation with the switch. If the switch that it is connected to is not managed, then suggest it be left on auto..
    0
     
    LVL 79

    Accepted Solution

    by:
    Also, add this to the 2600:
       ip route 192.168.255.0 255.255.255.0 192.168.100.5

    That would take care of pinging from the router and to/from the serial ip..

    0
     

    Author Comment

    by:scottparks
    Here is the result of :  show interface serial0:

    Serial0 is up, line protocol is up
      Hardware is PQUICC with Fractional T1 CSU/DSU
      Internet address is 192.168.255.2/30
      MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation HDLC, loopback not set
      Keepalive set (10 sec)
      Last input 00:00:00, output 00:00:00, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 3
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops)
         Conversations  0/13/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
      5 minute input rate 0 bits/sec, 1 packets/sec
      5 minute output rate 1000 bits/sec, 2 packets/sec
         791888 packets input, 587066085 bytes, 0 no buffer
         Received 12759 broadcasts, 0 runts, 0 giants, 0 throttles
         1780 input errors, 606 CRC, 1120 frame, 0 overrun, 0 ignored, 53 abort
         714762 packets output, 206578507 bytes, 0 underruns
         0 output errors, 0 collisions, 2 interface resets
         0 output buffer failures, 0 output buffers swapped out
         3 carrier transitions
         DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    > 1780 input errors, 606 CRC, 1120 frame, 0 overrun, 0 ignored, 53 abort

    Appears to be a lot of errors. These do indicated, as I suspected, a potential timeing issue.
    on your end, assuming you are using the same WIC-T1 DSU:

    interface serial 1
      service-module t1 clock source internal
      clock rate 2000000

    Then clear the counters on both ends and see if the errors go away.

    Clear counters:  rotuer#clear counters interface serial0


    0
     
    LVL 5

    Expert Comment

    by:epylko
    Something needs to be doing NAT for 192.168.100.0/24. Who is doing that? Are you sure it's working correctly?

    -Eric
    0
     

    Author Comment

    by:scottparks
    Cleared the counters after setting up the clock source on the serial interface and the errors have stopped, I will not know for sure until people in the office start using it again tomorrow, but here is the last 5 minute snap shot:

    Serial1 is up, line protocol is up
      Hardware is QUICC Serial (with FT1 CSU/DSU WIC)
      Description: point-to-point Berkshire SGI
      Internet address is 192.168.255.1/30
      MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
      Encapsulation HDLC, loopback not set, keepalive set (10 sec)
      Last input 00:00:03, output 00:00:01, output hang never
      Last clearing of "show interface" counters 00:05:59
      Input queue: 0/75/0 (size/max/drops); Total output drops: 0
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops)
         Conversations  0/16/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         282 packets input, 30635 bytes, 0 no buffer
         Received 48 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         267 packets output, 15471 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 output buffer failures, 0 output buffers swapped out
         0 carrier transitions
         DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
    0
     
    LVL 5

    Expert Comment

    by:AutoSponge
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.100.1
    ip route 199.224.122.104 255.255.255.248 192.168.255.2

    Change this last statement to
    ip route 199.224.122.104 255.255.255.248 Serial1

    and see if performance increases.  I don't like using another router's address (even when connected) in a static route statement.
    0
     

    Author Comment

    by:scottparks
    Darn it, the errors are back......

    Serial1 is up, line protocol is up
      Hardware is QUICC Serial (with FT1 CSU/DSU WIC)
      Description: point-to-point Berkshire SGI
      Internet address is 192.168.255.1/30
      MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
      Encapsulation HDLC, loopback not set, keepalive set (10 sec)
      Last input 00:00:00, output 00:00:07, output hang never
      Last clearing of "show interface" counters 02:47:04
      Input queue: 3/75/0 (size/max/drops); Total output drops: 0
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops)
         Conversations  0/16/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         2511 packets input, 225224 bytes, 0 no buffer
         Received 1327 broadcasts, 0 runts, 0 giants, 0 throttles
         238 input errors, 232 CRC, 6 frame, 0 overrun, 0 ignored, 0 abort
         2252 packets output, 199419 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 output buffer failures, 0 output buffers swapped out
         0 carrier transitions
         DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
    0
     

    Author Comment

    by:scottparks
    This is the remote side (serial on the clients router):

    Serial0 is up, line protocol is up
      Hardware is PQUICC with Fractional T1 CSU/DSU
      Internet address is 192.168.255.2/30
      MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation HDLC, loopback not set
      Keepalive set (10 sec)
      Last input 00:00:00, output 00:00:00, output hang never
      Last clearing of "show interface" counters 02:48:09
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops)
         Conversations  0/13/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
      5 minute input rate 0 bits/sec, 1 packets/sec
      5 minute output rate 1000 bits/sec, 1 packets/sec
         2288 packets input, 202148 bytes, 0 no buffer
         Received 1186 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         2545 packets output, 229861 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 output buffer failures, 0 output buffers swapped out
         0 carrier transitions
         DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
    0
     
    LVL 5

    Expert Comment

    by:AutoSponge
    First, call your provider to check PMs (performance monitors) in the direction of the site taking errors.  If you have an external CSU or a T1 controller card, check the error counts to see what type of errors you're seeing at the line level or frame level.  This can help troubleshoot them.

    Next, have your provider perform a stress test (at least 2 hours of patterns) to your CSU and SJ from the furthest point they have test access.  This may help isolate where the errors are coming from.  If the test shows that they took errors to the CSU but none to the smartjack, have them test again and this time put a T1 loopback plug at the dmarc instead of your equipment.  If they test with no errors, the problem is in your wiring or the CSU itself--otherwise it will force a dispatch and further troubleshooting or the SJ replacement.
    0
     
    LVL 11

    Expert Comment

    by:PennGwyn
    You've got two routers on your local LAN which go to different places.  Odds are good that your clients are pointing at one as their default gateway, and it's redirecting to the other as necessary.  Make sure to set "no ip redirects" on the LAN interfaces -- most clients will ignore redirects, but they'll chew up some bandwidth, and clients who *do* listen may get confused.

    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How to improve team productivity

    Quip adds documents, spreadsheets, and tasklists to your Slack experience
    - Elevate ideas to Quip docs
    - Share Quip docs in Slack
    - Get notified of changes to your docs
    - Available on iOS/Android/Desktop/Web
    - Online/Offline

    Suggested Solutions

    New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
    Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
    After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    884 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now