Wireless router setup in an existing network.

I have a network 192.168.0.1 that i just added a wireless router in. The wireless router is 10.0.0.1. I can access my 192.168.0.1 network from the wireless fine, but how can i access  the computers on the wireless network? Say for file and printer sharing or websites on those machines?
LVL 2
djohnson104Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

merowingerCommented:
you have to configure routes
mero
0
djohnson104Author Commented:
satic routes?
dynamic routes?
Im not really sure how.
0
TannerManCommented:
You need to have a route added to either your router or your Server (acting as the default gateway) of the following.......Just see what your network is using for the default gateway and that'll answer router vs. server

route add 10.0.0.0 mask 255.255.255.0 192.168.0.? -p

Now this is the format for adding it to a server from the command prompt.
Assumptions....that your on a network mask of 255.255.255.0. If not then change it above.
Replace the ? with the IP your wireless router has assigned for the 192.168.0.x network.

The syntax above is NOT for routers, just server.
If you want to test this without editing router or server, then go to a client and run the above command, BUT leave off the "-p".
The "-p" (persistent) just means to leave the route in your machine's route table after a reboot or disabling/re-enabling of your network card.

This tells anyone on subnet 192.168.0.x looking for anything on 10.0.0.x to got to the wireless device for access.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

CBozemanCommented:
Besides adding routes, you also need to check that the wireless router is _not_ performing NAT.  If it is doing NAT like you would have in an Internet router situation, the 192.168.0.x network will never see anything in the 10.0.0.x network.

Make sure NAT is turned off on the wireless router.

In addition to TannerMan's notes, if your default gateway for the 192.168.0.x network is another router (as opposed to a windows server like TannerMan assumes) most routers have a static routing table you can make a new entry into for the 10.0.0.x network.

CBozeman
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TannerManCommented:
CBozeman just to clairfy this was working fine till he replaced a 100mb switch with a gigbit switch and the asscoiated NIC's. However, good thing to mention in case he made changes to his wreless router. Machine PCA is able to go to internet, even though it is slow, so I think the wireless router setup is good to go.
0
djohnson104Author Commented:
I replaced a 100mb switch with a  gigbit switch? Im lost
0
CBozemanCommented:
I'm lost, too.

djohnson104, was the wireless router running NAT?

CBozeman
0
djohnson104Author Commented:
I follow you cbozwman, i believe it is. Can you disable nat on most cable dsl routers?
0
CBozemanCommented:
Yes, most routers have the option to disable NAT.  I've also seen it as "Single User Account: Yes/No", in which case you would choose no.

What is acting as your router in the 192.168.0.x network? another cable/dsl router?

CBozeman
0
djohnson104Author Commented:
well our 192.168.0.x network has a pix firewall that everyone connects to 192.168.0.1 and then that connects to the internet. so 192.168.0.1 is our gateway.  For our wireless its just a netgear wireless router for home use. It gets it ip from dhcp and then behind that are the 10.0.0.1. So what im gatering i need to put a static route on the 192.168.0.1 that will poing all 10.0.0.1 traffic to the wireless router.
0
TannerManCommented:
GUYS,,,my apologies. I thought I was answering another post. SO SORRY. Just slap me and call me stupid.
0
IanThCommented:
surely though  that route will be created in the router so you wouldn't need to do it in the pc's thats what a router does
0
IanThCommented:
actually just thought
 how is your routers wan nic setup

as as that should really have 192.168.0.1 as its gateway
0
CBozemanCommented:
Yes, make sure nat is off on the netgear router, then place a route in the 192.168.0.1, like
ip route 10.0.0.0 255.255.255.0 192.168.0.?, where 192.168.0.? is the WAN ip of the netgear.  You will need to change the netgear WAN ip to a static IP.

CBozeman
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Protocols

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.