Connecting Two LANs Over PPP leased line

We would like to share data from the server at the main location with the remote location and let the DHCP server at the main location assign IPs to the remote location. Here is a list of what we have.

Main Location has 3 T1s (Internet, Phone, PPP)
Remote locaion 1 T1 (PPP)
Connectivity between locations by 2 Cisco 1721 routers on the PPP line.

We are able to connect to the internet from the remote location but we are unable to share files or have the DHCP server assign IPs to the remote location.  The we also use the PPP line for VoIP at the remote location and it works fine.

Here is the info from each router

Current configuration : 702 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname MainOffice
!
enable secret 5 $1$9IKq$HVRGNfX.fVFkfnbtzsMKr.
enable password l3tm3in
!
memory-size iomem 25
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface FastEthernet0
 ip address 172.22.1.2 255.255.255.0
 speed auto
!
interface Serial0
 ip address 10.0.1.1 255.255.255.0
!
ip classless
ip forward-protocol udp 135
ip route 0.0.0.0 0.0.0.0 172.22.1.1 permanent
ip route 0.0.0.0 0.0.0.0 FastEthernet0 permanent
ip route 192.168.11.0 255.255.255.0 Serial0 permanent
no ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 password l3tm3in
 login
!
no scheduler allocate
end



Current configuration : 880 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Remote1
!
enable secret 5 $1$EjrF$59HfRCah2WhR941gxGPdj1
!
memory-size iomem 25
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface FastEthernet0
 description connected to EthernetLAN
 ip address 192.168.11.1 255.255.255.0
 ip helper-address 172.22.1.250
 speed auto
!
interface Serial0
 description connected to Internet
 ip address 10.0.1.2 255.255.255.0
 service-module t1 remote-alarm-enable
!
router rip
 version 2
 passive-interface Serial0
 network 192.168.11.0
 no auto-summary
!
ip classless
ip forward-protocol udp 135
ip route 0.0.0.0 0.0.0.0 Serial0 permanent
no ip http server
!
!
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
 password l3tm3in
 login
line aux 0
line vty 0 4
 password l3tm3in
 login
!
no scheduler allocate
end

Thanks
pcsonwheelsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

freakyunoCommented:
This is kind of a complicated solution.  Before I get into it to thick, are you a member of the IT department allowed to make router config changes, and have admin access to your network?

Are you comfortable with the Cisco OS, and are you at the main location or the remote location?
0
pcsonwheelsAuthor Commented:
Yes I have control over all routers and I am fairly comfortable with the Cisco OS.
Thanks
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

lrmooreCommented:
>We are able to connect to the internet from the remote location but we are unable to share files or have the DHCP server assign IPs to the remote location.  
Once you establish layer 3 connectivity, which is proven by the internet access, then the issues must lie with
1) DHCP server. Do you have a scope set up and activated for the 192.168.11.0 subnet?
2) name resolution and permissions within the Microsoft network will control the ability to share/see files accross the network.

Can you post result of "show interface serial 0" from both ends. I'm looking for the error counts. Since neither end appears to be providing the T1 clocking, you may have a lot of errors that affect the nebios broadcasts..
0
pcsonwheelsAuthor Commented:
Here are the rusults of "show interface serial 0"


MainOffice#show interfaces serial 0
Serial0 is up, line protocol is up
  Hardware is PQUICC with Fractional T1 CSU/DSU
  Internet address is 10.0.1.1/24
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 178/255, txload 8/255, rxload 3/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 141
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/9/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 24000 bits/sec, 40 packets/sec
  5 minute output rate 54000 bits/sec, 40 packets/sec
     18726310 packets input, 1811155167 bytes, 0 no buffer
     Received 587264 broadcasts, 8 runts, 694439 giants, 0 throttles
     354910633 input errors, 45299041 CRC, 299242354 frame, 0 overrun, 0 ignored
, 10369238 abort
     17940881 packets output, 3899477795 bytes, 0 underruns
     0 output errors, 0 collisions, 140 interface resets
     0 output buffer failures, 0 output buffers swapped out
     231 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

MainOffice#



Remote1#show interfaces serial 0
Serial0 is up, line protocol is up
  Hardware is PQUICC with Fractional T1 CSU/DSU
  Description: connected to Internet
  Internet address is 10.0.1.2/24
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 156/255, txload 3/255, rxload 8/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 142
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/26/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 51000 bits/sec, 37 packets/sec
  5 minute output rate 21000 bits/sec, 39 packets/sec
     16558248 packets input, 3651508595 bytes, 0 no buffer
     Received 499911 broadcasts, 0 runts, 4823 giants, 0 throttles
     216843448 input errors, 9196168 CRC, 206907860 frame, 0 overrun, 0 ignored,
 739420 abort
     17720463 packets output, 1733170168 bytes, 0 underruns
     0 output errors, 0 collisions, 129 interface resets
     0 output buffer failures, 0 output buffers swapped out
     7 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Remote1#
0
lrmooreCommented:
HUGE error count, as I suspected.. this will have a big impact on the netbios stuff..

>    354910633 input errors, 45299041 CRC, 299242354 frame, 0 overrun, 0 ignored
, 10369238 abort

Suggest setting the clock source to be the MO side..
  interface serial 0
    service-module t1 clock source internal
    clock rate 2000000
0
lrmooreCommented:
After you do that, clear the interface counters and then monitor for a while..
0
pcsonwheelsAuthor Commented:
I will be out of the office for a few hours and I will monitor when I get back
Thanks
0
pcsonwheelsAuthor Commented:
Once I set the clock source on the MainOffice side we lost communication with router on the Remote side.  I needed to remove

service-module t1 clock source internal

from the serial 0 interface to regain communication between the two routers.
0
lrmooreCommented:
You might lose contact for a brief period, but it should come right back up.
You might want to call your telco provider and verify with them whether or not you need to provide the clocking on one end. Else, report to them the high number of CRC and frame errors on the circuit and don't let them off the hook without being able to run clean..
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pcsonwheelsAuthor Commented:
Thanks,
I have contacted the telco and they are checking their cable, then I will check if I need to provide the clocking.  THis should be done Tonight.  Then we will see if the errors go away.
0
pcsonwheelsAuthor Commented:
I guess the telco could not make it out before the weekend so I will wait a little longer.  But I have another question.  I can telnet into the Main office router from the server once in telnet I can ping the server, ping the remote route, ping any computer on either the main or the remote lan but if I telnet from inside the telnet of the main souter to the remote router I can only ping the remote computers, the remote router and the main router.  I can not ping any computers on the mair lan or gateway from there.  Any idea why?

Thanks
0
lrmooreCommented:
My guess would be routing issues to the serial interface subnet. Their main gateway does not know about your 10.0.1.2 serial link IP subnet..
0
pcsonwheelsAuthor Commented:
I can ping 10.0.1.2 from telnet on the Main router.  Do I need to add a permanent ip configration on the main router to 10.0.1.2?

Thanks
0
pcsonwheelsAuthor Commented:
The telco tested the line and said that all errors are coming from the routers and not the line.  THey said that one of the routers needed to be the clock source and the other needed to be the clock source to be the line.  I have tried it in every way I can think of and the routers are only able to communicate if both are setup with the clock source as the line.  I have switched them from HDLC to PPP change the clock rate but I have no serial communications with either router set with clock source Internal.  Any idea!!!
Thanks
0
lrmooreCommented:
Try making the one at the main office the clock source again, the "bounce" the interface with "shut" wait 30 sec, "no shut"
also, try a different clock rate. use  clock rate ? to see what your options are and choose something closer to T1 speed of 1500000
0
pcsonwheelsAuthor Commented:
The same outcome.  I bounced the main office router 5 time in an 8 minute period and changed the clock rate to 1300000.  I took the main office clock source back to line and it connected immediaely.  The t1 line is direct from the main location to the remote location with nothing else inbetween.  I think I need to take a vacation.
0
pcsonwheelsAuthor Commented:
The olny thinh I can think of is a bad WIC card.  Hopefully it will equaite.
0
pcsonwheelsAuthor Commented:
The IP helper command now works on the remote router and I can ping from one lan to the other.  I modified the Routing table on the server which opened up the communications between routers.  I am still unable to share files between lans and I can only get the routers to communicate if both are set to clock source line.  If either one is switched to internal the communications stop.  I still a huge amount of errors on the serial port.  Any ideas.
Thanks
0
pcsonwheelsAuthor Commented:
The telco could not find what was causing the problem but they started supplying the clock and all errors went away.  I tried two different routers at each end with the same outcome so it does not appear to be a router issue but now the errors are gone and the connection is up to speed.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.