Hit Counter didn't show up on the page(W2k3 server)

Hi,

I want to add a Hit Counter to my web site(on W2K3 server). But after I added a hit counter by FrontPage, it didn't show up on the web page. I have removed Front Page Extension couple times and reinstalled it but still doesn't work.

Thanks.
mrongAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rcmbCommented:
Is the page with the hit counter in the root folder of your website? The problem is prbably related to the path to the hit counter. What displays where the hit counter should be?
0
mrongAuthor Commented:
Hi rcmb,

The page with the hit counter is in the root of my web site.
It displays "Hi Counter" with no image at where the hit counter suppose to display.

Thanks.
0
rcmbCommented:
Check your web permissions and ensure everyone has browse access.

RCMB
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

rcmbCommented:
Another point I forgot to ask is are you viewing the site from a web server or from a disked-based web? Hit counters must be fetched from a web server in order to work properly. If you are just testing this on a local machine it will not function.

RCMB
0
mrongAuthor Commented:
RCMD,

I view it from a web server. When you say 'browse access', do you mean the file? The file can be browsed.

Thanks.
0
rcmbCommented:
On your site permissions (tools, server, permissions) make sure everyone has browse access.
0
mrongAuthor Commented:
Do you mean from IIS or folder permisson?

Thanks.
0
rcmbCommented:
From FrontPage.

RCMB
0
mrongAuthor Commented:
Hi RCMB,

I never did it from FrontPage. Could you please give me more details?
Thanks a lot.

0
rcmbCommented:
Open your site in FrontPage and click on Tools, Server, Permissions

Set the group Everyone to browse.

RCMB
0
mrongAuthor Commented:
I have FrontPage2002 and I didn't see Server,Permission from Tools.
I use FrontPage to open the file from a remote workstation.( I mapped the drive(web server) from remote computer )

Thanks.
0
rcmbCommented:
I have FP2002 installed as well. Have you clicked on the two down arrows to expand the menu? Is it grayed out?

RCMB
0
mrongAuthor Commented:
Ok. I have server there but it is disabled and I can click on it.
0
rcmbCommented:
Okay -- so we clear things up -- Not displaying a hit counter is normally only related to two items:

1. Permissions are not set correctly
2. Server Extensions are not installed or not installed correctly.

If you are opening your website from the server - which based on your indications you are not doing. It appears to me you are opening the site from a drive letter vice http://servername. This will prohibit things from working correctly as the site now points to some drive letter vice the actual server. Permissions are different now because the anonymous access account does not have access to the drive letter the site is pointing to.

Open your site via http vice a drive letter. Go to File, Open Site and enter http://servername or ip address of the server. This should open your site and allow you to edit as normal.

Editing a website via a mapped drive is a bad thing as it will tend to relate things to the drive letter vice the actual root web.

RCMB
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.