Solved

Linux WS9 can't connect to the Internet.

Posted on 2004-10-28
225 Views
Last Modified: 2013-12-15
Hail and well met, I have a linux problem. I just recently moved office. Everything is up and running except for our Linux box. Linux WS9. I appologies now for my lack of knoledge in Linux. We use a static IP (Which works when inputed in a windows box) but I cant seem to get the Linux box back online.

I did some reading and I was asked to do a ipconfig (ifconfig), I did and it seems like its up, I see a UP BROADCAST in there. I have looked at the DNS entry and it is correct, basically no settings were changed since the move and the ISP didnt change anything so in theory I should be up and running.

Cant Ping or tracert

Can ping 172.0.0.1 and the static IP the box is using.

Please help, im loosing my mind :)


Best Regards

Chinawhite
0
Question by:chinaw
    13 Comments
     
    LVL 6

    Expert Comment

    by:blkline
    Reboot the machine, then post the results of the following commands (as root):

    route -n
    ifconfig
    cat /etc/sysconfig/network
    cat /etc/sysconfig/ifcfg-eth0
    cat /etc/hosts
    cat /etc/resolv.conf

    0
     
    LVL 6

    Expert Comment

    by:blkline
    Sorry, this one:

    cat /etc/sysconfig/ifcfg-eth0

    should read:

    cat /etc/sysconfig/network-scripts/ifcfg-eth0
    0
     

    Author Comment

    by:chinaw
    Dear blkline

    1. route -n
    2. ifconfig
    3. cat /etc/sysconfig/network
    4. cat /etc/sysconfig/ifcfg-eth0
    5. cat /etc/hosts
    6. cat /etc/resolv.conf


    1.
    Kernel IP Routing Table
    Destination          Gateway          Genmask            Flags   Metric   Ref     Use   Iface
    xx.xxx.xxx.xx        0.0.0.0            xxx.xxx.xxx.xxx    U         0          0           0   eth0
    169.254.0.0         0.0.0.0            255.255.0.0        U         0          0           0   eth0

    2.
    eth0       Link encap:Ethernet    HWaddr  00:06:5B:DD:1E:97
                 inet addr:xx.xxx.xxx.xxx   Bcast:xx.xxx.xxx.xxx   Mask:xxx.xxx.xxx.xxx
                 UP BROADCAST RUNNING MULTICAST  MTU:1500   Metric:1
                 RX packets:551 errors:0 dropped:0 overruns:1 frame:0
                 TX packets:54 errors:0 dropped:0 overruns:0 carrier:0
                 collisions:0 txqueuelen:1000
                 RX bytes:42397 (41.4kb)   TX bytes:7447  (7.2kb)
                 Interrupt:11 Base address:0xdc80

    lo          Link encap:Local Loopback
                 inet addr:127.0.0.1  Mask:255.0.0.0
                 UP LOOPBACK RUNNING   MTU:16436   Metric:1
                 RX packets:661 errors:0 dropped:0 overruns:0 frame:0
                 TX packets:661 errors:0 dropped:0 overruns:0 carrier:0
                 collisions:0 txqueuelen:0
                 RX bytes:64232 (62.7kb)   TX bytes:64232  (62.7kb)

    3.
    NETWORKING=yes
    HOSTNAME=localhost.localdomain

    4.
    cat: /etc/sysconfig/ifcfg-eth0/; No such file or directory

    5.
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1         localhost.localdomain      localhost

    6.
    search localdomain
    nameserver xx.xxx.xx.xx
    nameserver xx.xx.xxx.xxx

    (Sorry to keep some numbers from you, i hope i dont offend. Where the "x" are the correct numbers as per the spec sheet from the ISP.)



    0
     
    LVL 6

    Expert Comment

    by:blkline
    You're missing a gateway entry:

    route add default gw xxx.xxx.xxx.xxx

    That needs to be added to:

    /etc/sysconfig/network
    0
     
    LVL 6

    Accepted Solution

    by:
    Acutally, you'll add:

    GATEWAY=xxx.xxx.xxx.xxx

    to your /etc/sysconfig/network
    0
     

    Author Comment

    by:chinaw
    cat /etc/sysconfig/network-scripts/ifcfg-eth0

    # 3com Corporation|3c905c-TX/TX-M [Tornado]
    DEVICE=eth0
    BOOTPROTO=none
    HWADDR=00:06:5b:dd:1e:97
    ONBOOT=yes
    TYPE=Ethernet
    USERCTL=no
    PEERDNS=no
    NETMASK=xxx.xxx.xxx.xxx
    IPADDR=xx.xxx.xxx.xxx
    GATEWAY=xx.xxx.xxx.xxx
    0
     
    LVL 6

    Expert Comment

    by:blkline
    and what I wanted to see is:

    cat /etc/sysconfig/network-scripts/ifcfg-eth0

    0
     

    Author Comment

    by:chinaw
    added the GATEWAY=xx.xxx.xxx.xxx to the /etc/sysconfig/network and rebooted but still cannot connect.

    I try to lo'g on to www.eperts-exchange.com and i get the follwoing message   "www.eperts-exchange.com could not be found. Please check the name and try again.

    0
     
    LVL 6

    Expert Comment

    by:blkline
    what if you type:

    route add default gw (your gateway address)

    Then try again.   If it fails then please post:

    route -n

    Also, go to one of your windows boxes and at a command line type:

    ipconfig /all

    and post that.  I want to ensure that you are indeed using the correct address for the gateway.
    0
     

    Author Comment

    by:chinaw
    The gateway is 100% correct.

    when i do route add default gw xx.xxx.xxx.xxx   it says  SIOCADDRT:  Network is unreacheable


    when i do route -n

    Kernel IP Routing Table
    Destination          Gateway          Genmask            Flags   Metric   Ref     Use   Iface
    xx.xxx.xxx.xx        0.0.0.0            xxx.xxx.xxx.xxx    U         0          0           0   eth0
    169.254.0.0         0.0.0.0            255.255.0.0        U         0          0           0   eth0


    0
     

    Author Comment

    by:chinaw
    in network configuration i have 4 profiles. 1 is active and the rest are inactive. they have all the same settings. nicknames are eth0 (active) eth0/;1, eth0:2, eth0:3 (inactive)
    0
     

    Author Comment

    by:chinaw
    when i use text edit to edit the /etc/sysconfig/network in the open file window i see 2 network files, one is called network and the other is called network~
    0
     
    LVL 6

    Expert Comment

    by:blkline
    The file with "~' at the end is a backup copy of the original.  Does network~ contain something other than network?

    If it says "Network is unreachable" then the gateway is on another network.  I'm not sure I can help you unless you give me the more information about your network.  If you don't want to post them here then send them to my email address:

    blkline at attglobal dot net

    Run all of those commands I gave earlier and send them to me.  I'll post my comments back here but will sanitize the addresses in anything I post to here.

    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
    Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
    Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
    Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

    856 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now