Format huge drive.

I have a winchester WD2500 dive on my system running XPpro.. System has a motherboard  called P4P800-E. How can I format this drive as I get a max of 128GB on this drive only. Is there a utility?
LVL 1
PawloAAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lbertaccoCommented:
You need Windows XP at least SP1 (better SP2). The atapi driver included with the original (pre SP1) WIndows XP doesn't support LBA 48 addressing (which is necessary for hard drives larger than 128GB).
So just download the service pack and apply it. After that you should manage to repartition the harddrive and see it all.
0
PawloAAuthor Commented:
I did upload SP1 and it did not work. The system still sees only 128 GB on this drive. I know it should work because I did my MAXTOR 200GB drive previously. (I may have used the maxtor utility). Is there a utility that can recognize and format a drive > 128GB?
0
lbertaccoCommented:
Can you provide more details please?

- did you have sp1 installed previously or have you just installed it? In other words: when you have installed the HD, did you already have SP1 installed or did you install SP1 AFTER mounting the HD? (in this second case, you just need to repartition the HD)
- the 200gb previous HD was mounted on the same motherboard you are using now? (just to be sure that your MB supports LBA48)
- is this WD2500 drive your only HD or do you have others mountes? Which one is the primary one (with Windows XP) ?
- when you go to (right click)My Computer->manage->disk manegement you see both the HD and its partitions. Do you see both the disk and the partition as 128GB or the disk as 250GB and the partition as 128GB?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

unreal400Commented:
There is a simple registry fix that will stop this from happening.

open regedit
go to
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\parameters

add the following registry value
valuename:EnableBigLba
Datatype:REG_DWORD
value:1

I had the same problem with my 200GB western Digitals  and this fix my problems

-Kelly
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lbertaccoCommented:
This microsoft support document (http://support.microsoft.com/default.aspx?scid=kb;en-us;303013) says that the "registry fix" is not needed on Sp1 and Sp2 (it's actually IGNORED since on SP1/SP2 LBA48 addressing is always enabled). It's required only on original Windows XP not yet patched
0
PawloAAuthor Commented:
Could this have been a problem I have had with files disappearing and errors going into a folder then trying to delete it afterwards and the disk consistancy checks?
0
lbertaccoCommented:
It could it you didn't have at least sp1
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Desktops

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.