Setting up username and password to use BT as a smart host

I have set up exchange 2003 and we are using our server as a smart host (ie the mail is coming from our server) we now need to use the customers ISP ie BT as a smart host I have contacted BT and they have said that they have set it up to use there servers and gave me a username and password and the DNS name of the servers as mail.btconnect.com I know to put this in the smtp connector forward all mail through this connector to the following smart hosts but i cant seem to get the username and passsowrd to work i am not 100% sure where to put it and BT got a bit vague at this point .

so frstly where does the username and password go and is there a way to check that bt have set there end up correctly

our server is going down today and im in stuck !!!
LVL 1
irileyAsked:
Who is Participating?
 
SembeeCommented:
If you have configured the SMART HOST on the SMTP Virtual server, remove it. That should be left blank.
Create an SMTP Connector to send email via the BT server.
http://www.amset.info/exchange/smtp-connector.asp

Once created, click on the "Advanced" tab of the connector, then "Outbound Security". Change it from anonymous to Basic authentication. Click modify to enter the required username and password (one provided by BT).
Don't use integrated windows authentication, the server cannot understand that.

Simon.
0
 
scampgbCommented:
Hi iriley,
Go into the SMTP connector properties in Exchange System Manager
Advanced Tab

Click "Outbound security"

Choose "Basic Authentication" and use the Modify button to supply the username & password.

That should then work.

Does that help?
0
 
irileyAuthor Commented:
I have already tried this in the past I suspect BT have given me the incorrect username and password as nothing was sent from the mail server however I must admit I didnt set up relaying smart host a guy who has left did and on looking both the virtual and the smtp connector piont to the relay server ( old one i want to change to BT  ) I have run dnsstuff.com and found that the mail server is no longer blacklisted ( previously due to someone setting it up as an open relay (oops)) so until the weekend i have removed smart hosts and tested all seems fine to ie hotmail acct and tiscali acct with correct mail server address just hope the relaying ie no open relay is off as i have checked both the smtp connector and virtual server are allowing relaying for the domain ie ecrmpeople.com  thanks for your help I will lookinto this at the weekend as I dont want mail downtime.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.