Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Autoconfiguration Enabled

Posted on 2004-10-29
9
Medium Priority
?
2,338 Views
Last Modified: 2011-08-18
I have a computer that had massive amounts of popups. I ran a program from lava soft which removed them all. Now I can't get connected to the network. When I run from cmd prompt ipconfig /all I have autoconfiguration enabled and I can't do a release, renew. Is there someway to disable this so that I can once again get to the DHCP server? I hate to reimage this PC I'd really like to know what to do in this instance because I'm afraid with all the popup ads out there I'll be reimaging until the world ends. Thanks a bunch
0
Comment
Question by:Toninmd
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 10

Expert Comment

by:NetworkArchitek
ID: 12443239
Hi Toninmd,
What error do you get when you do a "ipconfig /renew" ?

Cheers!
0
 

Author Comment

by:Toninmd
ID: 12443251
All adapters bound to DHCP do not have DHCP addresses. The addresses were automatically configured and can not be released.
0
 
LVL 9

Expert Comment

by:SirtenKen
ID: 12443327
http://www.petri.co.il/disable_apipa_in_windows_2000_xp_2003.htm
shows the reg entry for disabling Automatic Private IP addressing.
it is under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\adapter_name

To fix your problem, though, I recommend reinstalling your TCP/IP protocol.
Reinstall of TCP/IP using the nettcpip.inf file (usually located in the c:\windows\inf directory) is covered by:
http://www.experts-exchange.com/Operating_Systems/WinXP/Q_20966809.html

If no joy, run "sfc /scannow" from a command line (have your xp disk on hand).
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 3

Expert Comment

by:cmsJustin
ID: 12443328
It's probably corrupt, Ad-Aware can damage programs sometimes when it cleans.
Try uninstalling TCP/IP, restart your computer, and then reinstalling it.
Maybe do the driver for the NIC at the same time while your at it.

Make sure you have the driver on your hard disk and the Windows CD before you uninstall them.

I had a similar problem when I copied a partition that was in use, the tcp/ip driver became corrupt.

-Justin
0
 
LVL 2

Expert Comment

by:virtuoso1
ID: 12443375
You may have a corrupted TCP/IP stack.  If that is the case, there is a command that resets it and is sometimes successful:

Open a command prompt window and type:

netsh int ip reset c:\logfile.txt (c:\logfile.txt being the location of the logfile that is written after the tcp/ip stack is reset)

Two keys will be rewritten:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters and HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DHCP\Parameters

I have seen the automatic private ip address in use when adware/spyware has hyjacked a machine.  Try removing as much as possible using Hyjackthis, and Spysweeper, which can be found:  http://www.spychecker.com -- under download antispy tools.  Get as much as possible, then do a system restore to an earlier date.  Also, spyware can hyjack your machine, and if you try to forcefully remove it without uninstalling it in add/remove programs, can corrupt your TCP/IP stack beyond repair.

If this doesnt work, you can do an in place upgrade without "reimaging."  Boot to the windows os cdrom, such as xp.  What OS are you running?  Assuming its XP, select the option to install windows xp, accept the liscence, then run a repair on the partition.  After the in place upgrade is finish, make when you boot up that you enable ICF, if this is on xp.  Make sure you have a firewall up on other OS's.  Then immediately run all of the critical updates for windows xp.





0
 

Author Comment

by:Toninmd
ID: 12443455
I forgot to say, this is a Windows 2000 system
0
 
LVL 6

Accepted Solution

by:
vand earned 2000 total points
ID: 12444452
Sounds like you winsock.

Follow this link.

http://www.softpedia.com/public/cat/13/9/13-9-161.shtml

This ones for XP, but, it's worth a try.

Alternately, you may follow these steps to rebuild your Winsock manually:
1) Go to Control Panel | Internet Options | Connections | LAN Settings and clear all of the boxes.
2) Re-create the Winsock2 registry entries:
a. Un-install ICS (if installed).
b. Un-install Dial-Up Networking. Do NOT reboot.
c. Delete registry key HLM\System\CurrentControlSet\Services\Winsock2
d. Re-install Dial-Up Networking. Reboot.
e. Re-install ICS (if desired).

A new command to repair this Winsock corruption problem is also available for users of Windows XP who have Service Pack 2 installed:

1) click Start, click Run and type CMD and click OK.
2) At the command prompt type: netsh winsock reset catalog (and press Enter)
3) At the command prompt type: Exit (and press Enter)
0
 
LVL 6

Expert Comment

by:vand
ID: 12444467
0
 

Author Comment

by:Toninmd
ID: 12444669
Thank you so much Vand. Downloading that winsock program did the trick. WOOHOO!!
0

Featured Post

Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For many of us, the  holiday season kindles the natural urge to give back to our friends, family members and communities. While it's easy for friends to notice the impact of such deeds, understanding the contributions of businesses and enterprises i…
WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question