Solved

Cisco PIX 515e Config Question

Posted on 2004-10-29
500 Views
Last Modified: 2013-11-16
I have a cisco pix 515e that I am having to work on.  I am using the PDM v2.1 because the telnet side has a password that no one knows.  anyways, my problem is that every time I create a rule to map all incoming HTTPS traffic into the firewall to IP 192.168.10.10 it gets changed to a "NULL" rule after I apply it.  I have already setup the Translation rules, and the host/network entry is there.

I'm very frustrated at this because I can't quite figure it out.

any help would be greatly appreciated.

L
0
Question by:Logicusa
    8 Comments
     
    LVL 79

    Expert Comment

    by:lrmoore
    If you show the config, are there conduits created? If yes, conduits appear as "null" rule in the GUI, but they still work.
    If you can get to the GUI, you can change the telnet password from the config | Admin section...
    0
     

    Author Comment

    by:Logicusa
    The gui wants the old password and will not let me change the telnet password
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Oh, yeah... darn user-friendly interfaces..
    Use the command line feature of the GUI and just change it there:
      passwd <new password>

    0
     

    Author Comment

    by:Logicusa
    Ok... i figured out the password.  Here is my config


    Consolidated1# write terminal
    Building configuration...
    : Saved
    :
    PIX Version 6.2(2)
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    nameif ethernet2 dmz security50
    enable password jWoctGhjCq96ctg3 encrypted
    passwd jWoctGhjCq96ctg3 encrypted
    hostname Consolidated1
    domain-name ciscopix.com
    fixup protocol ftp 21
    fixup protocol http 80
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol ils 389
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol sip 5060
    fixup protocol skinny 2000
    names
    access-list PERMIT_IN permit tcp any host 64.90.24.27 eq smtp
    access-list PERMIT_IN permit tcp any host 64.90.24.28 eq 3389
    access-list PERMIT_IN permit icmp any any
    access-list PERMIT_IN permit tcp any host 64.90.24.27 eq imap4
    access-list PERMIT_IN permit tcp any host 64.90.24.27 eq www
    access-list PERMIT_IN permit tcp any host 64.90.24.27 eq ftp
    access-list PERMIT_IN permit tcp any eq https host 64.90.24.26 eq https
    access-list 101 permit ip 192.168.10.0 255.255.255.0 10.1.2.0 255.255.255.0
    access-list 101 permit ip any 10.1.2.0 255.255.255.0
    access-list outside_cryptomap_dyn_30 permit ip any 10.1.2.0 255.255.255.0
    access-list consolidated_splitTunnelAcl permit ip 192.168.10.0 255.255.255.0 any

    pager lines 24
    interface ethernet0 auto
    interface ethernet1 100full
    interface ethernet2 100full
    mtu outside 1500
    mtu inside 1500
    mtu dmz 1500
    ip address outside 64.90.24.25 255.255.255.248
    ip address inside 192.168.10.1 255.255.255.0
    ip address dmz 172.6.0.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool ippool 10.1.2.1-10.1.2.254
    pdm location 192.168.10.10 255.255.255.255 inside
    pdm location 192.168.10.12 255.255.255.255 inside
    pdm location 192.168.10.13 255.255.255.255 inside
    pdm location 171.68.225.212 255.255.255.255 outside
    pdm location 192.168.10.2 255.255.255.255 inside
    pdm logging debugging 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    global (inside) 2 interface
    nat (inside) 0 access-list 101
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) tcp 64.90.24.27 smtp 192.168.10.10 smtp netmask 255.255.
    255.255 0 0
    static (inside,outside) tcp 64.90.24.28 3389 192.168.10.13 3389 netmask 255.255.
    255.255 0 0
    static (inside,outside) tcp 64.90.24.27 www 192.168.10.12 www netmask 255.255.25
    5.255 0 0
    static (inside,outside) tcp 64.90.24.27 https 192.168.10.12 https netmask 255.25
    5.255.255 0 0
    static (inside,outside) tcp 64.90.24.45 1 192.168.10.10 1 netmask 255.255.255.25
    5 0 0
    static (inside,outside) tcp 64.90.24.45 2 192.168.10.10 2 netmask 255.255.255.25
    5 0 0
    static (inside,outside) tcp 64.90.24.27 imap4 192.168.10.10 imap4 netmask 255.25
    5.255.255 0 0
    static (inside,outside) tcp 64.90.24.27 ftp 192.168.10.12 ftp netmask 255.255.25
    5.255 0 0
    static (inside,outside) tcp 64.90.24.26 www 192.168.10.10 www netmask 255.255.25
    5.255 0 0
    static (inside,outside) tcp 64.90.24.26 https 192.168.10.10 https netmask 255.25
    5.255.255 0 0
    access-group PERMIT_IN in interface outside
    route outside 0.0.0.0 0.0.0.0 64.90.8.213 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si
    p 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    aaa authentication telnet console LOCAL
    aaa authorization command LOCAL
    http server enable
    http 192.168.10.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    no sysopt route dnat
    crypto ipsec transform-set myset esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map dynmap 10 set transform-set myset
    crypto dynamic-map dynmap 30 match address outside_cryptomap_dyn_30
    crypto dynamic-map dynmap 30 set transform-set ESP-3DES-SHA
    crypto map mymap 10 ipsec-isakmp dynamic dynmap
    crypto map mymap interface outside
    isakmp enable outside
    isakmp identity address
    isakmp policy 10 authentication pre-share
    isakmp policy 10 encryption 3des
    isakmp policy 10 hash md5
    isakmp policy 10 group 2
    isakmp policy 10 lifetime 86400
    isakmp policy 30 authentication pre-share
    isakmp policy 30 encryption 3des
    isakmp policy 30 hash sha
    isakmp policy 30 group 2
    isakmp policy 30 lifetime 86400
    vpngroup vpn3000 idle-time 1800
    vpngroup consolidated address-pool ippool
    vpngroup consolidated dns-server 64.90.1.26 64.90.1.18
    vpngroup consolidated wins-server 192.168.10.10
    vpngroup consolidated default-domain CPI0
    vpngroup consolidated split-tunnel consolidated_splitTunnelAcl
    vpngroup consolidated idle-time 1800
    vpngroup consolidated password ********
    telnet 0.0.0.0 0.0.0.0 inside
    telnet timeout 10
    ssh 171.68.225.212 255.255.255.255 outside
    ssh 192.168.10.0 255.255.255.0 inside
    ssh timeout 30
    vpdn username bboney password *********
    vpdn username mmcbride password *********
    vpdn enable outside
    username zclanton password QX/w6B9i9AcagZZ6 encrypted privilege 15
    terminal width 80
    Cryptochecksum:e2b6a80afcb69513f864278f850f9f8f
    : end
    [OK]


    please note... the two translations that point at .45 are only there becauset he gui would not let me delete them
    0
     
    LVL 79

    Accepted Solution

    by:
    If you want to remove these:
      >static (inside,outside) tcp 64.90.24.45 1 192.168.10.10 1 netmask 255.255.255.255 0 0
      >static (inside,outside) tcp 64.90.24.45 2 192.168.10.10 2 netmask 255.255.255.255 0 0

    You can use command line...
     no static (inside,outside) tcp 64.90.24.45 1 192.168.10.10 1 netmask 255.255.255.255
     no static (inside,outside) tcp 64.90.24.45 2 192.168.10.10 2 netmask 255.255.255.255

    This line:
        >access-list PERMIT_IN permit tcp any eq https host 64.90.24.26 eq https
    Should look like this:
        no access-list PERMIT_IN permit tcp any eq https host 64.90.24.26 eq https
        access-list PERMIT_IN permit tcp any host 64.90.24.26 eq https
    0
     

    Author Comment

    by:Logicusa
    the access list line you refered to is the one that it keeps nulling on me... in the gui i'm telling it to point all https traffic inbound to 192.168.10.10 and it kicks it back as null and changes my 192 IP to the 64 IP you see there.  any idea why?
    0
     

    Author Comment

    by:Logicusa
    works perfectly
    Thansk a lot
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    It's supposed to be 64.x.x. in the acl because the traffic is initially destined to the public ip, not the private ip.

    Glad to help!

    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
    This article will cover setting up redundant ISPs for outbound connectivity on an ASA 5510 (although the same should work on the 5520s and up as well).  It’s important to note that this covers outbound connectivity only.  The ASA does not have built…
    This video Micro Tutorial is the second in a two-part series that shows how to create and use custom scanning profiles in Nuance's PaperPort 14.5 (http://www.experts-exchange.com/articles/17490/). But the ability to create custom scanning profiles a…
    Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…

    845 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    5 Experts available now in Live!

    Get 1:1 Help Now