Solved

VoiP Faxing, QoS, and MGCP Debugging

Posted on 2004-10-29
3,881 Views
Last Modified: 2007-12-19
I operate a BTS10200 Cisco SoftSwitch.....CAT 6509 as the Main Switch, and an AS5400 HPX as the current Voice Gateway.  All of my customers are connected via T1s with Cisco IADs (2420) back to an ESR 10008 Router, which connects to the 6509 via Fiber GigE....That is the basic network layout....

Question:  Most customers seem to be happy with their voice quality, but many of them seem to have problems faxing....Fairly random, no real pattern to it...Outbound may work, but then it will fail after 2, or 4 pages, and the same with inbound.

I am sure it has lots to do with QoS, but I am not real familiar with setting up a good strong QoS Policy....

I have tried many, but there seems to be little to no difference between them...Here are a couple of Examples:

class-map match-all MGCP
  match ip precedence 4
class-map match-all RTP
  match ip precedence 5

policy-map T1_QOS
  class RTP
    priority percent 90
  class MGCP
    bandwidth percent 4

and this one:

class-map match-all Voice-Call
  match access-group 108
class-map match-all Signaling
  match access-group 109

policy-map QOS
  class Voice-Call
   set ip precedence 5
    priority 1056
  class Signaling
   set ip precedence 5

access-list 108 permit udp any range 16384 32727 any range 16384 32727
access-list 109 permit udp any eq 2427 any eq 2427

------------------------------------------------------------------------------------------

What I am looking for are some suggestions on how to implement a good QoS Polity, and any suggestions on why the faxes are failing ?

Also, if anyone can shed some light on intrepting MGCP Debugs, that would be great....I know there is a lot of info in the MGCP Debugs, but I really don't know how to read them after I capture them....

Thank You,

Parry Sands
0
Question by:pasands
    15 Comments
     
    LVL 12

    Expert Comment

    by:Joel_Sisko
    QOS always helps but may not be your problem. First, you always need to use G.711 as the codec for faxing and modem use, the reason is that that the voice signal (fax in this case) is  uncompressed. Using any other codec causes compression (removes parts of the signal), which causes problems with faxing.

    Here is a link that is specific to some of your equipment:

    http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t11/ft_ghost.htm

    below is taken from the above link:

    Modem and Fax Passthrough Switchover
    When the gateways detect a data modem, both the originating gateway and the terminating gateway switch to modem passthrough mode. This switchover includes the following:

    •Switching to the G.711 codec

    •Disabling the high pass filter

    •Disabling Voice Activity Detection (VAD)

    •Using special jitter buffer management algorithms

    •On detection of modem phase reversal tone, disabling the echo canceler

    At the end of the modem or fax call, the voice ports revert to the previous configuration and the DSPs switch back to the original voice codec.
    0
     

    Author Comment

    by:pasands
    I have the codecs enabled and have been using them for quite some time.  I have g711ULAW enabled across the network.  No other codecs are enabled, with a few exceptions...

    The pass through statements are part of my default config on all of the gateways.

    Any configuration examples or troubleshhoting tips would be appreciated.
    0
     
    LVL 12

    Expert Comment

    by:Joel_Sisko
    OK, without seeing actual configs, l will assume that all is well on the Western Front. So letys turn to some troubleshooting:

    The Cisco 2420 is using a T1 for the WAN, what about the connection to the fax machines? Are you using another T1 or FXS ports? Can you hang a Cisco 2420 locally to the Softswitch, 6509 and Voice Gateway? What the goal is to do is to cut out the WAN portion out of the equation. If you can cut out the WAN and duplicate the problem then you know its something that is local, if not, then something about the WAN side (its a starting point).

    Also, are you using G.726  at all? The 2420's have been know to fail during faxing when the codec is part of the configuration, even if it is not being used. You mentioned that you are using G.711 all except...remove the exceptions and see if problems clear up.

    Also, if you are using FXS ports, try using a DTMF analyzer to see if DTMF digits are being distorted.

    Keep me posted



    0
     

    Author Comment

    by:pasands
    I haven't had any problems with other T1 customers faxing.  Only very early on when we first implemented the platform, but since we ironed out those bugs, its been pretty reliable.  The WAN is T1, and this is a 16 Port FXS IAD.  

    I looked at the Show MGCP, and there are 2 statements in there for G726...but it says dynamic, and it won't let me remove them...They are listed below:
    MGCP Dynamic payload type for G.726-16K codec
    MGCP Dynamic payload type for G.726-24K codec

    Also, here is a copy of the config on the IAD at this customers site:

    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    enable secret 5 $1$UedP$0Dg7yOJ8pslL1iei3v6LV/
    !
    clock timezone Central -5
    network-clock base-rate 64k
    ip subnet-zero
    ip cef
    !
    !
    ip domain name domain.net
    ip name-server xxx.xxx.xxx.xxx
    ip name-server xxx.xxx.xxx.xxx
    ip name-server xxx.xxx.xxx.xx!
    ip audit notify log
    ip audit po max-events 100
    !
    class-map match-all MGCP
      match ip precedence 4
    class-map match-all RTP
      match ip precedence 5
    !
    !
    policy-map T1_QOS
      class RTP
        priority percent 90
      class MGCP
       bandwidth percent 4
    !        
    !
    !
    voice call carrier capacity active
    !
    voice service voatm
     !
     session protocol aal2
     no voice detect
      vbd-playout-delay mode passthrough
    !
    voice service voip
     fax protocol t38 ls-redundancy 0 hs-redundancy 0
    !
    !
    !
    !
    !
    !
    !
    no voice confirmation-tone
    !
    !
    voice-card 0
    !
    !
    controller T1 0
     framing esf
     linecode b8zs
     channel-group 0 timeslots 1-24 speed 64
    !
    !
    !
    !
    interface Ethernet0
     ip address xxx.xxx.xxx.xxx 255.255.255.252
     no ip mroute-cache
     no cdp enable
    !
    interface Serial0
     no ip address
     no ip mroute-cache
     shutdown
    !
    interface Serial0:0
     ip address xxx.xxx.xxx.xxx 255.255.255.252
     max-reserved-bandwidth 99
     service-policy output T1_QOS
     no cdp enable
    !
    ip nat inside source list 1 interface Serial0:0 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0:0
    no ip http server
    !
    !
    snmp-server community
    snmp-server community
    snmp-server enable traps tty
    call rsvp-sync
    !
    voice-port 1/1
     echo-cancel coverage 32
     timing hookflash-in 750
     idle-voltage high
    !
    voice-port 1/2
     echo-cancel coverage 32
     timing hookflash-in 750
     idle-voltage high
    !
    voice-port 1/3
     echo-cancel coverage 32
     timing hookflash-in 750
     idle-voltage high
    !
    voice-port 1/4
     echo-cancel coverage 32
     timing hookflash-in 750
     idle-voltage high
    !
    voice-port 1/5
     echo-cancel coverage 32
     timing hookflash-in 750
     idle-voltage high
    !
    voice-port 1/6
     echo-cancel coverage 32
     timing hookflash-in 750
     idle-voltage high
    !
    voice-port 1/7
     echo-cancel coverage 32
     timing hookflash-in 750
     idle-voltage high
    !
    voice-port 1/8
     description FAX 246-3330
    !
    voice-port 1/9
     echo-cancel coverage 32
     timing hookflash-in 750
     idle-voltage high
    !
    voice-port 1/10
     echo-cancel coverage 32
     timing hookflash-in 750
     idle-voltage high
    !
    voice-port 1/11
     echo-cancel coverage 32
     timing hookflash-in 750
     idle-voltage high
    !
    voice-port 1/12
     echo-cancel coverage 32
     timing hookflash-in 750
     idle-voltage high
    !
    voice-port 1/13
     echo-cancel coverage 32
     timing hookflash-in 750
     idle-voltage high
    !        
    voice-port 1/14
     echo-cancel coverage 32
     timing hookflash-in 750
     idle-voltage high
    !
    voice-port 1/15
     echo-cancel coverage 32
     timing hookflash-in 750
     idle-voltage high
    !
    voice-port 1/16
     echo-cancel coverage 32
     timing hookflash-in 750
     idle-voltage high
    !
    mgcp
    mgcp call-agent  service-type mgcp version 1.0
    mgcp modem passthrough voip mode nse
    mgcp ip qos dscp cs4 signaling
    mgcp playout fixed 60
    mgcp package-capability rtp-package
    mgcp default-package dtmf-package
    no mgcp timer receive-rtcp
    mgcp fax t38 inhibit
    !
    mgcp profile default
     timeout tsmax 40
     max1 retries 3
     max2 retries 5
    !
    dial-peer cor custom
    !
    !
    !
    dial-peer voice 1 pots
     application mgcpapp
     port 1/1
    !
    dial-peer voice 2 pots
     application mgcpapp
     port 1/2
    !
    dial-peer voice 3 pots
     application mgcpapp
     port 1/3
    !
    dial-peer voice 4 pots
     application mgcpapp
     port 1/4
    !
    dial-peer voice 5 pots
     application mgcpapp
     port 1/5
    !
    dial-peer voice 6 pots
     application mgcpapp
     port 1/6
    !
    dial-peer voice 7 pots
     application mgcpapp
     port 1/7
    !
    dial-peer voice 8 pots
     application mgcpapp
     information-type fax
     port 1/8
    !
    dial-peer voice 9 pots
     application mgcpapp
     port 1/9
    !
    dial-peer voice 10 pots
     application mgcpapp
     port 1/10
    !
    dial-peer voice 11 pots
     application mgcpapp
     port 1/11
    !
    dial-peer voice 12 pots
     application mgcpapp
     port 1/12
    !
    dial-peer voice 13 pots
     application mgcpapp
     port 1/13
    !
    dial-peer voice 14 pots
     application mgcpapp
     port 1/14
    !
    dial-peer voice 15 pots
     application mgcpapp
     port 1/15
    !
    dial-peer voice 16 pots
     application mgcpapp
     port 1/16
    !
    rtr 1
     type jitter dest-ipaddr xxx.xxx.xxx.xxx dest-port 32726 interval 1
    !
    line con 0
     exec-timeout 0 0
     password
     login
    line aux 0
    line 2 3
    line vty 0 4
     exec-timeout 0 0
     password
     login
    !
    ntp clock-period 17207587
    ntp server xxx.xxx.xxx.xxx prefer
    end

    Thanks,

    Parry
    0
     
    LVL 12

    Expert Comment

    by:Joel_Sisko
    Just toook a quick look at the config: since we are looking for the needle inthe haystack, I want to summarize:

    Clients faxes randomly fail, more so when they are over one page long?

    The clients fax machines are connected directly to the Cisco IAD FXS port?

    Voice quality is good for VoIP based calls?

    T1 network between you and clients (by the way how many clients) point-to-point?

    Are all the T1's terminated on the same carrier? How large is the geographical region?


    There are a few things that jump out at me that I would change. I am going to wait for your response prior to adding thoughts. This way my answer will be more specific to your enviroment.

    0
     
    LVL 12

    Expert Comment

    by:Joel_Sisko
    One more question, do you happen to know what type of fax machines your clients are using?
    0
     

    Author Comment

    by:pasands
    Your summary is correct......All clients are Point-to-Point T1's....Using Multiple Carriers, but of course 90% still traverse the SBC Network....Geographic Area is Indianapolis and some of the outlying areas....

    This particular fax machine is a Canon 4000....There are 2 letters before the 4000, but cannot remember what they are.

    I just got back from this customers site, and I found some interesting cabling on the T1 extension from the demark.  At the smartjack, the jack was wired as follows:  
    Smart Jack Side:  Pin 1:  White-Orange,  Pin 2:  Orange,  Pin 4:  White-Green,  Pin 5:  Blue
    Extension Side:  Pin 1:  White-Orange,  Pin 2:  Orange,  Pin 4:  White-Blue,  Pin 5:  Blue

    I don't know how this T1 was working at all...After seeing that only 3 wires were actually connected...and the T1 was not taking errors.....

    I reconnected it with 1, 2, 4, & 5 straight through as it is supposed to be, and I was able to send the following faxes to multiple places:  2, 5, 7, 10, 15 Pages.... All went through....

    The customer is going to let me know tomorrow what their sucess rate was for the day, and tomorrow morning.

    Please let me know what your additional thoughts are.  Also if you happen to know how to interpret MGCP Debugs, a little lesson on that would be appreciated...

    I appreciate all of your help..

    Parry Sands
    0
     
    LVL 12

    Accepted Solution

    by:
    Parry,

    In regards to the cabling, typical wiring for a T1 is using a RJ45C, it is a 8 position keyed plug, the circuit is wired on pins 1,2  4,5; in regards to the wiring, using a straight thru cable works only if that the interfaces are set to be wired that way. Basically, you need to make sure that the Network Transmit pair is wired to the Customer Receive pair, and vice-versa for the other pair. Having the correct polarity of the individual conductors per pair can sometimes have an effect on things. Also on some sytems having more than the 4 wires connected, can have some adverse effects (could ground out the signal). In regards to only having the three wires, more than likley the pair that had the missing wire, was grounding out on one of the interfaces, allowing communications. But more than likely the crc rates were high, which caused prblems with the faxes. Also, another way to see if things are not kosher with the faxes is what connection speed they agree to transmit at, you can listen to he actual modulation tones when the fax first connects. If you here keep stepping down, it indicates a physical problem typically. Sometimes setting the faxes to a set transmitt speed helps ensure solid communications.

    Running    show interface   at the Cisco CLI can help determine physical problems. High CRC errors and rate of the errors indicate physical wiring problems.

    To test run the command as the system is configed now, then after a few days, go back and rewire as you originally found it, check the crc errors. See if there is big difference between the two, then that helps answer and confirm.

    So here are some thoughts from a telephony perspective:

    Your hookflash on the FXS ports is set at 750 ms, very high, anything over 800 ms is considered by most switches as a onhook signal (stops communication), I would receommned that to be lower lets say at 600ms. Though this should not have any effect on the faxes, just something I noticed.

    Also sometimes high loop current and high voltage can cause faxing issues also audio issues. If the fax maxhines can use the low voltage setting at 24v I would change it to that.

    I would recommend a book called Newtons Telecom Dictionary, great Telecom book (my bible in the industry). I will follow up later on the MGCP debugs
    0
     

    Author Comment

    by:pasands
    The fax is on Port 8, if you look at the config, I have it at its defaults.  Idle voltage-Low, and I don't remember what the default HookFlash is.

    I really appreciate all of the help and the info...I will definately try to get a copy of the Telcom book you mentioned.

    Also, I tried to duplicate the problem after I fixed, but it would never come back up....Had to be just a fluke with the original wiring.  I re-used the cable, just cut off the ends and re-wired it....so I don't have the original cable anymore...

    I look forward to seeing the MGCP info....Just curious...Do you work for Cisco ?
    0
     
    LVL 12

    Expert Comment

    by:Joel_Sisko
    No on working for Cisco, but my last name throws most people off. I have done alot of Telecom engineering across the country the past 13 years, worked on just about everything (Cisco, AT&T, Nortel, AVAYA, etc). In regards to debugging I found a good link from Cisco with sample debugs, but prior to viewing that, you need to understand the MGCP protocol. Also, if you are not familar with the basic telecom skills of call setup and teardown, Cisco also has a good link for that information also. Once you go thru this all of this I can answer any questions you may have to help clarify.

    The Netwon Telecom book is great, he is on the 20th edition I think, I strarted with the 10th edition, it has changed over the years as the technology evolved.

    Here is a list of links to keep you busy this weekend:

    http://www.protocols.com/pbook/VoIPFamily.htm    basic overview of VoIP

    http://www.cisco.com/warp/public/788/signalling/net_signal_control.html      basic telecom link

    http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a0080174804.shtml    debug sample

    http://www.cisco.com/application/pdf/en/us/guest/products/ps5037/c2001/ccmigration_09186a008011bd39.pdf   all of IOS voice commands

    MGCP rfc's below

    http://www.faqs.org/rfcs/rfc2705.html
    http://www.faqs.org/rfcs/rfc3525.html
    http://www.faqs.org/rfcs/rfc3660.html
    http://www.faqs.org/rfcs/rfc3661.html
    0
     
    LVL 12

    Expert Comment

    by:Joel_Sisko
    0
     

    Author Comment

    by:pasands
    Thanks....I'll go ahead and close out this topic, and award you the points...It might take a while to get through all of the docs listed here....

    Should I post specific questions about MGCP here, or should I contact you a different way ?

    Thanks Again for all of the help..

    Parry
    0
     
    LVL 12

    Expert Comment

    by:Joel_Sisko
    I am not sure about direct contact (postingpersonal emails) or if you can send emails to my account here at the EE. But I do monitor the entire site for VoIP based questions. Contact the EE admin to see what the exact policy is. But I do believe that you can post addtional comments for this thread even after you award/close it out.

    With all the docs, go thru the Cisco link on basic telecom in a detailed manner. The rest you can skim thru and focuss on what is most important for your application. Remeber that H.323, SIP, MGCP are the all encompassing protocol suites, and that there are many protocols that make up the suite. This is why I am stateing not to go crazy on those at first, the basic telecom link will have the most impact since all of the above protocols were develeoped from the foundation of basic telecom communications which is covered in the basic link (my opinion).



    Kindest regards,

    Joel
    0
     

    Author Comment

    by:pasands
    Thanks Again...

    Parry
    0
     
    LVL 12

    Expert Comment

    by:Joel_Sisko
    Just remebered one of my older books that actually has been updated, great book on T1's then and sure its even better now.


    Guide to T-1 Networking: How to Buy, Install & Use T-1 From Desktop to Ds-3
    by William A. Flangan


    Joel
    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Prepare to Pass the CompTIA A+ 900 Series Exam

    CompTIA aims to adapt its A+ Certification to reflect the most current knowledge and skills needed by today's IT professionals--and this year's 2016 exam is harder than ever. This certification is one of the most highly-respected and sought after in IT.

    Suggested Solutions

    Title # Comments Views Activity
    UC540 Setup with 6 PRIs 1 26
    Echo on outside calls from Cisco ip phone 5 42
    ASA 5505 Slowing Internet 11 107
    Virl for Cisco 4 beginner 6 38
    As companies replace their old PBX phone systems with Unified IP Communications, many are finding out that legacy applications such as fax do not work well with VoIP. Fortunately, Cloud Faxing provides a cost-effective alternative that works over an…
    Skype is a P2P (Peer to Peer) instant messaging and VOIP (Voice over IP) service – as well as a whole lot more.
    In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
    Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…

    846 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    10 Experts available now in Live!

    Get 1:1 Help Now