Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

The blind leading the blind

Posted on 2004-10-30
87
Medium Priority
?
648 Views
Last Modified: 2013-12-24
Very strange - just installed FPSE 2002 on a WinXP PRO box, with IIS and existing 2000 FPSE.

I'm getting a username and password box when accessing the site, either in the browser, FrontPage, SharePoint Admin, etc, etc.

Any ideas?

Thanks,
Sean

0
Comment
Question by:seanpowell
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 40
  • 19
  • 18
  • +2
87 Comments
 
LVL 29

Expert Comment

by:coreybryant
ID: 12453466
Do you have IUSR & IWAM settings set up properly?  :)

-Corey
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12453472
Hi,

Change 2000 FPSE to 2002 FPSE

hhammash
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12453477
Apparently not.

Did you want to walk me through that - I'm 4 hours in and ready to cut the tail of my mouse. Can't think straight.

I'd also like a vacation, if you could handle that as well that would be great.
0
Looking for a new Web Host?

Lunarpages' assortment of hosting products and solutions ensure a perfect fit for anyone looking to get their vision or products to market. Our award winning customer support and 30-day money back guarantee show the pride we take in being the industry's premier MSP.

 
LVL 14

Expert Comment

by:hhammash
ID: 12453479
OK,

When you get ther username and password box,  and type the username and passowrd correctly,  do you have access to the site?

If yes:
Is your site on your Intranet (University, company ...etc)?  If yes,  you'll always get it.  

If your website is on a host company which is external hosting a private website,  then when you check username and password you should not be asked for them again.

hhammash
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12453487
If you right click on the folder - you should get properties.  Under Security - what do you have listed there?  Network / Network Service should be there as well as the internet guest acccount.  Does this Windows XP have SP2 installed?  What about that firewall?

-Corey
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12453488
>>and type the username and passowrd correctly

This is the problem - what username and password :-(
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12453492
(You can use the admin user name / password) - that way that will at least help / show you have access to it

-Corey
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12453505
Yes, now I just need to remember them. I haven't used them on this box in a coon's age.
I'll get back to you :-)

Thanks guys,
Sean
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12453536
You're welcome sean
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12453550
Well, beats me. Tried "MyComputer", "Administrator", "Sean Powell". If I have a username, I'll be damned if I know what it is.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12453559
Do you log into the Windows XP system?

-Corey
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12453564
Hi sean,

Where is the site?  on your local drive? or on the Intranet?

hhammash
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12461796
Local, standalone box, which I log on to.
Clearly I have missed an important step here, just wish I knew which one. I'll see if I can find something in the kb articles somewhere.

Sean
0
 
LVL 12

Expert Comment

by:rcmb
ID: 12462646
Sean,

When you open the site how are you trying to enter -- machinename, localhost, etc.

Try opening http://localhost

If you are logged in as a OS administrator then the site should open without a problem. If you have copied this site over from another location I would remove server extensions from the site and then reinstall them. You may have some left over issues from the other site trying to interact here.

Curtis
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12462727
Thanks Curtis.

>>If you are logged in as a OS administrator then the site should open without a problem.
That's what I would have thought. I have uninstalled both sets of extensions for now... until I can find out why FPSE 2002 seems to need a name and password, of which the one's I use to log into the computer do not apply.

Sean
0
 
LVL 12

Expert Comment

by:rcmb
ID: 12462799
In FPSE 2002 if you have not assigned a user to the site then you will not have access. Go to the web adminitrator of FP2002 SE and add a user. Give the user admin level rights. Make sure the user is the user you are logged in as (you can select a user from the local network/machine or create your own user).

Curtis
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12462889
>>Go to the web adminitrator of FP2002 SE and add a user

I can't, that's the problem. Tryng to open the administrator asks me for a username and password, and subsequent attempts fail because the browser asks what to do with a dll file. It's very bizzare.
0
 
LVL 12

Expert Comment

by:rcmb
ID: 12462957
Remove 2002 server extensions and install 2000. Now add your login as an administrator.

Reinstall 2002 server extensions and this should pick the user up.

Curtis
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12463153
>>Now add your login as an administrator.
How exactly? I'm already logged into XP Pro as the administrator.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12463201
Just curious - is port 4952 open?

When you go to the FP extensions admin side - it should ask you for a user name / password.  And you should enter the admin user name / password.  But for some reason, this does not work?  Do you have TS on the server?

-Corey
0
 
LVL 12

Expert Comment

by:rcmb
ID: 12463221
In FrontPage -- tools, server, permissions you can add users and assign rights.

Curtis
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12463248
>> is port 4952 open?
Yes, but we finished it off last night. I'm now into the sherry.

I'll check...

>> When you go to the FP extensions admin side - it should ask you for a user name / password.
It does.
>> And you should enter the admin user name / password.  But for some reason, this does not work?
Correct, the browser goes into an infinite loop, I assume becuase it wants the username and password that I use to start up the computer, but doesn't recognize them.

>> Do you have TS on the server?
Terminal Services? Yes.

Sean
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12463267
Curtis - that option doesn't exist on FP2000. It looks like this is also a FAT drive - I wonder if that is causing it ?
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12463290
IE has that option to block websites etc.  Do you have that option enabled on this website?  Do you have this website "trusted"?  

-Corey
0
 
LVL 12

Expert Comment

by:rcmb
ID: 12463328
That will certainly cause your problem. Just convert it to NTFS so you can set permissions correctly.

Curtis
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12464175
Okay....

1. Converted drive to NTFS.
2. Uninstalled both 2002 and 2000 SE.
3. Re-installed 2000 SE only.
4. Now even that default installation is asking me for a username and password to open localhost in FP.

This tab in IIS, it is correct? The password is dotted out - beats me what it could be. Is "this" the username and password that FP is looking for, because it's not what I use to log on to the machine with. At least I don't think it is.
http://www.pdgmedia.com/sp.gif

Sean
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12464210
When you hit browse - do you see the other user names listed for your computer?  What is the IUSR & IWAM?

-Corey
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12464369
http://www.pdgmedia.com/sp2.gif

What is the IUSR & IWAM??
How do I access those?
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12464476
Now hit advanced.  These are usually the internet users..

-Corey
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12464485
Hi sean,

Is anonymous access in the folder properties in IIS encabled (checked) or not?

In IIS admin
Right click the folder and open properties.   Then,  look at the folder security.  Check the Anonymous access if it is not checked.

Regards
hh
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12464527
>>Is anonymous access in the folder properties in IIS enabled (checked) or not?
http://www.pdgmedia.com/sp.gif

>> Now hit advanced
http://www.pdgmedia.com/sp3.gif
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12464587
>>> Now hit advanced
>>>http://www.pdgmedia.com/sp3.gif

That might be the problem..  No users set up.  Can you set up a User and then add that to see if that works?

-Corey
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12464610
Hi sean,

what happens if you create a new web, do you get the same box?

Try creating a new web and see if you can access it with no problem.  If you don't  you better uninstall IIS and reinstall it.  These things take a long time to be figured out.  Sometimes it is one of the bad things in Frontpage.

Regards
hhammash
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12464622
>>Can you set up a User and then add that to see if that works?

I'm sorry Corey - where do I do that?
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12464635
>>what happens if you create a new web, do you get the same box?
Yes - perhaps a re-install of IIS is in order....

Sean
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12464669
You can try to go to Control Panel -> Users.  And try that as a test

-Corey
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12464740
I added another admin account, still no go. Sorry guys for taking up all your time with this. I'm really stumped here and simply don't understand why FP needs a username/ password to open up localhost. Nothing is protected from what I can see.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12464764
You mind creating a TS for one of us / all three to see if we can take a peak?
-Corey
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12464789
It is one of the wierd thing of FP.  In dealing with stuff like that I usually don't give it a chance.  Just reinstall which makes things go right,  you dont' know why.

Yesterday while I was making changes in one of the webs on my local drive to test your problem, I got a problem in accessing the sites with a strange message,  no password and username.  I just uninstalled IIS and reinstalled it.  Now I can access the same websites.

Just a strange thing again by FP.

hhammash
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12464817
Hmmm - not out in the open. I'll send you an email Corey.
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12464823
I'll try an unistall of IIS first...
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12464853
Definitely. :)  Let us know how that goes first.

Thanks!

-Corey
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12466334
Well, no luck with Remore Assistance despite Corey's kind help. Even opening up http://localhost in a browser now prompts me, so clearly it's getting worse. Un/Re-installing IIS didn't appear to help. So there's a setting somewhere that messed up - obviously from when I originally tried to install FPSE 2002.

Thanks for all your help though :-)
0
 
LVL 12

Expert Comment

by:rcmb
ID: 12468257
Go to windows explorer and set permissions on the inetpub/wwwroot to everyone full control. Make sure you propagate the permissions down.

Now see if you can get in.

Curtis
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12468602
The folder options are Read Only and Archive. Read only is checked.

I'm thinking an expensive MS Support call is going to be in order :-(
0
 
LVL 12

Expert Comment

by:rcmb
ID: 12468679
Did you copy this website from a cd? You need to remove the read only attribute because FrontPage cannot update files when they are read only.

Curtis
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12468774
No, it's just the same root web that I've had for years, I'm afraid...
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12468803
I am pretty much stumped.  We set up a test account - put that test account in the Front Page Admin group & then tried to use the user name / password to access the site.  It did not like it.  :-/  Usually that was the case when I screwed up something on one of my websites.  

-Corey
0
 
LVL 12

Expert Comment

by:rcmb
ID: 12469226
Have you tried setting permissions on the wwwroot folder? Give everyone full control.
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12470116
sean,

In directory security,  remove "Allow IIS to control Password"  restart and try.

hhammash
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12470123
Just remove the check mark from the check box and keep the fields unchanged.  Also keep Anonymous Access checked.

hhammash
0
 
LVL 12

Expert Comment

by:rcmb
ID: 12470857
Since so much has happened over the last few hours why not just back up the website to another location. Remove server extensions, remove iis, delete the inetpub directory. Reinstall iis, reinstall server extensions, open your new site in frontpage and import the old site using frontpage.

This will take about an hour and save you lots of heartache down the road.

Curtis
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12471791
Just deleted and uninstalled "everything", and then re-installed IIS.

And then I got the name/password prompt again (in the browser and in frontpage).

So - something on this PC (outside of IIS) is causing this. And it all started when trying to upgrade to FPSE 2002.
I'm going to try pouring a can of coke through the slots at the back and see if that helps.

Thanks again for all your suggestions,
Sean
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12475388
Hi sean,

You are most welcome.  I wish that we can find a solution for this problem,  it became like a challenge.

The Internet if full of question like yours with no obvious and fixed solution.

Question:
-----------
By upgrading,  did you mean installing an upgrade on a previous version,  or installed a fresh copy of FPSE2002 after removing the old FPSE?

Thanks
hhammash
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12475413
I installed 2002 "without" uninstalling 2000 first. That was probably a mistake, wasn't it :-)

I'm still researching on this end, but nothing yet.
0
 
LVL 2

Expert Comment

by:dtolo
ID: 12475544
When you log in to the box are you logging into a domain or a local user account, If you are logging into a domain log into the local machine instead.
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12475581
Nope, no domains. Just the single admin account...
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12475971
Okay - some progress, I think. From the browser I now get this:

HTTP 500.100 - Internal Server Error - ASP error
Internet Information Services
Technical Information (for support personnel)

    * Error Type:
      Microsoft VBScript runtime (0x800A0046)
      Permission denied: 'GetObject'
      /localstart.asp, line 40
    * Browser Type:
      Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
    * Page:
      GET /localstart.asp

Just FYI really :-)
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12476103
Not getting the prompt in FP any more, just a message telling me the extensions are not installed (which they are) ........

Sean
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12476238
From FP, the error message is now:
11/02/2004 14:19:22
HTTP 500 Server Error
<html><head><title>Error</title></head><body>The specified module could not be found. </body></html>

Just playing with different security settings.... I apologize for the emails.
Sean
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12476267
You have ASP enabled also, right?  

-Corey
0
 
LVL 14

Assisted Solution

by:hhammash
hhammash earned 1000 total points
ID: 12476368
Sean,

I am sure the biggest part of the problem was installing the new FPSE on the old one.

The problem resides among FPSE, IIS and Frontpage.

- Uninstall FPSE
- Uninstall Frontpage
- Uninstall IIS
- Most important,  Remove IIS from the Registery, it is essential.
- Remove Frontpage from the Registry
- Search your computer for any remains of IIS, and Frontpage and remove them
- Restart the PC
- Reinstall FP first
- Reinstall IIS and FPSE

Uninstalling without cleaning the registry and any remains of Frontpage and IIS on the hard disk will do no good.

I had a problem with Frontpage before,  not similar to yours.  I did all the above in sequence.  Then everything worked just fine.  I don't even think that Microsoft Support people have a clue of why is this happening, otherwise you would've seen in support.microsoft, becuase the Internet is full of persons with the same problem and without any solution.

Regards
hhammash

0
 
LVL 31

Author Comment

by:seanpowell
ID: 12476372
Yes, I also just now enabled SOL, in case it may help.
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12476470
hhammash,

I think you're right - its the best way to go.

I need to do a search to find out how to clean the registry correctly first...

Sean
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12476730
Not much out there.

Do i just perform a search in the registry for the values "frontpage" and "iis" and delete absolutely everything I find?
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12476800
Hi sean,

I am sure you know the following steps but I'll give you the names that you need to look for:

Run > Regedit >Edit > Find

- iis


Then

Run > Regedit >Edit > Find
-Frontpg

Then

Run > Regedit >Edit > Find
-Frontpage


Delete each file and folder you find seperately making sure that it clearly sayd iis or frontpg or frontpage.

Good luck
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12476847
Hi sean,

Yes delete every instance of

iis
fronpage
frontpg

Make sure to read the file name and path before removing.  The path should clearly mention the name that you want to delete.

After you finish do:
Start
Search for files and folders
IIS
Frontpage
Frontpg

On your computer and delete everything you find except any folder that you named yourself to indicate that you saved Frontpage files in it.

Restart the computer and install fresh copies of all above.

Good luck sean
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12477108
There's a lot of these:

HKEY_CLASSES_ROOT\AppConfig.IISAppConfig.1

and

IISAppConfig Class.

Lose all those as well?
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12477335
Hi sean,

Take a look at this before:
http://support.microsoft.com/kb/816085

In my case I removed all iis instances.

But take a look at the article.

hh
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12477964
Oh well, no go. Same old, same old.

This is very interesting:
If I create a new web under localhost and when setting the permissions choose "Inherit from Parent Node", I get this (my caps):

The parent node does not have any explicit Access Permissions set. Access Permissions which will be inherited to this node will NOT ENABLE ACCESS TO ANYONE. If you are sure you want to do this click Yes. (Otherwise, fix the parent node permissions so that correct permissions can be inherited)

So, this is telling me that if I use the existing permissions from localhost in localhost/test, no one will be able to access it. Which seems to be precisely why I can't access localhost.

But it beats me where those permissions are set. I still think (somehow) it's outside of IIS, since it was completely removed. But I may be wrong...

Sean
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12478004
Hi sean,

You removed everything and from the registry and still the same!!!?

This is a real challenge.

I'll read the post from the beginning and see if we missed anything.

hh
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12478040
Just to make sure:

In the Directory security,  did you remove the check box from the option that says "Allow IIS to control Password" without removing the values in the text boxes.  And keeping the checkbox of Anonymous selected?


hh
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12478056
Do you have Sharepoint installed?
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12478093
Yes - did that. Tried everything :-(

You're welcome to have a look through Remote Assistance if you think you could do anything else.

Sean
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12478544
I'll be glad to
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12478605
OKay - I'll post back when the system is clear... Would you prefer I emailed you?

Thanks hhammash :-)
0
 
LVL 14

Expert Comment

by:hhammash
ID: 12478746
Yes of course
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12478994
Not in your profile - perhaps you should email me :-)
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12495169
SOLVED!!!!!!!!!!!!!!

A suggestion by Sunray in the XP TA:
Remove the password from your main admin account
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12495249
Congratulations :)  I thought it had to do something with that permissions thing - but would have never thought to tell you to remove the password...   :-/  

-Corey
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12495394
You're not going to believe this.

The ONLY site I can access now is localhost. All the other external sites I work with won't accept the standard username/password. (These are just client sites at various hosting companies.)

I'm going to cry.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12495436
Now that is even weirder.  I do not see that having an effect on the other sites.  Can you http://www.thedomain.com & access it via explorer?  Or just not FP?

BTW - I sent you an email about 5 seconds before this.

-Corey
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12495498
Yea - browsers are fine. I don't understand why I can't open any external sites - this is very bizzare.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 12495587
And if you put the admin password back in - I assume you would be able to?  Can you log on unde a different admin account?

-Corey
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12495643
Main Admin Account:
Password removed: cannot access external sites.
Password put back in: cannot access external sites or localhost.

New Admin Account:
Password removed: CAN access external sites and localhost.
Password put back in: CAN access external sites and localhost.
0
 
LVL 29

Accepted Solution

by:
coreybryant earned 1000 total points
ID: 12495710
Well there you go :)  Kiss that Main Admin account good bye I would say.   Seems something is corrupted there.

-Corey
0
 
LVL 31

Author Comment

by:seanpowell
ID: 12495740
Yes, I agree. I need to go back to the XP TA now and find out how I can copy/move a lot of the specific user settings that the existing account had.

Thanks Corey,
Sean
0

Featured Post

Looking for a new Web Host?

Lunarpages' assortment of hosting products and solutions ensure a perfect fit for anyone looking to get their vision or products to market. Our award winning customer support and 30-day money back guarantee show the pride we take in being the industry's premier MSP.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this short web based tutorial, I wanted to show users how they can still use the powers of FrontPage in conjunction with Expression Web 3.  Even though Microsoft eliminated the use of Web components, we can still use them with FrontPage and edit …
This guide will walk you through the essential considerations and tech stack for building scalable websites. Know how to grow your business the smart way!
The purpose of this video is to demonstrate how to connect a WordPress website to Google Analytics. This will be demonstrated using a Windows 8 PC Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php :…
The purpose of this video is to demonstrate how to properly insert a Vimeo Video into a WordPress site or Blog. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp…
Suggested Courses

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question