[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Advanced Queue Failed to Deliver Message on one email domain

Posted on 2004-10-31
7
Medium Priority
?
1,246 Views
Last Modified: 2013-11-15
We have Exchange 2003 SP1 on SBS2003 using several email domains, all of which work fine apart from one.  For that domain (call it domain.com), most emails show the following entries in the Message Tracking Center, and fail:

SMTP: Message Submitted to Advanced Queuing
SMTP: Started Message Submission to Advanced Queue
SMTP: Advanced Queue Failed to Deliver Message

whereas all other domains (call one of them e.g. domain.co.uk) show the following, and deliver correctly:

SMTP: Message Submitted to Advanced Queuing
SMTP: Started Message Submission to Advanced Queue
SMTP: Message Submitted to Categorizer
SMTP: Message Categorized and Queued for Routing
SMTP: Message Queued for Local Delivery
SMTP: Message Delivered Locally to user@domain.co.uk
SMTP Store Driver: Message Delivered Locally to Store to user@domain.co.uk

Email addresses are entered correctly for each user in AD, recipient policies correct and updated.

The odd thing about it is that mails are sometimes delivered, depending on where they are sent from.  For example, if I send a message to user@domain.com from a remote computer (Outlook Express) through an ISP’s SMTP server, it will be delivered if I send it from my correct email address, but not if I send from a made-up address.  Any mails sent to the other domains (user@domain.co.uk) from any email address, genuine or not, will arrive correctly as they should.  From some locations (e.g. Hotmail) they always fail when sent to domain.com.

Mail comes through a separate Windows 2000 Server running ISA (but I ruled this out by temporarily replacing it with a hardware router forwarding port 25).

We are running GFI MailEssentials on the SBS2003 server - I disabled this and it makes no difference.

The server was upgraded from SBS2000, but we didn't using the troublesome domain until after the upgrade.

Any help appreciated, thanks.
0
Comment
Question by:davehaycox
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 104

Expert Comment

by:Sembee
ID: 12458728
Are you getting an NDR back on emails to this domain? If so, what does it say?
My instinct is that they are filtering their email and you are being blocked for some reason, but the NDR message will confirm that.

Simon.
0
 

Author Comment

by:davehaycox
ID: 12458903
No NDR, that's the odd thing (and yes, NDRs are enabled!). I know that all the mails are arriving at the Exchange server, so it's not an ISP filtering problem, if that's what you mean.

If I telnet in on port 25 from outside the network, any message I send using the SMTP command line will be delivered correctly, so I thought it might be something to do with the email header format.  We had our ISP forward all mail to domain.com (%1@domain.com forwarded to %1@domain.co.uk) and this made no difference at all.

David
0
 
LVL 104

Accepted Solution

by:
Sembee earned 1000 total points
ID: 12458966
This is inbound email? It isn't 100% clear.
Direct SMTP delivery or the awful POP3 connector?

If it is inbound email do the remote sites get NDRs?
While you have disabled GFI, I don't think that is enough. You may have to actually uninstall it to get rid of the hooks in to the SMTP service. I think that it is the SMTP service that has the problem - the emails are getting mangled by something and Exchange cannot read them.
Any other SMTP services runnings - AV anything like that?

Simon.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:davehaycox
ID: 12459010
Yes, this is inbound email with the problem.
It's direct SMTP delivery.
I have tried using the POP3 connector instead, this appears to make no difference.

The remote sites do not get NDRs, that's the frustrating thing - if I knew why it was failing it would give me something to go on.  I couldn't find any way in Exchange to determine why the mails were failing.

AV is Symantec Corporate v9.0, the standard version not the Exchange one.  I recently upgraded from 8.0 to 9.0 and took the opportunity to check the problem with AV uninstalled - no change.

I will uninstall GFI and see what happens.

David
0
 

Author Comment

by:davehaycox
ID: 12459150
Well, you were right, it was GFI Mail Essentials causing the problem!

It was the first place I looked, but clearly I didn't look hard enough.

Problem solved, thanks very much!

Of course, now I have spam coming in unchecked.  If I reinstall GFI afresh do you think it will recreate the problem?

Thanks again

David
0
 
LVL 104

Expert Comment

by:Sembee
ID: 12459168
Which version of GFI is it? It might pay to check their web site to see if there are any patches or sub releases that you can install. You could even download it again and then just enter your key.
It all depends on where was the problem within GFI.

Simon.
0
 

Author Comment

by:davehaycox
ID: 12459581
GFI was version 9 I think - just checked and there is a later version.

I'll download it and give it a try.

Slightly off-topic perhaps, but I've switched off NDRs now and they're still being sent.  I've also deleted the email address to send a copy of NDRs to under the SMTP connector, and the copy of the NDR is still coming as well.  I have rebooted, no change.

I'll raise another question perhaps if I can't sort it out, I've probably missed something.

David
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Want to know how to use Exchange Server Eseutil command? Go through this article as it gives you the know-how.
On September 18, Experts Exchange launched the first installment of the Help Bell, a new feature for Premium Members, Team Accounts, and Qualified Experts. The Help Bell will serve as an additional tool to help teams increase question visibility.
With the power of JIRA, there's an unlimited number of ways you can customize it, use it and benefit from it. With that in mind, there's bound to be things that I wasn't able to cover in this course. With this summary we'll look at some places to go…
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question