Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

McAfee Framework Sevice Problem

Posted on 2004-11-01
17
Medium Priority
?
18,572 Views
Last Modified: 2008-09-03
Hi
When I am trying to install a McAfee product, (Groupshield, Virusscan 7.1.0 or 8.0.0, or Protection Pilot)  I keep getting the error message: Error 1920.Service McAfeeFramework (McAfeeFramework) failed to start.  Verify that you have sufficient privileges to start system services. Abort / Retry / Ignore.
The computer OS is SBS Server 2000.

Thanks for your help.
0
Comment
Question by:Allan_Shiels
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 5
  • 2
  • +1
17 Comments
 
LVL 57

Expert Comment

by:Pete Long
ID: 12461836
click start > run > services.msc

locate the McAfee Framework Service on the list, ensure its startup is set to automatic (right click > properties) and ensure the sratup account details are set to "local system account" (on the log on tab)

Pete
0
 

Author Comment

by:Allan_Shiels
ID: 12461896
Thanks,
The McAfee Framework service is not present in the list of services.
0
 

Author Comment

by:Allan_Shiels
ID: 12464102
I have upped the points value of this, as the problem has been with use for more than a week now and we have exhausted all avenues that we know about.

We have also contacted Mcafee support center, who said they would escalate the problem to 2nd tier tech support - but they have never got back to us.

Any more help would be greatly appreciated.
0
Automating Your MSP Business

The road to profitability.
Delivering superior services is key to ensuring customer satisfaction and the consequent long-term relationships that enable MSPs to lock in predictable, recurring revenue. What's the best way to deliver superior service? One word: automation.

 
LVL 57

Expert Comment

by:Pete Long
ID: 12465988
sorry Allen

more info

are you using EPolicy orchistrator? hav the AV agent been installed on the client? (usually called FramePkg.exe)
0
 

Author Comment

by:Allan_Shiels
ID: 12466856
Hi Pete
The setup we were using was Groupshield, Protection Pilot, and Virus Scan together.
I have tried forcing the framepkg.exe to install manually.
It always seems to come down to the error installing the framework service.
Thanks
0
 
LVL 57

Accepted Solution

by:
Pete Long earned 1500 total points
ID: 12467066
OK sounds like the framepkg.exe file is the problem, you need to recreate the framepkg.exe file and when its created it will ask for the logon username and password that it will install under, I do this from my ePO console
0
 

Author Comment

by:Allan_Shiels
ID: 12467586
I dont actually have ePO installed , Protection Pilot is a cut down version, I will check and see if can recreate it from there.
I do have access to ePO under terms of the licence, so if needed I could install.  I cant get access to my clients site till tomorrow am,  So I will try then. Thanks
0
 

Author Comment

by:Allan_Shiels
ID: 12471096
Ok
I cant install ePO as I dont have access to it.
The agent install files are within the \Protection Pilot 1.0.1\Setup\Agents\EPOAGENT3000\3.1.3\0409\InstallFiles directory i have tried to install from this directory but I get the error

Searching for previous install...
The command line parameters specified are invalid.
The installation was not successfull!

This is when trying to run the frminst.exe file.
0
 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 12472671
Read some suggestions here also >> http://forums.mcafeehelp.com/viewtopic.php?t=9092
may be u can get some idea :)
0
 

Author Comment

by:Allan_Shiels
ID: 12472778
I have looked at that previously, it has not helped though :-(
Thanks
0
 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 12473063
ok plzz try this, go here >> http://ts.mcafeehelp.com/chat.asp?oaid=95
and give ur informations,,, and chat with a person there on ur problem,,,,, i have talked to them many times and they are really good at support :)

Hope they know the problem u are facing and its solution too =)
0
 

Author Comment

by:Allan_Shiels
ID: 12473553
nope they couldnt help, because it is a business product
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 12474554
Hello Allen, Im unfamilliar with your setup

Ive only ever created the frampkg agent files from ePO and they are system specific, i.e. each systems framepkg contains logon info and the location of the AV update database, there must be some method of creating it under your licencing, have you spoken to your software vendor?
0
 

Author Comment

by:Allan_Shiels
ID: 12477940
I have been in touch with NAI/Mcafee and have an ongoing case reference, however the response is somewhat sluggish, I think they might have given up as I havent had any correspondence for 2 weeks.
0
 

Author Comment

by:Allan_Shiels
ID: 12481889
Hi Pete
Finally got it sorted.  Managed to get Protection Pilot reinstalled and manually recreate the frampkg.  Stopped all Mcafee processes and services, manually ran the frampkg.exe file, this reinstalled the framework service correctly.
As you pointed me in the direction of the framepkg.exe file I will award you the points.
Many Thanks
Adam
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 12485081
Thanks Adam - glad you are fixed
0
 

Expert Comment

by:yuvraj055
ID: 21963587
hi
For re-installation solution


after uninstall

1 step :
stop  services of mcafee framework,by "services.msc" command at command prompt
 
2 step:
Remove mcafee folder from

C:\Documents and Settings\All Users\Application Data(hidden folder)
3 step
Remove Network associate folder from

C:\Program Files

Try to reinstall again.
0

Featured Post

Q2 2017 - Latest Malware & Internet Attacks

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out our latest Quarterly Internet Security Report!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For those of you actively in the Malware fightling business, we now have available an amazing new tool in the malware wars (first recommended to me by rpggamergirl (http://www.experts-exchange.com/M_3598771.html), the Zone Advisor for the Virus and …
If you thought ransomware was bad, think again! Doxware has the potential to be even more damaging.
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…
Email security requires an ever evolving service that stays up to date with counter-evolving threats. The Email Laundry perform Research and Development to ensure their email security service evolves faster than cyber criminals. We apply our Threat…

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question