McAfee Framework Sevice Problem

Hi
When I am trying to install a McAfee product, (Groupshield, Virusscan 7.1.0 or 8.0.0, or Protection Pilot)  I keep getting the error message: Error 1920.Service McAfeeFramework (McAfeeFramework) failed to start.  Verify that you have sufficient privileges to start system services. Abort / Retry / Ignore.
The computer OS is SBS Server 2000.

Thanks for your help.
Allan_ShielsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pete LongTechnical ConsultantCommented:
click start > run > services.msc

locate the McAfee Framework Service on the list, ensure its startup is set to automatic (right click > properties) and ensure the sratup account details are set to "local system account" (on the log on tab)

Pete
0
Allan_ShielsAuthor Commented:
Thanks,
The McAfee Framework service is not present in the list of services.
0
Allan_ShielsAuthor Commented:
I have upped the points value of this, as the problem has been with use for more than a week now and we have exhausted all avenues that we know about.

We have also contacted Mcafee support center, who said they would escalate the problem to 2nd tier tech support - but they have never got back to us.

Any more help would be greatly appreciated.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Pete LongTechnical ConsultantCommented:
sorry Allen

more info

are you using EPolicy orchistrator? hav the AV agent been installed on the client? (usually called FramePkg.exe)
0
Allan_ShielsAuthor Commented:
Hi Pete
The setup we were using was Groupshield, Protection Pilot, and Virus Scan together.
I have tried forcing the framepkg.exe to install manually.
It always seems to come down to the error installing the framework service.
Thanks
0
Pete LongTechnical ConsultantCommented:
OK sounds like the framepkg.exe file is the problem, you need to recreate the framepkg.exe file and when its created it will ask for the logon username and password that it will install under, I do this from my ePO console
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Allan_ShielsAuthor Commented:
I dont actually have ePO installed , Protection Pilot is a cut down version, I will check and see if can recreate it from there.
I do have access to ePO under terms of the licence, so if needed I could install.  I cant get access to my clients site till tomorrow am,  So I will try then. Thanks
0
Allan_ShielsAuthor Commented:
Ok
I cant install ePO as I dont have access to it.
The agent install files are within the \Protection Pilot 1.0.1\Setup\Agents\EPOAGENT3000\3.1.3\0409\InstallFiles directory i have tried to install from this directory but I get the error

Searching for previous install...
The command line parameters specified are invalid.
The installation was not successfull!

This is when trying to run the frminst.exe file.
0
SheharyaarSaahilCommented:
Read some suggestions here also >> http://forums.mcafeehelp.com/viewtopic.php?t=9092
may be u can get some idea :)
0
Allan_ShielsAuthor Commented:
I have looked at that previously, it has not helped though :-(
Thanks
0
SheharyaarSaahilCommented:
ok plzz try this, go here >> http://ts.mcafeehelp.com/chat.asp?oaid=95
and give ur informations,,, and chat with a person there on ur problem,,,,, i have talked to them many times and they are really good at support :)

Hope they know the problem u are facing and its solution too =)
0
Allan_ShielsAuthor Commented:
nope they couldnt help, because it is a business product
0
Pete LongTechnical ConsultantCommented:
Hello Allen, Im unfamilliar with your setup

Ive only ever created the frampkg agent files from ePO and they are system specific, i.e. each systems framepkg contains logon info and the location of the AV update database, there must be some method of creating it under your licencing, have you spoken to your software vendor?
0
Allan_ShielsAuthor Commented:
I have been in touch with NAI/Mcafee and have an ongoing case reference, however the response is somewhat sluggish, I think they might have given up as I havent had any correspondence for 2 weeks.
0
Allan_ShielsAuthor Commented:
Hi Pete
Finally got it sorted.  Managed to get Protection Pilot reinstalled and manually recreate the frampkg.  Stopped all Mcafee processes and services, manually ran the frampkg.exe file, this reinstalled the framework service correctly.
As you pointed me in the direction of the framepkg.exe file I will award you the points.
Many Thanks
Adam
0
Pete LongTechnical ConsultantCommented:
Thanks Adam - glad you are fixed
0
yuvraj055Commented:
hi
For re-installation solution


after uninstall

1 step :
stop  services of mcafee framework,by "services.msc" command at command prompt
 
2 step:
Remove mcafee folder from

C:\Documents and Settings\All Users\Application Data(hidden folder)
3 step
Remove Network associate folder from

C:\Program Files

Try to reinstall again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Anti-Virus Apps

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.