Solved

SQL Server Reporting Services - WorkGroup, not part of Domain - using URL access reports

Posted on 2004-11-01
1,198 Views
Last Modified: 2012-08-13
Hi there

Situration

1.Development Server is on WorkGroup, not main Domain. (win 2003 server(std))
2.Accessing dev server via \\Main Domain\Administrator
3.SQL 2K (Std)

SQL Reporting
1.Using SQL authentication for shared resource, rather win authentication.
2.Shared folder, access set to everyone.

Current Situration
1.Have created 5 reports, each has a url within Domino Notes application.  Click on anyone of them (assuming
\\Main Domain\Administrator\) --> reports work ok.
2.Log-on as non-administrator --> click on url, enter site ok, but popup appears asking for authentication of user
e.g. name, pwd & domain.

Constraints
1.Development Box cannot be joined to main domain
2.Host name e.g. http:\\wtdev01\reportserver  --> dealt with WINS server, not host file !

Requirement
Any user clicks on URL for the report, will open the report and be run without authentication issues.

Tried
1.Custom Authentication (e.g. Form Authentication) - issue cannot use Standard version of SQL Server !  Needs to be Enterprise.  Dead end.

Any ideas.
0
Question by:ImraneA
    8 Comments
     
    LVL 14

    Expert Comment

    by:simon_kirk
    Long shot, but try this:
     - Create a SQL user, and set access to allow at least read access of your SQL database
     - Go into Report Manager, and select your reports datasource
     - On the properties tab, set the "Connect Using:" to "Credentials stored securely in the report server"
     - Enter the username and password that you created, and apply the changes
    0
     
    LVL 11

    Expert Comment

    by:saleek
    I dont think that will work, as the authentication is required for reportserver and not the sql server datasource. Reporting Services will only authenticate using Windows Authentication and there is no way around it - apart from writing your own custom security extension, but even that is not recommended.

    The only other thing you can do is turn on Anonymous Authentication, but that will mean no security.

    If it is the development machine that is asking for login, then why is this a problem? After all it is a "development machine", you can afford to type in valid credentials everytime you test it?!


    regards,

    KS
    0
     
    LVL 14

    Expert Comment

    by:simon_kirk
    As the development box cannot be on the domain, can't you publish the reports to the Live reporting server and then get the users to access them?
    0
     

    Author Comment

    by:ImraneA
    Hi there

    Sorry for not responding earlier, totally mobbed by heavry workload.

    Solved the problem.  This is how I done it :-

    Within IIS Manager, set Reports, Reportserver + Actual Project to the following:-

    1.Ticked   --> Integrated Windows Authentication
    2.Disabled --> Anonymous User (Internet Windows User)

    Goto

    httP:\\nameofserver\reports

    Add a new user --> workgroup\Name of Internet User Windows (default) ISUR something (can't remember exactly)
    This user given browser rights.

    3.(Maybe not needed !) Gave default rights (read & write etc) for Visual Studio Project.

    4.Within IIS Manager, set Reports, Reportserver + Actual Project to the following:-

    1.Ticked   --> Integrated Windows Authentication
    2.Enabled --> Anonymous User (Internet Windows User)

    Checked by logging on as non-administrator user on domain.  Reports run ok by clicking on URL.  No other access rights given.  No form appearing asking for authentication.

    It works fine for this situration.

    I would not like to delete this question, as it will help others.  






    0
     
    LVL 11

    Expert Comment

    by:saleek
    Basically, you turned on Anonymous Authentication as I mentioned.
    0
     

    Author Comment

    by:ImraneA
    Yes.  But the steps to get there I figured out by myself...
    0
     
    LVL 11

    Expert Comment

    by:saleek
    There are no steps. After you turn it on thats it. There was no need to create a user or give rights - hence the term "Anonymous".

    But thats okay, as long as you're happy!
    0
     

    Accepted Solution

    by:
    Closed, 300 points refunded.

    modulo
    Community Support Moderator
    Experts Exchange
    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Why You Should Analyze Threat Actor TTPs

    After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

    Problem Statement In an SAP BI BO Integration project when a BO universe is built on a BEx query, there can be an issue of unit & formatted value objects not getting generated in a BO universe for some key figures. This results in an issue whereb…
    Jaspersoft Studio is a plugin for Eclipse that lets you create reports from a datasource.  In this article, we'll go over creating a report from a default template and setting up a datasource that connects to your database.
    This video is in connection to the article "The case of a missing mobile phone (https://www.experts-exchange.com/articles/28474/The-Case-of-a-Missing-Mobile-Phone.html)". It will help one to understand clearly the steps to track a lost android phone.
    In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…

    856 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    13 Experts available now in Live!

    Get 1:1 Help Now