IIS-//http/localhost problem

Hi, I'm working in windows 2000 professional, I intalled ISS, but when type //http/localhost nothing happen my browser is frozen. But when type ping localhost -t or ping 127.0.0.1 it work fine.

Please any suggestions
dfhernandezAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
SweatCoderConnect With a Mentor Commented:
sorry dfhernandez, i tried everything i could think of. something odd is going on with your pc. all i can think of is reinstall your entire OS, though i know that's a major pain.

i'm thinking maybe one of the following *might* be going on:

- port 80 is closed or disabled on your machine
- there is some service that iis indirectly relies on that is off or broken
- something corrupted in your registry or os
- some kind of spyware or trojan is messing with your http/tcpip/web server

wish i could be of more help.
0
 
SweatCoderCommented:
your url syntax looks incorrect. try this: http://localhost/
0
 
dfhernandezAuthor Commented:
The browser message is The page cannot be displayed. I don't thing that my problem is sintax error
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
SweatCoderCommented:
the url syntax you pasted in your question is definitely wrong. try clicking on the link in my response above and then tell me what message you get.
0
 
dfhernandezAuthor Commented:
I just type http://localhost 

the message is The page cannot be displayed
0
 
SweatCoderCommented:
create a text file: c:\inetpub\wwwroot\test.asp

inside this file, type the following:

<%
Response.Write "Asp is working!"
%>

then click this link or type in address bar: http://localhost/test.asp

. . .if you still get the broken page, go into your windows services and ensure that World Wide Web Publishing service and IIS Admin service are both running.
0
 
dfhernandezAuthor Commented:
I checked Windows services:

IIS admin service, status started
World Wide Web Publishing, status started

I created c:\inetpub\wwwroot\test.asp
I typed in address bar http://localhost/test.asp

the same message The page cannot be displayed




0
 
SweatCoderCommented:
copy/paste the entire contents of the error page and let me see.
0
 
dfhernandezAuthor Commented:
The page cannot be displayed
The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.

--------------------------------------------------------------------------------

Please try the following:

Click the  Refresh button, or try again later.

If you typed the page address in the Address bar, make sure that it is spelled correctly.

To check your connection settings, click the Tools menu, and then click Internet Options. On the Connections tab, click Settings. The settings should match those provided by your local area network (LAN) administrator or Internet service provider (ISP).
If your Network Administrator has enabled it, Microsoft Windows can examine your network and automatically discover network connection settings.
If you would like Windows to try and discover them,
click  Detect Network Settings
Some sites require 128-bit connection security. Click the Help menu and then click About Internet Explorer to determine what strength security you have installed.
If you are trying to reach a secure site, make sure your Security settings can support it. Click the Tools menu, and then click Internet Options. On the Advanced tab, scroll to the Security section and check settings for SSL 2.0, SSL 3.0, TLS 1.0, PCT 1.0.
Click the  Back button to try another link.



Cannot find server or DNS Error
Internet Explorer  
0
 
CDCOPCommented:
Can you get to your site by your IP address?
http://1.2.3.4
(That is not your IP)
Do you have any luck when you try: http://127.0.0.1

If you can, check your hosts file in C:\Winnt\System32\drivers\etc
Open the hosts file with notepad and make sure you have an entry:
127.0.0.1       localhost
0
 
dfhernandezAuthor Commented:
this my host file content:

# Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

127.0.0.1       localhost


You can see the entry exists.
0
 
SweatCoderCommented:
your IIS may be corrupted. try reinstalling it by removing it first, then install from windows cd.

IIS getting corrupted is not all that uncommon. it has happened to me probably 3 times in the past 5 years.
0
 
SevnnCommented:
Check permissions for your wwroot directory.  Open My Computer, go to inetpub, wwwroot.  Go to properties of the wwwroot directory.  Ensure IUSR_MachineName (the name of your computer) has read/list permissions.
0
 
dfhernandezAuthor Commented:
SweatCoder:

I reinstalled IIS, but the problem still here.

Sevnn:

I checked and everything is ok
0
 
SweatCoderCommented:
df, i can spare you five minutes to do a webex if you have high-speed internet and if you're interested. with webex i can see your desktop and control your mouse, and maybe i can see what's going on. if you're interested, email me at:

ee[AT]builderdash[dotcom].
0
 
dfhernandezAuthor Commented:
SweatCoder:

Ok I'll write you
0
 
dfhernandezAuthor Commented:
SweatCoder:

I found the problem, you got reason - port 80 is closed or disabled on your machine.

I uninstalled Mcafee (Antivirus, Personal firewall, Privace Service) after that i can access //http/localhost

Thank you very much for your support.
0
All Courses

From novice to tech pro — start learning today.