Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

What is wrong with my config?

Posted on 2004-11-01
8
Medium Priority
?
282 Views
Last Modified: 2013-11-16
I am trying to set up a pix to pix solution ( it used to work fine) and a pix vpn client to PIX solution.
Both are set up at the same 506e pix.

After trying to setup the Vpn client to pix the pix to pix solution has stoped working.

This is my config.

PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname aagotnes
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0
access-list nat_zero permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0
access-list 102 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside 213.184.206.164 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 192.168.1.230-192.168.1.240
pdm location 192.168.1.10 255.255.255.255 inside
pdm location 10.10.1.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 102
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 213.184.206.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set chevelle esp-des esp-md5-hmac
crypto ipsec transform-set nyset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set nyset
crypto map transam 1 ipsec-isakmp
crypto map transam 1 match address 101
crypto map transam 1 set peer 213.234.122.31
crypto map transam 1 set transform-set chevelle
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
isakmp enable outside
isakmp key ******** address 213.234.122.31 netmask 255.255.255.255
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 dns-server 192.168.1.15
vpngroup vpn3000 wins-server 192.168.1.15
vpngroup vpn3000 default-domain cisco.com
vpngroup vpn3000 split-tunnel 102
vpngroup vpn3000 idle-time 18000
vpngroup vpn3000 password ********
telnet 192.168.1.10 255.255.255.255 inside
telnet timeout 60
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:d625cf10fe52a20aca0f1f38e91adab7
: end
0
Comment
Question by:daxa78
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
8 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 12465713
Easy enough to fix:
Change your ip pool to a different subnet:
>ip local pool ippool 192.168.1.230-192.168.1.240
try:
     ip local pool ippool 192.168.2.230-192.168.2.240
                                             ^                   ^
Now, this acl makes sense:
>access-list 102 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0

You need to combine acl 102 and Nat_zero for your remote site to work at the same time:
>access-list nat_zero permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0

becomes:
     access-list 102 permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0

So now, it looks like this:
   access-list 102 permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0
   access-list 102 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
   nat (inside) 0 access-list 102


0
 
LVL 1

Author Comment

by:daxa78
ID: 12465875
But the network is in the 192.168.1.0 range why change it to 192.168.2.0 ? What is meant by the ippool ?
0
 
LVL 1

Author Comment

by:daxa78
ID: 12466030
How do i delete Ippools? and access-list entrys ?
0
WEBINAR - Latest Cyber Tips for Defense

Join the WatchGuard Threat Research Team on October 26th for an informative webinar featuring expert tips and tricks for defending your organization from today's latest cyber threats. Don't leave yourself vulnerable to attack. Register for the webinar today!

 
LVL 79

Expert Comment

by:lrmoore
ID: 12466260
Just use "no"

 no ip local pool ippool 192.168.1.230-192.168.1.240
 ip local pool ippool 192.168.2.230-192.168.2.240

 no access-list nat_zero permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0
 access-list 102 permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0

Why change it? Because the ippool is a range of IP addresses that are assigned to the VPN clients. They need to be a different subnet than your local LAN or the access-lists don't make sense.
0
 
LVL 1

Author Comment

by:daxa78
ID: 12466304
If they are in a diffrent subnet how will they access the local resources then?

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12466377
It's all magic... trust me on this one.
The client receives a route table that tells it that 192.168.1.x is available through 192.168.2.x

You may also have a problem with this:
>vpngroup vpn3000 split-tunnel 102
Change that to:
    no vpngroup vpn3000 split-tunnel 102
    vpngroup vpn3000 split-tunnel 103
    access-list 103 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0

0
 
LVL 1

Author Comment

by:daxa78
ID: 12466615
Oki i will do that. You are a wizard.

What was the line that i needed to add so that both pix to pix and the vpn client will work at the same time?

If you have any docs about pix config that someone else than cisco engineers has written...

Send them to me at garlid@nordicsol.no

Thanks once again....
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12466641
>What was the line that i needed to add so that both pix to pix and the vpn client will work at the same time?
Both the VPN client pool and the remote network subnet need to be included in the nat 0 access-list

   access-list 102 permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0
   access-list 102 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
   nat (inside) 0 access-list 102
0

Featured Post

WEBINAR - Latest Cyber Tips for Defense

Join the WatchGuard Threat Research Team on October 26th for an informative webinar featuring expert tips and tricks for defending your organization from today's latest cyber threats. Don't leave yourself vulnerable to attack. Register for the webinar today!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Wikipedia defines 'Script Kiddies' in this informal way: "In hacker culture, a script kiddie, occasionally script bunny, skiddie, script kitty, script-running juvenile (SRJ), or similar, is a derogatory term used to describe those who use scripts or…
To setup a SonicWALL for policy based routing to be used with the Websense Content Gateway there are several steps that need to be completed. Below is a rough guide for accomplishing this. One thing of note is this guide is intended to assist in the…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
Suggested Courses

598 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question