Solved

Configure sound on RDP client

Posted on 2004-11-01
307 Views
Last Modified: 2012-12-12
I have istalled windows 2003 in terminal server mode...  in test environment...  we are thinking uf upgrading to get sound.   which brings me to my question..

sound works on the server and when the client logs on the sound device is micrsoft RDP sound driver....  but it is muted and can not be unchecked.

are there some setup steps to make this work that I may have missed?

Thanks
0
Question by:Zoldy2000
    8 Comments
     
    LVL 11

    Accepted Solution

    by:
    start your Remote Desktop Connection CLient.
    Open the Options with click on "Options" :)
    select "Local Resources" Tab.
    Here you can select, where the sound should go.
    btw, you have 120 days from installation on.
    after that, your terminal server will not function without a terminal services licence server.
    you dont need TS, if 2 connections are enough for you. 2 are enabled in W2K3 per default.
    0
     
    LVL 2

    Author Comment

    by:Zoldy2000
    thanks... but I have done all of the setup steps ... it just does not work...
    0
     
    LVL 11

    Expert Comment

    by:WeHe
    you have to set this with ADSI Edit on your User Object.
    0
     
    LVL 2

    Author Comment

    by:Zoldy2000
    have to do what... sorry I do not understand what you are saying
    0
     
    LVL 11

    Expert Comment

    by:WeHe
    sorry, my last answer just went into the wrong question.
    0
     
    LVL 2

    Author Comment

    by:Zoldy2000
    anyone else have any more suggestions.  Sound is configured but when I view the sound device on the client I see RDP sound driver but it is not enable.   And I can not change it or select it as the sound device.

    Thanks
    0
     

    Expert Comment

    by:Simply_IT
    I think the reason for this is because "Audio mapping" is disabled on the RDP_Tcp Properties of the server. If you log into the server and do the following (Click on START-->All Programs-->Administrative Tools-->Terminal Services Configuration-->(The tscc window opens)--> Click on "Connections:-->Right Click "Properties" on RDP=Tcp-->Select the "Client Settings" tab-->remove the check next to "Audio Mapping" under "Disable the following:"-->Click "OK"

    Then just log out and log back in and there should be sound. That's what fixed this issue for me! Hope that helps
    0
     

    Expert Comment

    by:billfromgnet
    Was having exact same issue and this fixed it for me.  Thank you!
    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone. Privacy Policy Terms of Use

    Featured Post

    Free Trending Threat Insights Every Day

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    The HP utility "HP Lights-Out Online Configuration Utility for Windows Server 2003/2008" could be of great use when it comes to remotely configure a HP servers ILO WITHOUT rebooting the server. We would only need to create and run scripts using thi…
    Learn about cloud computing and its benefits for small business owners.
    With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
    In this sixth video of the Xpdf series, we discuss and demonstrate the PDFtoPNG utility, which converts a multi-page PDF file to separate color, grayscale, or monochrome PNG files, creating one PNG file for each page in the PDF. It does this via a c…

    877 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now