NTFS drive permissions (played around and changed some stuff, no im locked out)

hi im new here!
well I have my external USB hard drive, which is actually a normal hard drive connected to an USB to IDE converter, with a mini PSU. I use it with my windows XP PRO based PC, so it is formated with NTFS.

Over the months since i've had it, i've been playing with the permission (right click, properties, security, etc). Now i don't know what i've done with it, (on 2000, not xp) but i can't open any folders, and even the majority of files (some in the root can be accesed, but they are the only ones) give me "Access Denied".
Do i have to repair permissions? if so, how? what programs do i use?

i tried
http://support.microsoft.com/default.aspx?scid=kb;en-us;266118 
i get to item 8 and Import Template is greyed out... (on the 2k machine i am using at the moment, will have my XP machine in a week)

I really need to access the contents of my drive, because its got my work, music, and my downloads.

thanx you guys (and gals )!

p.s. i only have 125 points to give, so here they are :), however i think its "difficult" difficulty.
alien_ghostAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lee W, MVPTechnology and Business Process AdvisorCommented:
Provided you haven't played with encryption, this is actually quite easy.  

This describes how to fix this from an XP system - the procedure should be similar for 2000
-----------------------------
*Go to My Computer
*Right click the drive letter for your eexternal USB drive and select "properties"
*In the window that appears, select "security"
*Make sure there is a checkbox so that "everyone" has "full control"
*Click the advanced button
*Place a check in the box to "Replace permission entries on all child objects with entries shown here that apply to child objects"
*Click OK

This should reset the permissions
0
Steve McCarthy, MCSE, MCSA, MCP x8, Network+, i-Net+, A+, CIWA, CCNA, FDLE FCIC, HIPAA Security OfficerIT Consultant, Network Engineer, Windows Network Administrator, VMware AdministratorCommented:
What I find works many times is to go into the Security and look for the Ownership tab.  In XP it's under the advanced settings.  Anyway, what you want to do for the drive is to force it to take Ownership of all the files and directories.  There should be a box to replace owner on the subcontiners and objects.  Once you take ownership of the files and directories, go back into the permissions and give whatever permissions, Administors, everyone, etc., to the drive and let it reset all the permissions on all files and folders.  Once completed, you should be able to see and access all your files.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LucFEMEA Server EngineerCommented:
Hi alien_ghost,

You most likely have ownership allready as you where able to set the permisions. Most likely you set some to "denied"
When you start playing with permissions, please keep in mind only to set "Allow" unless you have any good reason to set something to denied.

Ok, now for the recovery, try doing the following.
Right-click the drive and choose "Properties" => "Security" => "Add" (here add the Administrative account you're using) and remove all other accounts (especially the ones you set to denied somewhere) Then set the permissions to "Full Control"
Then, last but not least, choose "Advanced" and there tick the "Reset permissions on all child objects and enable propagation of inheritable permissions"
Click OK, then OK (let it copy all permissions)

Now you should be able to access all again.

Greetings,

LucF
0
Hey MSSPs! What's your total cost of ownership?

WEBINAR: Managed security service providers often deploy & manage products from a variety of solution vendors. But is this really the best approach when it comes to saving time AND money? Join us on Aug. 15th to learn how you can improve your total cost of ownership today!

LucFEMEA Server EngineerCommented:
Hmm... I'm a bit slow today :)
Sorry leew.
0
alien_ghostAuthor Commented:
i tried the first suggestion, but it comes upo with error messages on some of the files/folders:

An error occured attempting to read directory:
d:/some directory
Access is denied
Continue Cancel

and

An error occured applying security information to:
d:/some directory
Access is denied
Continue Cancel

Same thing came up when i tried the second option. :(

any other tips?
0
LucFEMEA Server EngineerCommented:
So... you denied ownership on some folders.
Taking ownership should work for at least one Administrative account (if you have more accounts on your computer, try another one)
There will always be someone with ownership on the folders/files that will have the access to change the permissions.

LucF
0
Lee W, MVPTechnology and Business Process AdvisorCommented:
Use Samccarthy's suggestion regarding the taking ownership process.  However, I've seen instances where it chokes unless you go DIRECTLY to the folder it chokes on and tell it THERE to change the permissions/owner.  This may mean sitting there and writing those folders down.
0
alien_ghostAuthor Commented:
thanx u guys, i sahll give that a go, when i get to my XP machine (im using the school's 2k machine (boarding school, that's why im at school at 22:00), to which i hav'n'y got admin rights), and use other Admin accounts. i shall try that and then shell out some points :)
once again, thanx
0
LucFEMEA Server EngineerCommented:
Good luck alien_ghost and let us know what you find.
My responce might be late as it's 23:08 here (in the Netherlands) and I have to get up early tomorrow, but I'm sure you're in good hands here.

LucF
0
calibrateCommented:
I tried all of the above as I found myself in the same dumb situation.  The process described by leew and by just taking ownership by clicking directlly on the directory/folder in question. Once I did that - all is good.  Thanks for the tips!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
OS Security

From novice to tech pro — start learning today.