• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 337
  • Last Modified:

Bind DNS Server seems to be limited to 50 hosts

I'm running a minimal install of redhat 9 with Bind 8 and webmin (for the customer) as a dns server. (times 2 in two locations)

Currently we have 50 domain names held here, but when I went to add number 51, this domain would not transfer to the slave DNS server, nor can I dig that domain..

I have tried increasing the maximum open files setting, the maximum data memory usage etc. etc. but with no result..

In the log files there is the following:-

Nov  1 14:14:42 ns1 named[1163]: zone example.com.au/IN: loading master file /var/named/example.com.au.hosts: unexpected end of input
Nov  2 12:03:20 ns1 named[1163]: dns_rdata_fromtext: /var/named/example.com.au.hosts:13: near eol: unexpected end of input


All existing domains are still working fine and I'm sure I've missed something simple.

Cheers
Zaneyfunster
0
zaneyfunster
Asked:
zaneyfunster
1 Solution
 
jlevieCommented:
This isn't a matter of the open files limit, but rather a problem with /var/named/example.com.au.hosts. At or around line 13 of that file there's an error that is the cause of the problem. If you post the contents of that file we should be able to tell you what's wrong with it.
0
 
zaneyfunsterAuthor Commented:
Hey jlevie..

I'm really sorry about the delay, I've been overseas...

Yes you are correct..
I was using Webmin to generate the hosts files and something had gone wrong, it was creating a really dodgy MX record on line 13.

I manually created a host file, and it worked, re-installed webmin and it is now back to normal and working fine.

I should have spotted the problem but at the time I was in a state of panic ;o)

Cheers
Shane
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now