Solved

Keyboard not recognized - can't login to Windows 2000

Posted on 2004-11-02
2,325 Views
Last Modified: 2012-08-14
Hi all,

I have a W2K machine, all SP's & fixes installed.

In the weekend, I decided to do some housecleaning & sort out all the cables etc under my desk. I unplugged all cables, sorted them, an plugged them all back.

The USB devices, quite a lot of them, were not plugged back into the sockets/hubs they originally were in.

When I boot now, the BIOS recognizes the keyboard & mouse, but at the login-screen neither the keyboard nor mouse are recognized.

The keyboard works, I've tested on an other machine.

My take on this is that usually when you move a device from one USB socket to another, the device drivers are often  reinstalled. Could it be that the system wants to reinstall the device drivers, since I moved the keyboard to another socket, and can't do this, since I haven't logged in?

(I've tried to put all back as they were, but the keyboard is still dead. I've also
tried all alternative sockets to stick it in, still no go)


The interesting bit is that a normal PS/2 keyboard also does not work.
It works in the BIOS/setup screens, it works when I press "f8" at the W2K screen,
but does not work at the login screen.

I've tried all three "Safe Modes", the keyboard is still dead in all of them.
The PS/2 keyboard is dead, too.

PS/2 works as far as enabling me to select "Safe Mode".
With only USB keyboard plugged in, pressing F8 has no effect..

I tried unplugging everything but a PS/2 keyboard, still the same.



The "toggle" keys/lights such as Caps/Numlock etc stay frozen after W2K boots, they can be toggled as far as the F8 prompt, with the PS/2 keyboard.

I didn't muck with the BIOS when the problem arose, I just unplugged cables, and plugged most of them back in, in different sockets from  where they originally were. I also removed one USB hub, and one game controller.


Since the problem started, I've been into the BIOS and tried to put everything as vanilla as I can, making sure that PS/2 mouse is enabled, that USB legacy is OK. I'm not overclocking (now), and I've even reduced the USB speed.


What really worries me is that I apparently have lost support for PS/2 keyboard, I would think that "always" was good.
I'm not sure what type of keyboard I had when I installed the OS, it *might* have been the USB, but I'm not sure..
 
Story:
1) With only USB keyboard installed:
PC boots normally to W2K login screen. Keyboard is dead, no lights, nothing. The keyboard is not broken, though, since it works on an other PC.

2) With only PS/2 keyboard installed:
PC boots, lights come on, I can toggle lights until W2K starts the graphical part of the boot process, they the lights freeze in the state they were in.

Before W2K boots, I can use the PS/2 keyboard in the BIOS and in the F8-boot options menu.

The PS/2 keyboard also works normally on an other W2K machine.
 
PS/2 mouse, and USB legacy support is enabled in the BIOS.
 
And I doubt there is a HW problem - the keyboard works without problems before W2K graphical boot starts.

At the W2K login-window the mouse does NOT work, there is no cursor.

When the PC boots, the BIOS reports the mouse if it is connected on USB.
 
(I started this problem in the W2K group, had no go there:
http://www.experts-exchange.com/Operating_Systems/Win2000/Q_21190018.html)
0
Question by:thoger
    18 Comments
     
    LVL 28

    Expert Comment

    by:burrcm
    Jump into the bios, reset to defaults. Set it to halt on all errors. Does it boot to login now, or stop posting with a keyboard error? Try it with only mouse conected and only keyboard connected. Make sure that you are plugging the keyboard into the keyboard ps2 port, not the mouse one - there should be a bit of a picture stamped on the case, or the sockets will be colored green for mouse and purple for keyboard.

    Chris B
    0
     
    LVL 22

    Expert Comment

    by:DanCh99
    I had some odd problems where my usb keyboard was fine in Windows, but wouldn't work on the Recovery Console screen.  I had to change the BIOS settings that related to USB to the *opposite* of what seemed sensible, and then it was fine.  
    I can check the settings exactly when I get home ('bout 8 hours from now)
    0
     
    LVL 31

    Expert Comment

    by:rid
    If the PS/2 KB works in BIOS setup - then the hardware is OK. This seems very much like a w2k problem. Can you get any mouse to work in windows? If so perhaps you can navigate with the mouse and uninstall all KB and USB-related hardware and let windows re-detect it.

    I suggest you try with all USB things disconnected, no mouse but *only* the PS/2 keyboard connected. Verify that it works in BIOS and the earlier windows startup stages. Will it work when windows is up and running?
    /RID
    0
     
    LVL 1

    Expert Comment

    by:Godxilla2001
    You may try to boot to the last known good config. See if it restores the use of the Keyboard.
    0
     

    Author Comment

    by:thoger
    OK, we're making some progress.

    I did the reset of the BIOS, then tried all sorts of combinations of PS/2 & USB mouse & keyboard, to no avail.

    Then I decided to repartition with Acronis, create a small 5 GB partition, install W2K on that, and try a restore.
    Acronis reported "File system error: Runlist corrupted" on drive C:. Aha!!!

    Boot from CD, got to recovery console, chkdsk/p.

    Boot again, and now atleast the mouse is working. If I didn't have a password, I'd be in :-)

    I'm running repartitioning now, will install & have look when it's done.

    I have a week old backup of \winnt, \docs&settings \program files & System State.

    I intend to restore all .dll's .vxd's etc in  \winnt, first, and see if that helps.
    If not, I'll try \winnt\* \Program Files\ + System State

    Problem is: I have some rather bad experiences restoring W2K from backups,

    I usually have lost most settings etc, much like "last know good config". (When that has done anything worthwile at all, that is)

    Any comments?
    0
     

    Author Comment

    by:thoger
    One more thing: What's a "corrupted runlist", anyway?

    All references I find are to NTFS combined with Linux, which makes sense, since Acronis
    standalone is Linux-based. What would scandisk say for the same problem?
    0
     
    LVL 31

    Expert Comment

    by:rid
    This is pretty obviously not hardware, as input devices work up to a certain point. It is probably driver related and I see a few possibilities (others may se something else...):
    1) Accidentally, clashing drivers may have been installed and the input devices are disabled at a point where these conflicting drivers are loaded.
    2) A hardware conflict arises when drivers are loaded and activate USB and/or PS/2 devices
    3) When all USB drivers are loaded, the drain on the 5 V bus becomes too heavy, and the KB cannot work properly.

    You could try starting up with a "Live CD" operating system (like Knoppix) to see if KB/mouse can work OK at all  in a GUI. If yes, your win2000 install may indeed be damaged.
    /RID
    0
     

    Author Comment

    by:thoger
    Acronis is Linux-based, and when I boot from the CD, USB keyboard & mouse works well
    That means we've ruled out hardware, actually.

    I tried the repartitioning tonight, and it appears to have aborted. There were no messages, and the process was not finished. I wouldn't be surprised if the damn cat has stepped on the ESC key..

    Plan B: Install W2K on to drive D:. This failed, since Drive D: is 200GB, and W2K unpatched doesn't like that.

    Plan C: Either go "Last known good..." or "Repair" from the CD.
    What is most likely to end up with a good system?
    0
     
    LVL 31

    Expert Comment

    by:rid
    "What is most likely to end up with a good system?"

    Good question.... I haven't had to try out either one. One would think "Repair" should be the more powerful utility, but perhaps you will lose some settings and such. If you've tried repartitioning, you're perhaps not too concerned about that. A clean reinstall, maybe?

    /RID
    0
     

    Author Comment

    by:thoger
    The repartitioning with Acronis retains data well, no problems.
    I would like not to loose too many settings & have to live with a semi-good system with lots of conflicts in the next months.

    There is no user data on the disk (apart from Docs&Settings), this is on other disks.

    I'll try the repair & restore, wish me luck.

    (And check out Acronis, it's good stuff)
    0
     

    Author Comment

    by:thoger
    And that didn't work :-(

    I booted from CD, did chkdsk /r then "automatic recovery".

    This appears to have completed, then rebooted.

    Then when it booted, it apparently went through all disks and did a scandisk, for about 1-2 hours (500GB of data).

    Then: Login-screen, mouse OK, no keyboard..
    0
     

    Author Comment

    by:thoger
    Right, I'm about to give up..

    Install spare harddrive, move original C: to secondary channel. Install W2K on spare drive,
    restore  \winnt, \Docs&Setts, systemstate to old C:

    Still no keyboard??

    I did a "replace everything, please", with .dll's, .exe's, registry, the lot.
    Where's the problem? \Program Files??

    Is there any way to tell W2K to "please, do NOT try to load anything from Startup, Registry->Run/RunOnce"?

    By pressing some magic combination as it boots, perhaps?
    0
     

    Author Comment

    by:thoger
    OK, that's it. Where's that axe..

    1) installed W2K into \winnt
    2) Restored from backups (three times, NTBACKUP kept crashing)
    3) Started installing drivers again
    4) Got them all in. Last to go: USB.
    5) WHOMP! system froze as drivers were installed..

    0
     

    Author Comment

    by:thoger
    By now I guess I'm talking to myself.

    I had it installed, restored, fixed, and all drivers were in.

    Then I discovered that some devices were installed 3-4-5 times, and proceeded to uninstall the extras.

    WHOMP! Here we go again..


    What the F*** is causing this??
    0
     
    LVL 31

    Accepted Solution

    by:
    This is only for USB keyboard or all USB devices?
    Does the WHOMP happen even with a PS/2 keyboard installed (instead of USB)?

    And you say this does not happen in the Acronis environment....

    Is it possible that the USB controller is not quite w2k compliant?

    Could it be that it is still a matter of current draw - as accessories/drivers are activated the ports are put under a too heavy load and fold... Are you running some things off a powered hub? Can you try doing so?
    /RID
    0
     

    Author Comment

    by:thoger
    Hi all,

    OK, I think we're about done, at least as far as we're going to get.
    A few weeks ago I had three power losses in a  week, and the PC lost power while up & running.
    My take on this is that this probably screwed up the disk(s), and scandisk/chkdsk was unable to fix the problems.
    This has led to corrupted registry/config in the area of USB, and when I shut down/started up for doing the cables,
    I ran into these problems, that actually had nothing to do with the re-cabling.

    I've now installed W2K again, and restored from backups.
    The system appears to run well, and I've re-installed all drivers that a restore apparently does not restore for you.
    I still have a few more USB-devices in Device Manager than I think I should have, but I'm leaving them alone
    for now. I also have a USB root HUB listed in Device Manager that really should not be there, but I'm leaving that, too.

    I don't think the system is very healthy, and I see a format/reinstall without restore in  my future, but I'll postpone that
    for a more convenient time.

    Thanks to all who helped. I'm awarding the points to RID, for staying with me until the bitter end.

    (And RID: The MB is new, a ASUS K8N-E Deluxe, and there are no power issues, this happened also with only the KBD
    attached. And a lesson for the future: NEVER install a system with only USB Keyboard attached. That's why the PS/2
    keyboard didn't work: The drivers were not installed when I set up the system, since I then was using a USB keyboard.)
    0
     
    LVL 31

    Expert Comment

    by:rid
    Aha. One would have expected legacy hardware like a PS/2 KB to work without specific drivers, but apparently not so in this case (w2k). Thank you for the points. Hope your system will behave... :)
    /RID
    0
     
    LVL 22

    Expert Comment

    by:DanCh99
    Thanks for adding in all the updates.  I'll make sure to add a ps2 keyboard to my working XP systems, just to get the drivers installed, so they'll work when USB bites the Big One....  I've seen a few other Q's around on similar issues, and it will come in handy there too.  good luck with the rebuild.
    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    What Security Threats Are You Missing?

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    Windows 7 does not have the best desktop search built in. This is something Windows 7 users have struggled with. You type something in, and your search results don’t always match what you are looking for, or it doesn’t actually work at all. There ar…
    No matter the version of Windows you are using, you may have some problems with Windows Search running too slow or possibly not running at all. Before jumping into how you can solve this issue, just know there are many other viable alternative deskt…
    With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
    This video Micro Tutorial is the first in a two-part series that shows how to create and use custom scanning profiles in Nuance's PaperPort 14.5 (http://www.experts-exchange.com/articles/17490/). But the ability to create custom scanning profiles al…

    856 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    9 Experts available now in Live!

    Get 1:1 Help Now