[Webinar] Streamline your web hosting managementRegister Today


printing problems at windows 2000 domain, event id 61, code 3003

Posted on 2004-11-02
Medium Priority
Last Modified: 2012-05-05
here's what I've got:
-AD domain (just one) with 2 DCs (windows 2000 server sp4+)
-plenty of workstations: win2000 & XP & mac OSX
-3 network printers: hp laserjet 4mv, hp laserjet 4000 and huge xerox colorlaser with Mac OSX controlling it
-one DC has network printers (and drivers) installed & shared

Domain used to be NT4 domain which was updated to win2000 domain and printing worked ok. After one HW-failure I had to rebuild the domain, so no it is clean-installed windows 2000 domain, although mixed-mode.
HP Laserjets won't print bur xerox does. If I log in to any workstation as Administrator all printers work, but as an regular user, I'll get (Event Viewer) following printing error:

The document Untitled - Notepad owned by <username> failed to print. Win32 error code returned by the print processor: 3003 (0xbbb).  
(I checked that this means that print processor is unable to send data to printer port)

All users of domain are in CORPUSERS (domain global) group and "print" permissions for CORPUSERS are granted to both Laserjets. Won't work. I even tried to grant full control for CORPUSERS, and still no luck.
Then created an PRINT (domain local) group with CORPUSERS as members and granted "print" permissions for both printers to PRINT-group. Nothing changed.

I tracked error situation and found that spoolsv.exe is actually creating two files to spool dir:

After an about 1 minute, I'll get an error message, and after I cancel (or retry n-times & cancel) the job, spool-files are deleted.

Printer drivers are from HP and installed via "HP Install network printer Wizard"

a) What am I not understanding?
b) Does anyone have solution for me?
If not, can someone tell me what *really* happens when domain-workstation prints document to printserver (spools, temp-dirs, re-processing, permissions?)

Thank you already!

Question by:mkuutti

Expert Comment

ID: 12471839
You may have already looked at these, but...

If your running Terminal Services on the DC used as print server....this may OR MAY NOT help...

This one is specific to windows 2003, BUT, has serveral useful links included to help you with events 61
LVL 20

Accepted Solution

Debsyl99 earned 1000 total points
ID: 12472135
Potential solutions listed here and well worth working through. It may be worth checking on the port configuration for the hp printers - check that the ip is listed rather than a dns name.
Event ID: 61

Deb :))
LVL 20

Expert Comment

by:Zaheer Iqbal
ID: 12472405
It has to be a rights issue ...??? double check rights and permissions...
LVL 20

Expert Comment

by:Zaheer Iqbal
ID: 12472414
Check permissions on each user????

Author Comment

ID: 12472831
Thanks Deb and all others. My 3-month battle against evil windows is over.

I had really tried almost everything exept printer port settings. That was the thing, both HP-printers started working after I changed IP instead of an DNS-name. Printer had static IP and it's dns name was correctly set up at dns-server.

So it seems that domain users (excluding Domain Admins) have no permission to run nslookup or wins-query. Why? Only Bill knows... On the other hand, Xerox had an lpr-type port which had dns-name on it and it worked just fine all time. Does not make sense, but that's life with windows...

Oh boy, I was happy to hear that old sun-burned 4MV moaning after clicking "print".

Featured Post

Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
You do not need to be a security expert to make the RIGHT security. You just need some 3D guidance, to help lay out an action plan to secure your business operations. It does not happen overnight. You just need to start now and do the first thin…
SQL Database Recovery Software repairs the MDF & NDF Files, corrupted due to hardware related issues or software related errors. Provides preview of recovered database objects and allows saving in either MSSQL, CSV, HTML or XLS format. Ensures recov…
This video tutorial shows you the steps to go through to set up what I believe to be the best email app on the android platform to read Exchange mail.  Get the app on your phone: The first step is to make sure you have the Samsung Email app on your …

607 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question