Access violation

 I am using Borland c++ builder 6 and have reacently encountered an access violation when trying to compile various programs. The following message appears in a window:

" Access violation at address 00C8A365 in module 'COMP32P.Dll. Read of address 726F6254"

The error first appeared when trying to complie an old program which had previously always ran fine with no bugs. After this, all other programs would still compile but after re-saving and trying to compile them the above message would appear. This also went for any new programs I  wrote, they at first complied with no problems, but after saving them the error occured.

I have tried to re-install Borland c++ builder 6 and tried putting the COMP32P.Dll in the same location as my executable file, but neither seemed to have an effect as the error still occurs.

Have you idea what is causing this Access violation, Thanks?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Do you have any custom components installed on the toolbar?

I've experienced this before. Sometimes it was caused by an installed custom package that was doing something like this:

    throw "Some text";

Changing that to:

    throw Exception("Some Text");

fixed it.

Not that it could be the only reason.

Also, disable the class browser and the code insight features to see if it helps.
Try disabling or enabling the Debug options on the Project properties. Play with all the compiler flags, too. You may find the solution yourself.
George TokasCommented:
I think this is a message in release build..
Make a debug build and see from the IDE if it is causing again the same message...
A few secs ago I had a phone from the other place I work and have a similar problem with BCB6...

Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

nottifAuthor Commented:

I have tried all the suggestions but none have worked so far. Just a bit more information, I am using Helix's OpenGL components with BCB6 and windows XP !
I had a similar problem. Its not related to custom components.
I did not get the error after installing C++Builder 6 Update Pack 4. Try it out.

Visit this site formore info.,1410,29793,00.html
nottifAuthor Commented:

My Borland C++Builder 6 softwear was the free downloadable trial so I could not install the update pack. However, i  no longer get the error message. Un-installing and then re-installing my OS seemed to do the trick!!!

Thanks however, to everyone for there suggestions.
You should ask for points refund then :)
George TokasCommented:
PAQed with points refunded (500)

Community Support Moderator

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Editors IDEs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.