Access to Analysis Cubes is denied????

Hallo Experts,

it is a very strange Problem. I dont know how to figure out the problem.
We made a website with different Reports (XP - Webcomponents, Pivottable).
Recordsource from the Pivottable
Provider=MSOLAP.2;Integrated Security=SSPI;Persist Security Info=False;Data Source=MCWWTKDKSQL;Initial Catalog=GB_Plus;Client Cache Size=25;Auto Synch Period=10000

Setting from the Analysis Server
'Repository'
Local:
Provider=Microsoft.Jet.OLEDB.4.0;Data Source=E:\Program Files\Microsoft Analysis Services\Bin\msmdrep.mdb
Remote:
Provider=Microsoft.Jet.OLEDB.4.0;Data Source=\\MCWWTKDKSQL\MsOLAPRepository$\msmdrep.mdb

We are working in a firm-network. So everyone can ping the server, also the collegues in GreatBritain. But they get no access to the analysis server.
They got all rights to have access, but the collegues in GB get the message
"The Pivottable list "Bonus" could not connect to the data Source "Bonus". For information...."
"0x80004005: Cannot connect to the server mcwwtkdksql. The server is either not started or to busy"

The analysis server is started and the the server isn't  ot busy.

They have also access to the SQL-Server, that works fine.

It is a nightmare. Do you know what to do? Thanks in advance

best regards

Klaus Schulze


schulzekAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Duane LawrenceCommented:
It sounds like it is a permissions problem.  Try granting access to the user the program is using.

D
0
wael_tahonCommented:
1:
open
C:\Program Files\Microsoft Analysis Services\Bin

and copy the msolap.asp to the IIS root on the server

2:
when you are setting the connection from the webcomponent
Server Name:   http://YourServer/
UserName:    appropriate User
Password: appropriate  Password

I'm using this technique to avoid opening firewall and use http

Note you must have SQL Server 2000 Enterprise

Best Regards
Wael Tahon
0
wael_tahonCommented:
I forgot you must use MS OLEDB Providor for OLAP Services 8.0 Driver
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

schulzekAuthor Commented:
comment ot wael tahon
I copied the file into c:\inetpub\wwwroot

I have the SQL Server Developer - is that working with your suggestion?
Which provider should i take ? Olap?

Klaus
0
wael_tahonCommented:
I didn't test it with developer edition but it work with me on enterprise edition

Providor name: Microsoft OLEDB Providor for OLAP Services 8.0 Driver ( MSOLAP.2 )
0
schulzekAuthor Commented:
I think it is working with the Developer.
But if have no entry in the initial catalog. Made i anything wrong?
0
wael_tahonCommented:

Ok lets try to make it using excel first to see if you have a problem:

Open MS Excel
Data menu -> PivotTable and Pivot Chart Report -> "Choose External Datasource" option
Next -> Press "Get Data" button -> Choose "OLAP Cubes" Tab -> Double Click on "new datasource"
Give a name to your datasource -> Select "Microsoft OLEDB Providor for OLAP Services 8.0"
In the server name type "http://YourServer/" -> Enter the username and password
Choose your database -> The select your Cube -> Ok -> Next -> Finish
0
schulzekAuthor Commented:
Hallo weal tahon,
what settings have to be made in the IIS. I think about the Anonymous access / Atuthenticated access

best regards

Klaus
0
wael_tahonCommented:
Whatever setting you choose for authontication you must provide user name and password of a use in the same domain of the server
0
MichaelSFullerCommented:
On your IIS server is this a seperate box? if so you have to make sure that COM+ is setup correctly, for the pivot control service to authenicate properly.
0
schulzekAuthor Commented:
Hallo weal_tahon,

thanks a lot for your big help. The solution works very fine.
Best regards from munich

Klaus Schulze
0
wael_tahonCommented:
I'm happy that it works now

Best regards from Cairo

Wael Tahon
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.