Solved

Creating vpn between two pix 501's

Posted on 2004-11-02
357 Views
Last Modified: 2013-11-16
Hi,

I'm trying to connect two pix 501's using vpn.

The vpn comes up with no errors, but I simply cannot transmit traffic over them. It just times out.

Here are the configs:
------------------
top pix

PIX Version 6.3(3)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname top
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip 192.168.60.0 255.255.255.0 192.168.40.0 255.255.255.0

access-list 101 permit ip 192.168.40.0 255.255.255.0 192.168.60.0 255.255.255.0

pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 192.168.10.2 255.255.255.0
ip address inside 192.168.40.55 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.40.0 255.255.255.255 inside
pdm history enable
arp timeout 14400
nat (inside) 0 access-list 101
route inside 0.0.0.0 0.0.0.0 192.168.40.1 1
route outside 192.68.60.0 255.255.255.0 192.168.10.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.40.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set fixitagain esp-des esp-md5-hmac
crypto map turbo 1 ipsec-isakmp
crypto map turbo 1 match address 101
crypto map turbo 1 set peer 192.168.10.1
crypto map turbo 1 set transform-set fixitagain
crypto map turbo interface outside
isakmp enable outside
isakmp key ******** address 192.168.10.1 netmask 255.255.255.0
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
telnet 192.168.40.0 255.255.255.255 inside
telnet 192.168.40.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
username admin password ******** encrypted privilege 15
terminal width 80
Cryptochecksum:87a8ca7f9a9be0712fe44f8209738b4d
: end
top#

------------------------------------
bottom pix

PIX Version 6.3(3)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ********* encrypted
passwd ********** encrypted
hostname bottom
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip 192.168.60.0 255.255.255.0 192.168.40.0 255.255.255.0

access-list 101 permit ip 192.168.40.0 255.255.255.0 192.168.60.0 255.255.255.0

pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 192.168.10.1 255.255.255.0
ip address inside 192.168.60.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
route outside 0.0.0.0 0.0.0.0 192.168.10.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.60.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set nowaymofo esp-des esp-md5-hmac
crypto map shamone 1 ipsec-isakmp
crypto map shamone 1 set peer 192.168.10.2
crypto map shamone 1 set transform-set nowaymofo
! Incomplete
crypto map shamone interface outside
isakmp enable outside
isakmp key ******** address 192.168.10.2 netmask 255.255.255.0
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
telnet timeout 5
ssh timeout 5
console timeout 0
username admin password ********** encrypted privilege 15
terminal width 80
Cryptochecksum:13333c5a943b3749c4928b0f458f1a45
: end
bottom#



SOS
0
Question by:cddps
    7 Comments
     
    LVL 79

    Expert Comment

    by:lrmoore
    You need to add an acl on each side:

    TOP PIX, add:
       access-list 102 permit ip 192.168.40.0 255.255.255.0 192.168.60.0 255.255.255.0
       crypto map turbo 1 match address 102

    Then re-apply the crypto map to affect the changes:
       crypto map turbo interface outside



    BOTTOM PIX, add:
       access-list 102 permit ip 192.168.60.0 255.255.255.0 192.168.40.0 255.255.255.0
       crypto map shamone 1 match address 102

    Then re-apply the crypto map to affect the changes:
       crypto map shamone interface outside
    0
     

    Author Comment

    by:cddps
    Hi,

    I've done that now.

    But I still can't get through the pix's, the vpn comes straight up, it must be something glaringly obvious.

    Here are the latest configs:

    -------------------------------------
    Top

    PIX Version 6.3(3)
    interface ethernet0 100full
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname top
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list 101 permit ip 192.168.40.0 255.255.255.0 192.168.60.0 255.255.255.0

    access-list 102 permit ip 192.168.60.0 255.255.255.0 192.168.40.0 255.255.255.0

    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 192.168.10.2 255.255.255.0
    ip address inside 192.168.40.55 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm history enable
    arp timeout 14400
    nat (inside) 0 access-list 102
    route inside 0.0.0.0 0.0.0.0 192.168.40.1 1
    route outside 192.68.60.0 255.255.255.0 192.168.10.2 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http server enable
    http 192.168.40.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    no snmp-server contact
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set fixitagain esp-des esp-md5-hmac
    crypto map turbo 1 ipsec-isakmp
    crypto map turbo 1 match address 102
    crypto map turbo 1 set peer 192.168.10.1
    crypto map turbo 1 set transform-set fixitagain
    crypto map turbo interface outside
    isakmp enable outside
    isakmp key ******** address 192.168.10.1 netmask 255.255.255.0
    isakmp policy 1 authentication pre-share
    isakmp policy 1 encryption des
    isakmp policy 1 hash md5
    isakmp policy 1 group 1
    isakmp policy 1 lifetime 1000
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    username admin password hVaczTlgs9v6Ux3t encrypted privilege 15
    terminal width 80
    Cryptochecksum:c87bcbcd7c077b9a31d74a38b776775c
    : end
    top#

    --------------------------
    bottom

    PIX Version 6.3(3)
    interface ethernet0 100full
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname bottom
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list 101 permit ip 192.168.40.0 255.255.255.0 192.168.60.0 255.255.255.0

    access-list 102 permit ip 192.168.60.0 255.255.255.0 192.168.40.0 255.255.255.0

    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 192.168.10.1 255.255.255.0
    ip address inside 192.168.60.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm history enable
    arp timeout 14400
    nat (inside) 0 access-list 102
    route outside 0.0.0.0 0.0.0.0 192.168.10.1 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http server enable
    http 192.168.60.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set nowaymofo esp-des esp-md5-hmac
    crypto map shamone 1 ipsec-isakmp
    crypto map shamone 1 match address 102
    crypto map shamone 1 set peer 192.168.10.2
    crypto map shamone 1 set transform-set nowaymofo
    crypto map shamone interface outside
    isakmp enable outside
    isakmp key ******** address 192.168.10.2 netmask 255.255.255.0
    isakmp policy 1 authentication pre-share
    isakmp policy 1 encryption des
    isakmp policy 1 hash md5
    isakmp policy 1 group 1
    isakmp policy 1 lifetime 1000
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    username admin password hVaczTlgs9v6Ux3t encrypted privilege 15
    terminal width 80
    Cryptochecksum:e701ed642de96d61f6218171c93ae0f9
    : end
    bottom#

    ----------------------------


    cheers,
    steven
    0
     
    LVL 79

    Accepted Solution

    by:
    Couple of things:

    You didn't do exactly as I suggested. You now have the same acl (102) applied to two different processes - crypto and nat.

    TOP:
      This current 102 access-list is backwards anyway:
        no  access-list 102 permit ip 192.168.60.0 255.255.255.0 192.168.40.0 255.255.255.0
      should be:
        access-list 101 permit ip 192.168.40.0 255.255.255.0 192.168.60.0 255.255.255.0
        access-list 102 permit ip 192.168.40.0 255.255.255.0 192.168.60.0 255.255.255.0
        nat (inside) 0 access-list 101
        crypto map turbo 1 match address 102
    Don't put the next hop for the remote LAN yourself, make the truely the next hop
        route outside 192.68.60.0 255.255.255.0 192.168.10.1 1

    This entry tells me that since this is just a test environment, this PIX might not be the PC's default gateway:
    >route inside 0.0.0.0 0.0.0.0 192.168.40.1 1
    If that's true, then on your test PC, or on the router that is 192.168.40.1, you must add a static route entry for the 192.168.60.0 network, or on the testing host, add a static route..


    BOTTOM:
        This current 101 access-list is backwards anyway:
        no  access-list 101 permit ip 192.168.40.0 255.255.255.0 192.168.60.0 255.255.255.0
      should be:
        access-list 101 permit ip 192.168.60.0 255.255.255.0 192.168.40.0 255.255.255.0
        access-list 102 permit ip 192.168.60.0 255.255.255.0 192.168.40.0 255.255.255.0
        nat (inside) 0 access-list 101
        crypto map turbo 1 match address 102
    Don't point your default gateway to yourself:
       route outside 0.0.0.0 0.0.0.0 192.168.10.1 1
    Make it the other PIX
       route outside 0.0.0.0 0.0.0.0 192.168.10.2 1



    0
     

    Author Comment

    by:cddps
    Your are a bloody genius.

    ITS NOW WORKING :D

    I owe you a number of beers!!!!!

    Thanks,
    Steven
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Hmm.... that's twice I've earned beer for helping set up a back-back pix vpn in a lab setting...
    Hic!
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Don't forget to come back and "Accept" a comment and grade appropriately. I don't get credit for the Q until it's closed, and only you can close it.

    Thanks!

    0
     

    Author Comment

    by:cddps
    :-D
    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Anonabox PRO Tor & VPN Router

    PRO is the most advanced way to fortify your privacy and online anonymity by layering the Tor network with VPN services. Use both together or separately, and without needing to download software onto your devices.

    Suggested Solutions

    Title # Comments Views Activity
    IOS upgrade limitations 5 48
    suspending the anti virus 6 76
    Cisco ASA 5505 with Verizon Fios 10 47
    L2/L3 Switch configuration 4 78
    If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
    From Cisco ASA version 8.3, the Network Address Translation (NAT) configuration has been completely redesigned and it may be helpful to have the syntax configuration for both at a glance. You may as well want to read official Cisco published AS…
    This video Micro Tutorial is the first in a two-part series that shows how to create and use custom scanning profiles in Nuance's PaperPort 14.5 (http://www.experts-exchange.com/articles/17490/). But the ability to create custom scanning profiles al…
    This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …

    856 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now