Able to Ping but not map/access

I have a Windows 2003 server on a small closed network with 3 other machines and a switch.  I am manually assigning IP addresses.  For some reason, on one computer w/ Windows XP I can ping the server 156.80.47.250 fine in the command prompt, but I cannot map a shared drive or find the computer in My Networks.  On another computer w/ Windows 2000 I can ping and map it no problem.  Both are setup with Client for MS Networks and TCP/IP w/ the following settings:

IP: 156.80.47.248 or .249
Subnet: 255.255.255.0
Gateway: 156.80.47.250

Two notes:
When I run net view \\156.80.47.250 I get a System Error 1231 has occured message....

This server is running SQL and when I try to connect to it using Enterprise Manager I can see the SQL server Name, but it can't connect.

Any thoughts on the problem...it must be really simple I'm just missing it...!
bnicosiaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MazaraatCommented:
Sounds like a DNS/WINS issue.  Are you running either?  If not, you will need to turn one of them on, or edit the local host file to reflect the IP and name of the server.  Also are you running as a domain or peer-peer?  If your in a domain, try removing the PC and re-adding it to the domain.
0
MarakushCommented:
I see your running XP on the workstations...

Can you try a test for me please... Disable the windows firewall (Any software firewall on the workstation) on the workstation that is having the problem.

Marakush
0
Bernie SalvaggioIT ManagerCommented:
I agree with Mazaraat, it sounds like a DNS/WINS issue.  If you don't have any 98 or lower machines you probably don't need to be running WINS, try turning it off if you are running it.  Regardless, you should have DNS running on the server.  If you don't have it running, the following is a great link for installing DNS on a 2003 server.

http://www.petri.co.il/install_and_configure_windows_2003_dns_server.htm

-Bernie
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

huntersvcsCommented:
You might also try mapping to the IP instead of the name - at least until you have the DNS/WINS problem solved.
0
bnicosiaAuthor Commented:
Thanks for the help...here are the answers to your questions....

I am not running a DNS or WINS server.
I have tried mapping to the IP, but that doesn't work either.  
I am running peer-peer.  

Few questions though...
How do I disable the Windows firewall?
I can connect w/ the Windows 2000 computer, no problems, mapping directly to the IP and such, do I still need to run DNS?
Does the LMHOSTS file have to be called LMHOSTS?  I have 4 files in that directory, none named LMHOSTS (one is named HOSTS).  I don't know that this is the issue since I can't even map to the IP address...

Any thoughts?  Thanks again,
0
Bernie SalvaggioIT ManagerCommented:
Is everything else working (network wise) on the machine in question? Can you get to the Internet? Is it just this problem getting to the server?

You can disable the Windows Firewall by going to the Control Panel, double-click Windows Firewall, click Off next to the red shield, click OK.

Name resolution on your network and the Internet will be more efficient if you have DNS running on your server.  It's a breeze to set up and takes up minimal resources to run, you may as well.

If you want to make manual entries, don't use LMHOSTS, that's for NetBIOS.  Use the hosts file in the same directory.

-Bernie
0
bnicosiaAuthor Commented:
Bernie, this is a closed small LAN w/ no access to the internet.  I don't have that Windows Firewall selection in the Control Planel (is this because I have SP1?).  Anyways, I don't believe the DNS issue is the problem, since I can't even map to the server with the IP address.  Both the LMHOSTS and the HOSTS file changes work, but that doesn't get me any closer, I can just ping the server name now too!  

Is it some strange security setting that might be upset?

Just a note, but I don't want to confuse things, I am connecting this computer to my office LAN also (but not at the same time). Enabling/Disabling each connection.  I am doing this same thing on the W2K machine w/ no problems.

Any more thoughts? Thanks,
0
Bernie SalvaggioIT ManagerCommented:
It could be a security issue.  What permissions are set on the server? It seems unlikely though because the other machines can connect, but who knows.

You say that you use this computer to connect to another network... Do you use the same network card to do so? I'm just trying to make sure it's not the network card that's the problem.

What network protocols do you have running on the network? Are you using TCP/IP, NetBIOS, IPX/SPX? Do you have a protocol installed on the other machines that isn't on this one?
0
thribhuCommented:
hi,

see to that u have netbois protocol enabled.......

and make sure File and print share service is enabled..........

The below is generally not required but for better resolving and maintaining cache .........

go to C:\WINDOWS\system32\drivers\etc

here u see hosts file (open with notepad)

make entries
IPADDRESS     Computername
x.x.x.1              pc1
x.x.x.2              pc2

check LMhost file in the same location and make entries

 x.x.x.1    pc1                     # Discription of the system
 x.x.x.2    pc2  

still unable to resolve then let me know pls...............
0
thribhuCommented:
i for got to tell u one more thing that

in winXP pls check the computer browser service.

start->run-> type services.msc

see if the computer browser service is started .... if not so, start it.......
0
bnicosiaAuthor Commented:
Thanks for your help, but still no resolution.

I've modified the LMHOSTS and HOSTS files, that doesn't help.  It lets me resolve the computer name when pinging but thats it.  

I use a different NIC card, but I wouldn't think that is the problem since I can ping.  

All the protocols are the same, just File and Printer sharing and TCP/IP (NetBOIS over TCP/IP is enabled).  These are the same setting as on the W2K machine.  
0
thribhuCommented:
in winXP pls check the computer browser service.

start->run-> type services.msc

see if the computer browser service is started ....

or restart the service...........




0
dunglc99Commented:
Make sure you config the same workgroup name on 03 systems (specially on XP).
0
RuzReyCommented:
I hope I haven't missed something - 156.80.47.250 is a public IP address. This could cause weird routing problems.

Normally, I would expect your network to use private IP addresses, for example starting at 192.168.1.1 (netmask 255.255.255.0).

If you want to avoid DHCP, then each PC would have a HOSTS file like:-

192.168.1.1   pc1
192.168.1.2   pc2

and obviously each PC should be set to use these settings.

Do you connect to the Internet at the office? If yes, how?
What is the Gateway: 156.80.47.250 machine? What else is it connected to?

Ruz
0
moduloCommented:
PAQed with no points refunded (of 500)

modulo
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.