why do i get bde error $210D if my routine in COM DLL but it works fine as standalone app

i'm trying to do some dBase restructuring with the BDE.  can't put it in my main app because we are using a special bde replacement.  when i compile this restructuring code into a standalone app, it works great.  when i compile the same code into a COM automation DLL, i get bde error $210D (not enough memory).  i know for sure that the bde is in use in this project (not the bde replacement)...something strange seems to be happening...  it's almost like the memory allocation conflicts with the application's memory space but i don't know enough about the memory management of COM to make a good guess how to fix this.

in a way, it's not too terrible because the standalone app works fine...but i wanted a nicer solution!

thanks!
mp
LVL 2
mikepjAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mohammed NasmanSoftware DeveloperCommented:
from BDE support page
http://www.bdesupport.com/errors.htm

====
Shared memory conflict ($210D)
Problem: The BDE is trying to use a location in memory that is already in use by the operating system or another application.
Solution:
1) Close all BDE applications.
2) Find the program BDEADMIN.EXE. This is usually in a directory somewhere under "\Program Files\Borland...".
3) Run BDEADMIN.EXE and click on the Configuration tab.
4) There should be an item in the treeview on the left side called "Configuration". If it's not expanded, expand it.
5) Next, expand the System entry below it. Under System, select INIT.
6) In the right-side window, find the entry called "SHAREDMEMLOCATION". Change this value to 5BDE.
7) Next, click on the word "Object" in the main window's menu bar, and select Apply.
8) Answer "OK" to the confirmation to "Save all edits...".

Other values that may also help solve this issue on NT or Windows 2000 are: 1000, 7000, and 7F00. If none of these values resolve the issue, you may try 2000, 3000, 4000, etc. or any values in between the specified ranges below for each operating system:
    Windows 95/98: SHAREDMEMLOCATION = 9000 to FFFF
    Windows NT/2000: SHAREDMEMLOCATION = 1000 to 7F00
It has also been reported by some users that removing or disabling the driver for a sound card on Windows NT can resolve the issue as well, but normally just "relocating" the BDE's memory pool using the SHAREDMEMLOCATION setting will suffice.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mikepjAuthor Commented:
thank you for your response.  sorry for my late response; i had been hoping to try some of that stuff but i haven't had time.  didn't want to fool with customer's bde config since that horror show would be something i'd like to attend.  tried some memory location stuff before posting this question but it didn't work.  this one looks a bit different from the one i had.  i've decided to accept your answer to close the question.  the bde setup sure is a frustrating and hopeless mess...i can't possibly modify customer bde config without taking the chance of breaking something of theirs!

thanks for trying to help,
mp
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Delphi

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.