• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3762
  • Last Modified:

REP-0730 Error

Hello,

Trying to compile my Oracle Reports 9i, report, I get an error like:

REP-0730: The following bind variable is not defined P_ACTION.

REP-0730: The following bind variable is not defined P_SERVERNAME.

I created those 2 user parameters.

1) How can I resolve these errors ?

PT

0
ptreves
Asked:
ptreves
1 Solution
 
ptrevesAuthor Commented:
Hello,

This is my sample function:
-----
function BeforePForm return boolean is
  vc_parameter_form         varchar2(4000);
  vc_hidden_runtime_values  varchar2(1000);
  vc_report_name            varchar2(100);
begin
  if (:p_action='_action_') then
           vc_hidden_runtime_values :='_hidden_'l
  else
        srw.get_report_name(vc_report_name);
        vc_report_name:=subst(vc_report_name,1,instr(vc_report_name,'')-1);
        vc_hidden_runtime_values:='report='||vc_report_name||
        '&destype='||&destype||'&desformat='||:desformat||'
        &userid='||:p_user_connect||'&server='||:p_servername;
  end if
 
  vc_parameter_form='<html><body bgcolor="#ffffff"><form method=post
  action="||:P_ACTION||">'||'<input name="hidden_run_parameters" tyope=hidden
  value="||vc_hidden_runtime_values||">'||'<center><p><table border=0 cellspacing=0
  cellpading=0><tr><td>'||'<input type=submit></td><td> width=15><td><input
  type=reset><\td>' ||'</tr></table><p><hr><p>';
  srw.set_before_form_html(srw.text_escape,vc_paramter_form)

  return (TRUE);
end;
-----

PT
0
 
oratimCommented:
All I can suggest is to double check your user parameters and make sure they are spelled correctly.
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now