gltest.obj : error LNK2001: unresolved external symbol __imp__ilLoadImage@4

Hi All!!

I installed a library called DevIL that is intended to manage images.

I configured MSVC++ with the following settings:
1. project->c++ settings->category: Code Generation
2. project->c++ settigns->use runtime library: Multithreaded DLL

I am sure that the code is correct because it's the working example the guys give us to try (this code gives me exactly the same error as my application).
Something is wrong because it doesn't link:

Compiling...
gltest.c
Linking...
gltest.obj : error LNK2001: unresolved external symbol __imp__ilLoadImage@4
gltest.obj : error LNK2001: unresolved external symbol __imp__ilBindImage@4
gltest.obj : error LNK2001: unresolved external symbol __imp__ilGenImages@8
gltest.obj : error LNK2001: unresolved external symbol __imp__ilutEnable@4
gltest.obj : error LNK2001: unresolved external symbol __imp__ilEnable@4
gltest.obj : error LNK2001: unresolved external symbol __imp__ilInit@0
gltest.obj : error LNK2001: unresolved external symbol __imp__ilGetInteger@4
gltest.obj : error LNK2001: unresolved external symbol __imp__ilDeleteImages@8
gltest.obj : error LNK2001: unresolved external symbol __imp__ilutGLBindTexImage@0
gltest.obj : error LNK2001: unresolved external symbol __imp__ilutRenderer@4
Debug/test.exe : fatal error LNK1120: 10 unresolved externals
Error executing link.exe.

test.exe - 11 error(s), 0 warning(s)

Thanks!
joao_yeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

waysideCommented:
You have to tell Visual Studio to link against the library you installed:

(for VC++,net) project settings->linker->input->additional dependencies

add in the devIL library that you must link against.
0
skiritis13Commented:
Are you using VC++ .NET?

If so try Project->Properties->Linker->Additional Dependencies
In the Additional Dependencies field type the libraries ( .lib files ) your library is using.

Aftert that try Tools->Options->Projects->VC++ Directories
In that window, in Show directories for:
1) Choose Include files: there, add the directory the devIL's headers ( .h files ) are.
2) Choose Library files: there, add the directory that devIL's library ( .lib files ) are.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
C++

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.