OpenVPN installation trouble

Hi All,

I am having some trouble installing OpenVPN.  I've had no success finding support at openvpn.sourceforge.net or any other site.  I have succesfully installed the latest LZO compression libraries and OpenSSL.  However, when I ./configure I get the error messages:

configure: checking for OpenSSL Crypto Library and Header files...
checking openssl/evp.h usability... no
checking openssl/evp.h presence... no
checking for openssl/evp.h... no
configure: error: OpenSSL Crypto headers not found.

I have located the evp.h include file and also tried the following:

./configure --with-ssl-headers=/usr/local/ssl/include/openssl

which points to the location of where the evp.h file resides.  Still no success.  Any help would be very much appreciated!!

Linux Dist - Mandrake 10

tonydm
tonydmAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

owensleftfootCommented:
Configure is checking for the headers in oppenss/ so it would be worth leaving it off the end of your configure command ie
/configure --with-ssl-headers=/usr/local/ssl/include/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tonydmAuthor Commented:
Thanks owensleftfoot,

that did the trick!  Although I got another error;

configure: checking for OpenSSL Crypto Library and Header files...
checking openssl/evp.h usability... yes
checking openssl/evp.h presence... yes
checking for openssl/evp.h... yes
checking for EVP_CIPHER_CTX_init in -lcrypto... no
configure: error: OpenSSL Crypto library not found.
0
tonydmAuthor Commented:
An added note:

I tried this with no success:

./configure --with-ssl-headers=/usr/local/ssl/include/ --includedir=/usr/include

Where the /usr/include points to the parent directory of the location of the /KerberosIV/krb.h file.

Didn't work! :(
0
admin0Commented:
up2date/yum openssl-devel

Do you have the openssl-devel rpm installed ?

Please check and if not installed, install and give it another try.
0
rajasekarramasamyCommented:
I am also facing this same problem. I have install openssl-devel rpm now the problem rectified. \
Thanks admin0.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.