[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

OpenVPN installation trouble

Posted on 2004-11-02
5
Medium Priority
?
4,087 Views
Last Modified: 2012-06-27
Hi All,

I am having some trouble installing OpenVPN.  I've had no success finding support at openvpn.sourceforge.net or any other site.  I have succesfully installed the latest LZO compression libraries and OpenSSL.  However, when I ./configure I get the error messages:

configure: checking for OpenSSL Crypto Library and Header files...
checking openssl/evp.h usability... no
checking openssl/evp.h presence... no
checking for openssl/evp.h... no
configure: error: OpenSSL Crypto headers not found.

I have located the evp.h include file and also tried the following:

./configure --with-ssl-headers=/usr/local/ssl/include/openssl

which points to the location of where the evp.h file resides.  Still no success.  Any help would be very much appreciated!!

Linux Dist - Mandrake 10

tonydm
0
Comment
Question by:tonydm
5 Comments
 
LVL 17

Accepted Solution

by:
owensleftfoot earned 1000 total points
ID: 12481804
Configure is checking for the headers in oppenss/ so it would be worth leaving it off the end of your configure command ie
/configure --with-ssl-headers=/usr/local/ssl/include/
0
 

Author Comment

by:tonydm
ID: 12485200
Thanks owensleftfoot,

that did the trick!  Although I got another error;

configure: checking for OpenSSL Crypto Library and Header files...
checking openssl/evp.h usability... yes
checking openssl/evp.h presence... yes
checking for openssl/evp.h... yes
checking for EVP_CIPHER_CTX_init in -lcrypto... no
configure: error: OpenSSL Crypto library not found.
0
 

Author Comment

by:tonydm
ID: 12485562
An added note:

I tried this with no success:

./configure --with-ssl-headers=/usr/local/ssl/include/ --includedir=/usr/include

Where the /usr/include points to the parent directory of the location of the /KerberosIV/krb.h file.

Didn't work! :(
0
 
LVL 6

Expert Comment

by:admin0
ID: 20254877
up2date/yum openssl-devel

Do you have the openssl-devel rpm installed ?

Please check and if not installed, install and give it another try.
0
 

Expert Comment

by:rajasekarramasamy
ID: 23946084
I am also facing this same problem. I have install openssl-devel rpm now the problem rectified. \
Thanks admin0.
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
As many of you are aware about Scanpst.exe utility which is owned by Microsoft itself to repair inaccessible or damaged PST files, but the question is do you really think Scanpst.exe is capable to repair all sorts of PST related corruption issues?
Suggested Courses

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question