Record not added. Member NCIRCPP is full

Hi there,

When I do a wrkactjob I see a job with a message that says: "Record not added. Member NCIRCPP is full". I can then choose to either ignore, increment by 1 or by any other amount 1- 9999.

What does this mean? Has my object ran out of space? How can I check which files are close to being "full"?

Thanks,
J.
jacovanderbergAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jacovanderbergAuthor Commented:
Hi,

The platform is an AS400 (iSeries) with a DB2 database.
0
Shalom CarmelCTOCommented:
Hey,
You will have to dump the list of members in the files using the following syntax:

DSPFD FILE(libname/filename) TYPE(*MBR) OUTPUT(*OUTFILE) OUTFILE(worklib/overflowmb)
(the library can be *LIBL and the file name can be generic, if you know what I mean).

Then, use your favorite reporting tool like QRY400, or a PC based one if you like, and look for the following records:

select * from worklib.overflowmb where (mbrcdc * 0.90) < (mbnrcd+mbndtr)

replace 0.90 with your own ratio.

ShalomC
0
Shalom CarmelCTOCommented:
Also, consider changing the critical tables' record capacity to a meaningful number.
Try the CHGPF command, you will see the allocated records parameter.

ShalomC
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

jacovanderbergAuthor Commented:
Hi ,

Thanks for all the feedback so far. I do have very little knowledge about the AS400 and DB2, but will try your suggestions and let you know which one worked best for me. Shalomc, when you say "changing the critical tables' record capacity to a meaningful number", what do you mean?/How will I change it?

Thanks,
J.
0
Shalom CarmelCTOCommented:
I recommend setting the records limit on high volume transaction files to be *NOMAX.
The way to set this limit on a particular file is by the Change Physical File command, like this:

CHGPF FILE(library/file) SIZE(*NOMAX)

Of course, to be really sure what files to select, how to predefine the file size and whether to preallocate disk space or not, you need a professional to look over your AS400 and your application.


ShalomC
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jacovanderbergAuthor Commented:
Thank you for your valuable input.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DB2

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.