• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 944
  • Last Modified:

XP - NIC will not pick up DHCP address

Hi,
This has me stumped: An XP Home Dell on a LAN suddenly does not get network settings from DHCP. The NIC gets an automatic private address from XP. It had been working fine for months prior to this.

The machine was moved to another LAN with a known working connection to a router providing DHCP.

I replaced the NIC twice, with 2 different brands right out of the box. With the first replacement, the new NIC did the same thing. When the second new NIC went in, it will not install properly (it's a D-Link, and XP reports only that"There was an error installing the new hardware - The specified file could not be found").

I checked for spyware using Ad-Aware and Spybot. I re-installed NAV (due to a seperate problem), updated and scanned for viruses (none found).

I reset TCP/IP using netsh.

I performed a Repair install of XP as a last ditch effort, and to my surprise it did not help the problem.

I need advice on possible causes and solutions. Formatting and re-installing? Please NOOOOO!
0
westone
Asked:
westone
  • 5
  • 5
  • 3
  • +6
7 Solutions
 
JammyPakCommented:
the standard XP answer is - did you disable the built-in firewall?!

esp. if you installed SP2, the firewall locks everything down unless you open it. I didn't think it blocked DHCP, but it's still something I would verify.
0
 
EricCommented:
could be the winsock in windows xp..  download the Windows XP Winsock 1.2 fix from http://www.softpedia.com/public/cat/13/9/13-9-161.shtml and let me know if that fixes the problem you are having..

have you checked the cabling ???
0
 
gdplusmoreCommented:
You should check the DHCP Table on the router and clear any entry for this node (you should see the computer name listed)

are you getting a status light on the router for this node ?
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
westoneAuthor Commented:
Thanks for the quick replies.

This machine does not have a software firewall installed. My experience is that a software firewall such as that in NIS or XPSP2 will not block DHCP settings.

I will try the winsock fix.

As mentioned in the original post, the machine was placed on a known working connection of a functioning LAN with a router providing DHCP. I can unplug the data cable from this machine, plug it into another machine, and that machine receives DHCP and browses the network and the internet just fine. The problem is most certainly on the XP box.

I will be back with the results of the wisock fix in several hours.

Thanks!
0
 
EricCommented:
ok.  keep us posted..

just fyi, the winsock fix takes less than a minute to run

0
 
lemonteeCommented:
Try uninstall and reinstall the NIC. Remove from the Device Manager and reinstall back.

0
 
stevemjpCommented:
I doubt it's the NIC. He is on his third one now!

My gut feeling is that it's with the TCP/IP stack.

The winsockxpfix.exe is a good shout.

8}
0
 
stevemjpCommented:
Another tip.

Get yourself some ghosting software such as Norton Ghost, or Powerquest Drive Image.

That way, with SysPrep you can replace a box within an hour. No messing about.
0
 
tonyteriCommented:
First, try to give it a static ip, to assure that you can get networking up and running.  if that works, then change the settings and restart.

If upon restart, the dhcp did not register, go to local connections, right click on your nic, and select properties.  Then select Repair.  that will release the ip, and try to get a new one.  you will be able to watch the process.

TT
0
 
DiCeRCommented:
Probably a stupid question, but it needs to be asked: Are the cable allright? On most NICs today you get LEDs that indicate link-status and traffic. Got any of those? Swap with a cable you know works and try again.

Have you tried with a different user or in safe-mode with networking? I've seen before that there are software-components running in user-mode that fcks up things. A new user or safemode should bypass that.

If you network it to another computer with a Crossover cable and no hub or switch between - can you ping or network those directly? If it does - then the NIC is allright and the TCPIP stack is allright, its the DHCP that doesent reach it.

Does it work on the LAN if you set a static, legal, available IP? If it does - your DHCP server probably has some issues with that card/machine in particular. Check the DHCP leases and/or allocations on the router.

Get a Knoppix CD and boot with it. Thats an OS-on-a-CD and does excellent autodetection of most hardware. An excellent thing to test your card with. You get some pretty powerful tools to do diagnostics there too.

Hope this helps.
0
 
westoneAuthor Commented:
Sorry about the delay, a job kept me out of the office all afternoon yesterday.

Unfortunately, the winsockxpfix did not repair the problem. Most certainly something is out of whack with XP networking properties. No connections at all are listed under "Network Connections", and when I run an ipconfig /all, there are no results, just a line that says "Windows IP Configuration", and that's it.

I have not been able to find any further help so far.

So, the LAN and DHCP and cables are proven okay. The NICs are known good. XP networking is buggered. 5 users on this machine and GBs of data.

All suggestions appreciated.
0
 
yvsupportCommented:
Have you tried a differernt logon?

I have seen an XP box buggered exactly like this, but when I created a new admin logon and logged on as the new user all the TCP stuff was back.
0
 
EricCommented:
start -> run -> services.msc

check to make sure the following services are started.
1. Network Connections
2. DHCP Client
3. DNS Client

0
 
westoneAuthor Commented:
DHCP, DNS, and Network Connections are up and running.

All Users are experiencing the same problem.

0
 
EricCommented:
the services is the only thing that i can think of that could be stoping the connections from showing up.

0
 
westoneAuthor Commented:
Well now something different is occuring.

Under network connections there is one item that states "PRPI Unavailable - Device Missing"

There is currently no NIC in the machine, I uninstalled in Device Manager, and removed all references to it from the registry.

Any thoughts?
0
 
DiCeRCommented:
Im still waiting for some feedback on my other suggestions; Safe-mode, crossover-cable, boot with Knoppix CD etc. You have already deleted it from the hardware manager, but next time this card is re-detected, please use the manufacturers drivers instead of the one that xp offers you. Make sure the driver is most recent too.Verify that those drivers ARE installed by checking the driver-page on the card-properties in the hardware-manager.

The more you describe it - the more it sounds like a driver/network-card issue with XP.

If there are - as you say - no connections listed in the networking-applet in control-panel, it means that Windows XP does not see you network-card. It is - by all practical means - not working. Getting no results from "ipconfig /all" only stregthens this theory. It could also mean that you have no TCP/IP-stack installed, but that is unlikely.

As I have suggested earlier - boot a Linux CD like knoppix and see if a different OS can work with it. You can even try a DOS network-disk like the ones you can find on bootdisk.com. YOU NEED TO VERIFY IF THE CARD AND/OR CABLE REALLY WORKS. Take out the NIC, try it in a DIFFERENT machine. Any and all debugging you do in XP, is meaningless until you know it works.

Hmm... It could be the PCI-slot its in. Swap the card to a different slot.

Hope this helps
0
 
westoneAuthor Commented:
Most of your suggestions were clearly made after making no more than a cursory glance at the previous posts.

I've used 3 different NICs new out of the box, at least 1 should be good, right?

As mentioned previously (twice), The machine was moved to a known working connection on a known working LAN.

Also posted was the fact that the cable was removed and connected to another machine which received DHCP settings and browsed the LAN w/ no problem. How could cable or anything else outside of the machine in question possibly be the cause? Why would I waste time hooking up a crossover cable?

0
 
EricCommented:
im assuming that since you accepted answers, you either fixed it, or have given up on it.????!!??

what was the final thought about it ?
0
 
DiCeRCommented:
Ok. Im misunderstanding your comments a bit then. Im thinking that "moving a computer to a working location" is to me not the "same as moving it to a working location and comfirm that its working" *shrug* The location might be ok but thats no guarantee the computer works. I agree - if the computer works elsewhere, using a crossover makes no sense. I just missed a clear statement that it did work elsewhere. Sorry. Case closed.

Hope you got your problem worked out without a reinstall tho...
0

Featured Post

Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

  • 5
  • 5
  • 3
  • +6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now