[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1723
  • Last Modified:

Notes error: Entry not found in index

Hi, I have some code that walks through a view and modifies each document.

Set doc = view.GetFirstDocument
While Not(doc Is Nothing)
     Set tempDoc = doc
     'modify doc...
     Call doc.Save(False, True)
     Set doc = view.GetNextDocument(tempDoc)
Wend

I'm using tempDoc because after I modify doc, GetNextDocument(doc) does not return the next document (is this expected?).  The code above worked fine before, but for some reason it no longer works - I get the Notes error: Entry not found in index.  I didn't make any other changes to the agent, so I don't know why this has stopped working now...

Any help would be much appreciated.  Thanks!
0
pw05
Asked:
pw05
1 Solution
 
HemanthaKumarCommented:
Probably after the save the document is falling off the view..So check the select condition of the view and make sure the document fields related to the select is not altered in a way if drops off the view or correct the select condition in the view to match up with the correct field values

~Hemanth
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now