disabling bi-directional printer communication for OS/2

I have a linux box (printing with cups), a windows box, and an os/2 box that all need to print to the same printer

printer is currently hooked up physically to the os/2 box and shared on the windows network and windows clients can print to the printer no problem

Enter Linux, since linux doesnt speak the networking language of os/2, linux and os/2 do not play well together when it comes to network shared resources (especially on a win 2000 active directory domain)

There are a large number of internet posts describing how to get linux to talk to an os/2 printer but none of them worked for me, and some werent even finished works

ok, so I broke down and bought a parallel auto sensing switch that lets you share via cable one printer with two computers.

so I installed it, used epm to print a test file, and it worked fine, then on my windows box I changed the print driver to a lpt1 source.  Then I could print directly to the printer and then I could share that on my network and then linux could print to the printer.

would have been easier if I could have had windows share a share, but we all know you cant do that

the auto-sensing printer switch was the perfect solution to a short term problem (im eventually getting rid of the os/2 boxes) with one exception...

the printer switch box does not support bi-directional print functions like ink levels and the like.

and it comes with instructions on how to disable this function in windows

well, my question is, how do you disable bi-directional printer port in os/2?
LVL 8
Rance_HallAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Danny KonCommented:
Rance,

First of all standard OS/2 doesnt use Bi-directional printing as far as i know
In your question you are not saying which version OS/2 and the printer you are using.
This will be very helpfull to solve the problem.
Maybe the easiest way is to buy a printer cable doenst support bi-di printing
Also you can try do disable the spooler

if you really want to find a solution then first start to check in you config.sys if there is a file called print01.sys and see if this is not remarked
if this is not remarked than os/2 is not using bidirectional support if it is remarked most likely you will find an other driver like BIDI.exe or simulair installed on the machine
As stated above really need to know the printer and if it use a native os/2 driver etc

Dan

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Operating Systems

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.