[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 205
  • Last Modified:

Help getting Started

We are going to redesign our site around asp.net. I've installed .net 1.1 framework on our Testing Server. I will have myself and another person working on these pages.  Can you direct me how to set it up so that we can both develop and test pages. Right now I've created a simple test.aspx page and put it in the development/testing folder on the server.

When I try to go to the file via

http://servername/mdfx/test.aspx

I get the following...

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>

 
I figure I don't have something configured properly. I even moved the file to the root of the wwwroot folder on the testing server and get the same results.

Jody
0
kevinbenedict
Asked:
kevinbenedict
  • 5
  • 2
2 Solutions
 
kevinbenedictAuthor Commented:
In my webconfig document I changed

<customErrors mode="RemoteOnly" /> to <customErrors mode="Off" />


now I get the following...

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: File or assembly name Microsoft.SharePoint, or one of its dependencies, was not found.

Source Error:


Line 47:     <httpHandlers>
Line 48:       <add verb="*" path="/_vti_bin/*.aspx" type="System.Web.UI.PageHandlerFactory, System.Web, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
Line 49:       <add verb="*" path="*.aspx" type="Microsoft.SharePoint.ApplicationRuntime.SharePointHandlerFactory, Microsoft.SharePoint, Version=11.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
Line 50:     </httpHandlers>
Line 51:     <customErrors mode="On" />
 
Source File: c:\inetpub\wwwroot\web.config    Line: 49

Which doesn't match up with what I see on line 49 in my code which has nothing on it

Jody

0
 
kevinbenedictAuthor Commented:
I changed the original webconfig page with a simpler one than that which was installed when I installed .net 1.1. And it now works.  Looks like this webconfig file is the key to my sucess or pain.

I'm assuming that if I want to authenticate users using sql I'll have to tweak this config file. Is this correct? Can you direct me to information on this?

thanks
Jody
0
 
ryerrasCommented:
you want to authenticate users using sql? what do you mean?
One way of authenticating users is using Forms authentication, please take a look at the following articles

http://www.15seconds.com/issue/020220.htm

http://www.devhood.com/tutorials/tutorial_details.aspx?tutorial_id=85

http://www.c-sharpcorner.com/Code/2002/Sept/UserManageUtil.asp
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
diablocuteCommented:
When you say you want to authenticate users using sql, you mean you r going to have a login page with username and passwrod fields, Is that right?
If so,  you need to set the authentication mode to Forms
 <system.web>
   ...
   <authentication mode="Forms"/>
  </system.web>
      
good link        
http://www.15seconds.com/issue/020220.htm            
0
 
kevinbenedictAuthor Commented:
ryerras
I want to use my SQL table Members table to authenticate users.

I'll check out the links.

J
0
 
kevinbenedictAuthor Commented:
Quick clarification...

If I have a website with multiple folders. One of those folders will be hold the Members folder with all their related files. Do I put my webconfig file in this folder as that's the one I want to be secure?

Thanks
j
0
 
ryerrasCommented:
yeah. in the root web.config, allow all the users using
<authorization>
      <allow users="*" /> <!-- Allow all users -->
</authorization>

Then in the folder which you want to secure, place another web.config and customize its authorization element according to your needs
0
 
kevinbenedictAuthor Commented:
Thanks
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now