SMTP Open Relay Test Failed

When running the Exchange Server Best Practices Analyzer, I get a “failed open relay test”.

New install of Exchange 2003, no previous Exchange, Windows 2003 Domain with ADS,DNS,WINS

I currently am using POP3 interface for about 30 offsite (non-LAN) users with Outlook 2003.  No VPN is used.  Watchguard Firewall uses a User Filter to pass all SMTP requests directly through to Exchange server.  LAN users connect via Exchange Mailbox.

I am adjusting the settings using Exchange SM \ OurMailServer\Protocols\SMTP\Default Smtp Virtual Server\Properties.

General – "All unassigned"

Access\Authentication\Anonymous Access – Checked
…\…\Basic authentication – Checked, Default domain = ourdomain.com
…\…\Integrated Windows Authentication – Checked, Users = Authenticated Users – Submit Permission=Allowed, Relay Permission=Allowed

Access\Connection Control\Connection\All except the list below – checked, No computers in list.

Access\Relay Restrictions\Only the list below – Checked, Computers = 192.168.1.0
…\…\Allow all computers which successfully… - Checked

Messages\… - All Defaults

Delivery\Outbound Security\Anonymous Access – Checked, Nothing else checked.
…\Outbound connections\ Defaults
…\Advanced\ Defaults

What can I do to keep POP3 open and not be an open relay???

rwlaman
rwlamanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
I think it is your 192.168.1.0 entry.
That lets you firewall do it as well as the traffic appears to come from that.

Loose the entry totally and leave the authenicated part. Then configure the POP3 users to authenticate when they send email via SMTP.

Simon.
0
rwlamanAuthor Commented:
Leave "only the list below" checked and then have nothing in the Computers list??
0
SembeeCommented:
Yes.
Enable the option "All all computers which successfully authenticate to relay, regardless of the list above".
This will mean the users must authenicate when they send email, but that is easily setup.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.