Cisco PIX 501 v6.3(3) - Trouble with SMTP & FTP

Posted on 2004-11-03
Last Modified: 2010-04-17
Internet ----- [x.x.x.50] Cisco PIX [n.n.n.1] ----- [n.n.n.20] MS Exchange 2000 Server
x.x.x.0 is the external network (Internet)
n.n.n.0 is the internal network

I'm pasting the config below the questions.

1) SMTP Problem:
- Users can send mail internally. It doesn't look like it's going external.
- No outside mail is coming in.
- If I telnet to n.n.n.20:25 from the internal network, I see Exchange respond, so the service is at least listening.
- If I telnet to x.x.x.50:25 from the web, Exchange does NOT respond.
- I thought doing a 'no fixup smtp 25' would solve that, but it didn't...something else is wrong & I don't see it.

2) FTP Problem:
- I can ftp to any outside server from any machine on the internal network except for n.n.n.20.  The only difference I can think of is that n.n.n.20 has a static IP whereas the rest of them use the PIX for DHCP.  I don't see how this is related, but I can't think of anything else.  n.n.n.20 uses the same gateway (n.n.n.1) & DNS servers as the rest of the machines, and I'm not ftp-ing by name anyway, so the DNS wouldn't matter...

Any ideas?  I'm a programmer by trade - Cisco PIX configuration is new to me.


----- CONFIG -----
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password vCJ6MPbMJfKQnKVU encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix
fixup protocol dns maximum-length 512
no fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
access-list inside_access_in permit ip any any
access-list inside_outbound_nat0_acl permit ip any n.n.n.192
access-list inbound permit tcp any any eq smtp
access-list outside_access_in permit tcp any any eq smtp
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside x.x.x.50
ip address inside n.n.n.1
ip audit info action alarm
ip audit attack action alarm
ip local pool corp-vpn n.n.n.180-n.n.n.199
pdm location n.n.n.192 outside
pdm location n.n.n.20 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0 0
static (inside,outside) tcp interface smtp n.n.n.20 smtp netmask 0 0
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside x.x.x.1 10
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http n.n.n.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-pptp
telnet timeout 5
console timeout 0
vpdn group vpn accept dialin pptp
vpdn group vpn ppp authentication mschap
vpdn group vpn ppp encryption mppe auto
vpdn group vpn client configuration address local corp-vpn
vpdn group vpn client configuration dns x.x.x.5
vpdn group vpn pptp echo 60
vpdn group vpn client authentication local
vpdn username user1 password *********
vpdn enable outside
dhcpd address n.n.n.52-n.n.n.179 inside
dhcpd dns x.x.x.5
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
Question by:mudpoet
    LVL 79

    Accepted Solution

    First, remove this entry:
       >access-group inside_access_in in interface inside

       PIX(config)#no access-group inside_access_in in interface inside
       PIX(config)#no access-list inside_access_in

        >route outside x.x.x.1 10  <== this "10" should be a "1"
       PIX(config)#route outside x.x.x.1  <== do not specify a hop count and it will default to 1

        Change this:   >access-list outside_access_in permit tcp any any eq smtp
        to this:    access-list outside_access_in permit tcp any interface outside eq smtp
     Then, re-apply the access-list to the interface (required any time you make a change to the acl)
         access-group outside_access_in in interface outside

    Assuming that >n.n.n.20  has a static IP, what is it's default gateway setting and subnet mask and DNS settings? Can you post C:\>route print from that system?

    Let's see what affect these changes make and go from there..


    Author Comment

    SMTP) I made your changes and it didn't work. Would you like me to paste the new config?

    FTP) n.n.n.20 has the same gateway and DNS as what the PIX gives out via DHCP to the rest of the machines.  Here's a copy & paste of `route print` (n.n.n.0 ==

    C:\>route print
    Interface List
    0x1 ........................... MS TCP Loopback interface
    0x1000002 ...00 53 45 00 00 00 ...... WAN (PPP/SLIP) Interface
    0x1000003 ...00 04 23 a6 30 04 ...... Intel(R) PRO/1000 MT Dual Port Server Adap
    Active Routes:
    Network Destination        Netmask          Gateway       Interface  Metric
       1       1       1       1
         1       1
    Default Gateway:
    Persistent Routes:

    LVL 79

    Expert Comment


    For FTP, try re-enabling the fixup for ftp:

    no fixup protocol ftp 21


      fixup protocol ftp 21

    Save the config and then reboot the PIX. You should never have to, but I've seen it work magic.. I've also seen it not make any difference...

    Author Comment

    FTP fixed.  Odd thing is, it was like that to begin with...I tried `no fixup protocol ftp 21` in an attempt to get it working.

    #2 solved.

    Any other SMTP ideas?????  Boss. Breathing. Down. Neck.
    LVL 79

    Expert Comment

    Can you post result of "show access-list"

    Are you sure there is no typo in this line with the "n.n.n" ?
         >static (inside,outside) tcp interface smtp n.n.n.20 smtp netmask

    What does your MX record point to for email? Is it the outside IP of the PIX?

    Author Comment

    I was mistaken.  It is working.  Dunno why it didn't the first time I tried, but I tried again just now (had to leave earlier) it worked.  Maybe I typo'd the telnet command or something.  Thanks for all the help.
    LVL 79

    Expert Comment

    Whew! Good job!

    Featured Post

    IT, Stop Being Called Into Every Meeting

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Join & Write a Comment

    Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
    There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    734 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    24 Experts available now in Live!

    Get 1:1 Help Now