Enable Change Password option in OWA 2003


I've followed the procedures below and still cannot see the change password button. Anyone have any clue what I'm missing? If this is enabled on the FE, does it also need to be enabled on the back-end? Anyone done this with a large enterprise clustered environment? OWA works great, and has been for several months. I also tried changing the password flags for W3Svc to 0 to no avail.


How to enable password change functionality for Microsoft Exchange Server Outlook Web Access
http://support.microsoft.com/kb/268419

OWA configured as a Front-End server on Windows 2003 / Exchange 2003 Enterprise SP1 - Front-End Server

1. From Windows Explorer, verify that the physical directory exists at C:\Windows\System32\Inetsrv\Iisadmpwd. It should contain nine *.htr files.  
2. From within the IIS Microsoft Management Console (MMC) snap-in, open the default Web site.
3. Right-click the default Web site and point to New on the pop-up menu, and then click Virtual Directory.
4. On the second screen of the wizard, give the virtual directory an alias of IISADMPWD. On the third screen, give the folder a physical directory location of C:\WINNT\System32\Inetsrv\Iisadmpwd. On the fourth screen, select Read, Run Script, and Execute Access privileges. Click finish on the fifth screen of the wizard to prompt creation of the folder.
5. At this point, you can change user passwords through Outlook Web Access. Passwords must be entered in a DOMAIN\Username format to be changed. Additionally, all password complexity and history requirements must be met when you change a password or an error will be returned.

Note The IISADMPWD requires a Secure Sockets Layer (SSL) connection to work. This is designed to avoid changing passwords across a network through HTTP, which is clear text. After you click the submit button, the protocol is changed from HTTP to HTTPS. If necessary, follow the steps in Help to obtain a server certificate for the Web server (http://localhost/iishelp/iis/htm/core/iiocrsc.htm on a server with IIS installed). You can also use Microsoft Certificate Services 2.0 (which is included with Windows 2000) to sign a server certificate that can be used by IIS to enable an SSL session.



You can hide the Change Password button by adding the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB
1. Start Registry Editor, and then locate the preceding registry key.
2. On the Edit menu, click Add Key to add a new key named OWA.
3. On the Edit menu, click Add Value to add the following value to the OWA registry subkey if you want the Change Password button to appear:
Value name: DisablePassword
Type: REG_DWORD
Data: 0


If you want to hide the Change Password button, add the following value to the OWA registry subkey:
Value name: DisablePassword
Type: REG_DWORD
Data: 1
4. Stop and then restart the Exchange Information Store Service (MSExchangeIS) and the Microsoft Internet Information Services Admin Service--this stops the World Wide Web Publishing Service (W3SVC).  
5. Make sure you restart all other dependent services (IMAP4, POP3, Microsoft Exchange Routing engine, W3SVC, MTA Stacks, and so on).
LVL 12
BNettles73Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

michaellundgrenCommented:
Hi BNettles73,

You only need to enable the change password button on your back-end servers:

Location: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeWeb\OWA
Value: DisablePassword
Type: REG_DWORD
Value Data: 0 or 1
Enter the value 0 if you want to enable the change password feature. (The Change Password button is available.)
Enter the value 1 if you want to disable the change password feature. (The Change Password button is unavailable.)

And create the IISADMPWD virtual directory on the front-end servers.

Regards,
Michael Lundgren
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BNettles73Author Commented:

That was it ...

I was trying to do everything on the Front-end ... I had a suscpicion that was it but more or less wanted confirmation.

IIS changes made on the FE
Registry changes made on the BE
IISReset on the FE

Password Change is now enabled.

Thanks Michael!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.