Win98-95 Pc's Cannot see the Network Nor can the Win2k Server Unless we Install Netbui

We were running win2K SBS with win2k Fileserver with XP, 2000, Win98 and Win95 Clients.

Had to Reinstall win2K Filesserver, and Joined it back to domain.

XP Clients and 2000 can see the win2k Fileserver

95 and 98 cannot see win2k Fileserver shares or printers. But clients can Ping the FileServer,
95 and 98 can still see the win2k SBS server OK

Must be something on the Win2k Fileserver.

If we install NetBui then win 98 and win95 clients can see the shares and printers.

Thanks in advance.




Wayne_OwenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lrmooreCommented:
Try enabling WINS server and be sure to point the 95 and 98 clients to it...
0
Wayne_OwenAuthor Commented:
Domain Controller has Wins, Fileserver Has not,
95 and 98 Clients can See the Domain Controller but cannot see the Fileserver
95 and 98 Clinets logonto the Domain correctly
Do I have to install WINS on the Fileserver ?
0
lrmooreCommented:
You don't have to install the WINS serverice on Fileserver, but you need to put the WINS server IP in Fileserver's TCP/IP settings
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Wayne_OwenAuthor Commented:
Domain Server's IP Address is in the Wins Table

Current Settings are:

Ip Address of Domain Controller 10.0.0.2
Ip Address of FileServer 10.0.0.3

Network Settings of Fileserver

Default Gateway (Router) 10.0.0.20
DNS 10.0.0.2
Append Primary and Connection Specific DNS suffix Selected
Append Parent Suffixes of the Primary Suffix Selected
Register this connection address in DNS

Wins
Address used 10.0.0.2
Enable LMHosts Lookup selected
Enable Netbios over TCP/IP Selected


0
lrmooreCommented:
From a 98 PC, can you ping the Fileserver by name?
Using "nbtstat -c" on the 98 PC, can you see an entry for the fileserver?
Is it the same IP address that was used prior to the rebuild?
Before you rejoined it to the domain after the rebuild, did you first delete the old computer account from the domain?
0
Wayne_OwenAuthor Commented:
Yes Can ping By IP and Name

Yes See 2 entry's in list
SERVER2 00 Unique 10.0.0.3 420
SERVER2 20 Unique 10.0.0.3 420

The Same IP Address Was Used On REbuild

The OLD Account was not Deleted before rebuild, We did Use a Different Computer Name on Rebuild, then deleted the Old Computer name after rebuild.
We went through the DNS removing entries for the old Name, also checked that SERVER2 10.0.0.3 is in the DNS correctly.
0
crissandCommented:
Go to fileserver's nic properties/tcp-ip protocol/Enable netbios over tcp/ip.
0
Wayne_OwenAuthor Commented:
File Server Nic already Enabled for netbios over TCP/IP, Nics Settings are in previous Comment.

I have two Nic's installed and are Teamed, Have Installed Very same drivers on Domain Controller in the same way and it is OK, so I do not suspect the Nic Drivers nor the Intel Pro Teaming Software. Have Uninstalled and tried with single adaptor with the same problems.
0
lrmooreCommented:
Just for giggles, on the file server, enable the Guest account and see if it makes a difference.
Yes or no will tell us that it is a domain SID issue and not a networking/driver issue..
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Wayne_OwenAuthor Commented:
Not at Server Site until 8.30am GMT tommorow, but will try first thing and post back.

Thanks.
0
Wayne_OwenAuthor Commented:
Enabled Guest Account on the FileServer, No Difference.

So then this points us to a Networking/driver issue.
0
crissandCommented:
Have you give permissions to users over the shares on the fileserver?
0
Wayne_OwenAuthor Commented:
There are Shares on the FileServer that are Open to everyone and some have permissions.

All XP,2000 machines are able to connect correctly,

All 98 and 95 machines with netbui installed can connect correclty, with TCPIP only they can see nothing, not even the FileServer.

Have run netdiag on the Fileserver all results are passed.

0
crissandCommented:
Try to uninstall and reinstall Active directory client for windows 98, this sometimes solve the problem. And don't forget File and print services on windows 9x workstations.
0
Wayne_OwenAuthor Commented:
Have reinstalled Active Directory Client Extensions on a 98 PC all PC's have File and Print Services installed (They all use to see the FileServer)

Don't know if this may shed some light.

Select Network Neighbourhood - I can see the FileSever Icon - Double Click and the Error is - The Network is Busy

Type into the Address bar \\Server2 - Error is - Windows cannot find \\Server2 Check the Spelling........

Select Find Computer - Enter Server2 - Finds FileServer - Double click and Error is - The Network is Busy

Does any of this Help !

0
crissandCommented:
The network is busy error message is related to security. See what authentication level do you have on the file server's nic.
0
Wayne_OwenAuthor Commented:
IP Security = Do Not Use IPSEC

TCP/IP Filtering = Ebable TCP/IP Filtering is De-Selected
0
crissandCommented:
Do you have any error codes in the server's event log? See the security log first.
0
Wayne_OwenAuthor Commented:
No Events at all in the Security Log
No Errors in the Application Log
1 Error in the System Log (Printer Error)
0
crissandCommented:
I think the server is configured to use Kerberos authentication protocol, that's why windows 2000 and xp stations can authenticate. Windows 9x can use ntlm authentication.

Let's try a ipconfig /all in command prompt on the server and on one workstation, and publish here the result.
0
Wayne_OwenAuthor Commented:
Hope you can tell from This.

Thanks, Wayne.

Windows 98 IP Configuration

      Host Name . . . . . . . . . : LF13.STEVENSDOM
      DNS Servers . . . . . . . . : 10.0.0.2
      Node Type . . . . . . . . . : Hybrid
      NetBIOS Scope ID. . . . . . :
      IP Routing Enabled. . . . . : No
      WINS Proxy Enabled. . . . . : No
      NetBIOS Resolution Uses DNS : No

0 Ethernet adapter :

      Description . . . . . . . . : Intel 8255x-based Integrated Fast Ethernet
      Physical Address. . . . . . : 00-02-A5-2B-19-3E
      DHCP Enabled. . . . . . . . : Yes
      IP Address. . . . . . . . . : 10.0.0.107
      Subnet Mask . . . . . . . . : 255.255.255.0
      Default Gateway . . . . . . : 10.0.0.20
      DHCP Server . . . . . . . . : 10.0.0.2
      Primary WINS Server . . . . : 10.0.0.2
      Secondary WINS Server . . . : 10.0.0.2
      Lease Obtained. . . . . . . : 11 05 04 14:41:21
      Lease Expires . . . . . . . : 11 13 04 14:41:21


Windows 2000 IP Configuration

        Host Name . . . . . . . . . . . . : Server2
        Primary DNS Suffix  . . . . . . . : stevensdom.local
        Node Type . . . . . . . . . . . . : Hybrid
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : stevensdom.local

Ethernet adapter Team #0 - Adaptive Load Balancing Mode:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Intel(R) Advanced Network Services Virtual Adapter
        Physical Address. . . . . . . . . : 00-06-5B-8F-15-02
        DHCP Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 10.0.0.3
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 10.0.0.20
        DNS Servers . . . . . . . . . . . : 10.0.0.2
        Primary WINS Server . . . . . . . : 10.0.0.2
0
crissandCommented:
Now run on a windows 9x workstation

nbtstat -a server2

and let's see the answer.

Anyway, in the network I administer I have created a group on the file server where I included all domain users, and give that group permissions and security rights over the shares.
0
siltechCommented:
Have you tried to edit the hosts & lmhosts file manually? dont forget to get rid from the .sam extension

if it will help you then you may replace though file automatically on the users computers using the login script

0
Wayne_OwenAuthor Commented:
All the 98 and 95 users have Exchange mailboxes, shares to Database files Ect, they are all OK undet TCP/IP
All the 98 and 95 users have login scripts, setting up printers and mapped drives, also using policy's. these are also all OK, except maps to Fileserver when only TCP/IP is  installed, when I install Netbui then all maps are correct to the Fileserver.

The Hosts file is copied down from the Domain Controller when the User Logs on.

I will now not be back to the Office until monday 8th @ 8.30am GMT, this I hope might give everyone time to ponder, I require to resolve this by mid next week or I may be forced to Reinstall the OS. We have critical applications that run on the Fileserver, and I think this problem is interfering with the operation of the apps, uses winsock for wireless clients in the factory which are loosing their connections.

The Network problem is persistant when applications are running or not, the problem existed prior to reinstalling our internal applications after the rebuild.

crissand I will run nbstat when I get into the office on monday morning.

0
siltechCommented:
before you reinstall the OS try to install another server (even on a laptop or PC) as a DC and check if the problem comes from the specified OS or maybe from an old GP or something. If you like I can connect you via Terminal Server & see if I can help you
 
0
Wayne_OwenAuthor Commented:
Results of nbtstst -a server2

Run from a 98 PC with only TCPIP installed

Server2           00     Unique    Registered
Stevensdom     00     Group     Registered
Server2           03     Unique    Registered
Server2           20     Unique    Registered
Stevensdom     1E     Group     Registered
LPalser            03     Unique    Registered
BSutherland     03     Unique    Registered

0
crissandCommented:
Ok. Now let's use gpedit.msc to verify the security on the file server:

Computer/Windows Settings/Security Options/Digitally sign client communication (allways) sa fie disabled.
Computer/Windows Settings/Security Options/Digitally sign server communication (allways) sa fie disabled.

I think if you'll look at the same configurations option on the SBS server you'll see the options are disabled already.
0
Wayne_OwenAuthor Commented:
Within

Computer/Windows Settings/Security Options/

I Have

Account Policies, Local Policies, Public Key Policies and IP Security Policies

Within Local Policies I Have

Digitaly Sign Client Communications (Always) Disabled
Digitaly Sign Client Communications (When Possiable) Enabled
Digitaly Sign Server Communications (Always) Disabled
Digitaly Sign Server Communications (When Possiable) Disabled.

Am I Looking in the Correct Area ?

Thanks.

0
crissandCommented:
Yes. These settings must be the same on the sbs server which is accessibale and the file server. These settings can be modified by domain policy, if the domain policy is applied to the file server well.

Look to secure channel too (lower), it's one setting that speaks about windows 2000 (strong key).
0
Wayne_OwenAuthor Commented:
Secure Channel Require Strong(Windows 2000 or Later) Session Key
on both FileServer and Domain Controler both the Same Disabled.

I have also removed the Teaming on the Network cards and disabled the Second Card, The Primary card has the Latest Drivers installed.

Tested again with win98 client and all test are the same as above.
0
crissandCommented:
Start again.
1.The windows 9x station are configured that it take the userlist and password from the domain, is'n't it?
2.The network configuration on 9x machines has NIC, tcp/ip, client for microsoft network and File and printer sharing for ms network?
3.The master browser on all workstation is disabled?
4.The file server is joined to the domain?
5.There is a group of domain users that have access to the shares?
6.Have you tried to access the shares using a username from one of the windows 2000 workstations, which connect well?
7.If the connection is settled thru group policy, this is not apllying to windows 9x workstations, you must create scripts.

0
Wayne_OwenAuthor Commented:
1. Yes
2. Yes
3. Yes (Master is Domain Controller)
4. Yes
5. Yes
6. Yes (All Connects fine and seems to be Win98/95 rather than XP or 2000)
7. Connection is not Settled through Group Policy.

Any Less Confused !
0
crissandCommented:
1.Now, have you created a group of domain users in the Local users and groups section of the file server?
2.This group have permissions over the file shares?
3.All the workstations are added (manualy) in the computers OU (or in a home made OU) of active directory users and computers section?
0
Wayne_OwenAuthor Commented:
Do I Understand Correctly, You are asking if,

On the Fileserver are there a Group containing all the Domain Users, then the Shares are getting their authority from this group, then all the PC's to be added to the OU

The Fileserver is only a file server and has no Active Directory, hence no OU's

The Domain Controller OurDomain/OU contain all the PC's, remembering there is not a problem with any PC and any shares on the Domain Controller,
On the Domain Controller, there are Groups which contain all the WinXX Users, On the FilesServer the Folder's requiring the shares are shared to these Groups.
The Users can get access to these share's or Denied from the shares only if Netbui is installed.

Sorry if I seem to be running over the same info again,
0
crissandCommented:
It's ok, but the users from windows 9x workstations must be added to the file server, at least from my experience this was the method to access the shares. Initially I created a local group with only these users, added from Active directory, because the file server is joined to the domain, but I found it easy to add all the users from active directory to a local group, and deal with permissions for that group over the shares.
0
Wayne_OwenAuthor Commented:
I Understand what you are saying, Prior to the rebuild the FileServer everything was Sweet, Don't particullary like workarounds, I like to understand the problem and resolve it, the Install of Netbui is a workaround at the moment and is keeping us working, I would like to understand what it is that may be incorrect on the FileServer, to my understanding all should be working correctly.


Question
1. Is this worth persuing further, I have moved Apps that were giving problems to a divfferent Server. So not critical.
2. Since I am new to EE, Completing this as unresolved, Do I give the points to the person whom I think has been most helpfull.

Sorry Question 2 is a question within a question, Don't want to upset anyone.

Should you think this is not now worth persuing any longer, if I manage to resolve do you wish to be informed ?

Many thanks to all.
0
crissandCommented:
The netbeui problem indicate there is something wrong with the netbios protocol, especially with netbios over tcp/ip (when netbeui is not installed).
0
Wayne_OwenAuthor Commented:
What would be the best way to Remove Netbios to make sure that when reinstalling the network Drivers Netbios / TcpIp gets updated/installed correctly.

Will now be out till 9.00 GMT.

Thanks
0
crissandCommented:
Try first to install on Windows 98 machine the unofficial service pack from:

http://exuberant.ms11.net/98sesp.html
0
Wayne_OwenAuthor Commented:
Sorry, for not replying earlier.

Since all the Winxx PC's are afffected with the problem is it not wise to assume that the problem is on the fileserver,

In this case what is the best way to ensure that netbios is removed and reinstalled on win2K.

Thanks, hopefully get this resolved and award the points.

Wayne :)
0
Wayne_OwenAuthor Commented:
Have split points, Thanks crissand, alas since this is still not rectified I will reinstall over the festive season.

Thanks to all who persisted in trying to answer.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.