?
Solved

Windows 2000 - Move location of user profile

Posted on 2004-11-04
12
Medium Priority
?
186 Views
Last Modified: 2010-04-14
I have recently setup my desktop PC with Windows 2000 from Windows 98 as I need a more stable platform and IIS.

My drives are partioned with a seperate partition for user data and files.  I have managed to copy the profile to the new location using Control Panel>System>User Profiles.  But can't make the profile point to this new location.  I have tried using the Profile Path box under Control Panel>Users and Passwords but this seems to just bring up messages about not being able to log onto the server.

There is no server here, just a desktop PC and a laptop connected over the network and to the internet through a router.

Can anyone point me in the right direction to be able to move the user profile to this new location?
0
Comment
Question by:yorkshirepudding
  • 7
  • 5
12 Comments
 
LVL 11

Expert Comment

by:KaliKoder
ID: 12496829
Hello YorkShirePudding,

When you copied the profile to the location you said, did you actually give the profile the right permissions to be used ?
Are you trying this, because you dont want to have the profile in the C:\documents and settings\username folder ?
Is the profile on the same C: drive where you moved it from ?

Please reply back, Thanks
0
 
LVL 1

Author Comment

by:yorkshirepudding
ID: 12497137
Hi

I'm not sure what you mean on that first point.  From the Copy To dialog the Permitted To box has the right username in and there are no restrictions on drive access.

Yes - I want files on a separate partition so if something happens to Windows and the drive needs re-formatting, all the data is safe.

No - I am trying to move it to drive E:

Thanks
yorkie
0
 
LVL 11

Expert Comment

by:KaliKoder
ID: 12497385
Ok, try doing the following:

- Reboot your machine (sometimes its necessary as W2K still has hooks on to the profile you are trying to copy)
- Make sure you are not logged on as the user whose profile you are trying to copy and that you are logged on as a user who has admin previleges on your machine
- On the E: drive, make a folers called Profiles, Share this folder with the same name Profiles$ , and make sure you set the share permissions Everyone = FC
- Now click on Start and then right click on the MyComputer icon you see in the Start menu, goto properties, then to advanced tab, user profiles and settings. Highlight the user whose profile you want to copy and click "Copy to" , in the location type, \\yourcomputernamehere\profiles$  and make sure where it says "permitted to use", you type in "Yourcomputername\theUserNameHere" (without quotes). Hit ok and ok again to close out of the system properties
- Go to your E:\profiles folder and see if you see data there. Also make sure that the user has the necessary NTFS permissions for this whole E:\profiles folder and sub folders
- Now goto Start -> Control Panel -> Users and Password and double click the user whose profile you just copied, go to the profiles tab, and type in \\YourComputerNameHere\profiles$ and hit ok and ok again to close out of user properties
- Log on as the user, see if you get any error messages. If you dont then all is good

Another note, what I explained above, would always copy the users profile to and from the E:\profiles$ share. However, you would never be able to get rid of the C:\documents and sharing\username folder , this is by design from MS and can not be changed. However, it does accomplish your goal of the profile being always available if the machine or the C: partition crashes.

Thanks and Good Luck!
0
Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

 
LVL 1

Author Comment

by:yorkshirepudding
ID: 12498513
When I try to logon as the user, I get the following message:

Windows did not load your roaming profile and is attempting to log you on with your local profile. Changes to the profile will not be copied to the server when you logoff. Windows did not load your profile because a server copy of the profile folder already exists that does not have the correct security. Either the current user or the Administrator's group must be the owner of the folder. Contact your network administrator.

I created a new favourite then checked the Favourites folders to see which one it had gone in.  The favourite had been created in the default folder on the C: drive

Any other ideas?

Thanks
yorkie
0
 
LVL 11

Expert Comment

by:KaliKoder
ID: 12498701
Ok. its a definitely an issue with permissions. I am hoping you did everything like I said. Please do the following step by step:

- Log on to the box as an administrator (not as the user)

- Go to your E:\profiles folder, right click and goto properties, in the sharing tab, make sure the folder is shared as profiles$, click the share permissions button on the SAME tab, and make sure the "everyone" group has full control. Hit Apply

- Now go to the security tab, make sure Administrators are listed there and also the user is listed there, Administrator should have Full Control and User should have Modify/Change permissions.  Now click on the Advance Button, go to the Owner tab, and make sure "Administrators" are listed as the owner, if not add them and make sure the checkbox that says, replace owner on all subcontainers is checked on. Hit Apply. Now come to the permissions tab again, Clear the checkbox that says, "Inherit permissions from parent......." you would be prompted, do you wanna copy or replace ? Choose Replace, and hit Apply. Now while being on the same permissions tab, make sure the checkbox that says, "replace permissions on all child objects....." is checked on, and hit apply. Click ok and then ok again to get out of file permissions.

- Log off, and relog on as the user. See what happens!

Good Luck!
0
 
LVL 1

Author Comment

by:yorkshirepudding
ID: 12498787
This may be the problem - I don't have a 'Security' tab so can't set ownership on this folder.

Any ideas how I get it?

Thanks
yorkie
0
 
LVL 11

Expert Comment

by:KaliKoder
ID: 12498805
Yorkie.. can you tell me if the File System on your E: drive is FAT32 or NTFS ? It seems it is FAT, you can go to your C: drive in Explorer, right click it and say properties, it should say there, File System is FAT or NTFS
0
 
LVL 11

Expert Comment

by:KaliKoder
ID: 12498842
Yorkie, also, what happens when you Ping yourcomutername from a command prompt.

To do this, Click Start -> Run -> in the box type "cmd" (without the quotes) and hit enter. Then on the command prompt you get, type "Ping thenameofyourcomputer" (without quotes) and hit enter, what do you get ? Do u get replies ?
0
 
LVL 1

Author Comment

by:yorkshirepudding
ID: 12499407
Hi

Have now converted E: to NTFS and gone through your instructions as best I can.  Only difference was the option was either Copy or Remove.  When I did remove it took away all permissions so tried copy instead.  I don't get the message at logon but it still uses the profile on the C: drive.

Pinging works fine - no probs there

Thanks
yorkie
0
 
LVL 11

Accepted Solution

by:
KaliKoder earned 1000 total points
ID: 12499550
Ok Yorkie, thats a good sign. We are getting somewhere. No when you say you dont get any error messages, but it still uses the profile on C: drive, how are you able to say that. In order to test this, please do this:

Go to your E:\profiles folder, and look for the date and time stamp on a file called ntuser.dat (you need to make sure hidden file viewing is turned to turn it on, In Windows explorer click on Tools ->Folder options -> View and make sure show hidden files and folders and show system files is turned on) . Is this date and time stamp corrosponding to the time when you logged the user off ?

- Log back on as the user, now, put a file on the desktop (any file). Now log off, and log on as administrator, and go to E:\profiles and there in the desktop folder, look if the file exsists. If it does, then profile is being written back and forth correctly.

Thanks
0
 
LVL 1

Author Comment

by:yorkshirepudding
ID: 12499760
Hi

It seems to be working.  I think I'm starting to understand what's happening.  It only copies to the E: drive when I logoff but uses the C: drive on an ongoing basis then copies back to the C: drive when I logon.  

Thanks for all your guidance and help.  Full marks!!!
yorkie
 
0
 
LVL 11

Expert Comment

by:KaliKoder
ID: 12499819
Hi Yorkie!

Thanks for the Marks. Yorkie, what happens is that, your location where the profile resides is correct (E:\profiles). However, the reason you are thinking, that its copying stuff to the C:\documents and settings\username folder, is also correct. This is windows behaviour by default, it can not be changed. This area (C:\documents and settings\username ) is a place on your computer, where Windows stores a "local" or whats called a "cached" copy of your "roaming" (one located on E:\ drive) profile. This functionality was put in place, so that lets say if your "roaming profile" was located on another machine or a server on your network, and lets say the network died and you could not get to your server, then in this case, you would not be helpless, the cached copy would kick in and you be able to work!

When you log off, any changes you made to your profile (eg; a New favorite in IE, a new shortcut on your desktop etc) get "pushed up" to your "roaming profile location" (E:\profiles). This way your profile on E:\ drive always stays current. In case of an emergency (C: partition going bad) you would still have a copy of this on your E: :)

Thanks again!
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
If anyone asked you to network diagram of the internet, it was drawn in the form of a fluffy cloud which further became known as cloud computing. Popularly cloud computing is defined as workloads that run over the internet in a commercial provider’s…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Look below the covers at a subform control , and the form that is inside it. Explore properties and see how easy it is to aggregate, get statistics, and synchronize results for your data. A Microsoft Access subform is used to show relevant calcul…
Suggested Courses

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question