Copying AUTORUN.INF files

When we are copying an INF file to a network drive, we get an access denied or file is in use message.

How can we get around this error?  it is only when we are trying to copy to a network drive.

THANKS!
The_machineAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pjcrooks2000Commented:
make sure the CD rom has not actually started to run before you copy it.  e.g. stop the application on the CD running then right click on the drive where the autorun.inf file is and click on explore.  You should then be able to copy it to the drive.

cheers

pjcrooks2000
0
The_machineAuthor Commented:
The file is not from a cd. It is in a folder that I need to copy to the network.
0
pjcrooks2000Commented:
Why not then just open up the file copy and paste the contents of it into another text file using notepad.

The save the file on the network drive as filename.inf and makes ure you select "all files" from the save as type drop down box below ehere you specified the name for it.

That should do it, as your only making a copy of it!

pjcrooks2000
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

The_machineAuthor Commented:
No dice, I already tried that, in fact if I rename the autorun.inf to autorun2.inf it works, but once it is on the network server I can’t rename it back to autorun.inf.
0
pjcrooks2000Commented:
Do you have write privileges to this network server?  

What I mean is create a new file on your machine in notepad copying and pasting the contents from the old file to the new file and save it on your desktop or somewhere.  Then you should be able to copy it from the desktop to the network server, there is a possibility that you no not have permissions to place or write files of this nature into your network share.  First try copying a standard text file to the share to make sure that works then copy the new file that you have created to the share.

0
Crash2100Commented:
Maybe autorun files are not allowed on the server for security?  Especially since it took the file when you renamed.  To get around this you could put the file in a zip file or something.
0
The_machineAuthor Commented:
First off I am an enterprise admin, I have full permissions, I can copy any .inf file as long as it is not autorun.inf . If I log in to the server I can copy the file from a CD or rename the file from autorun2.inf to autoun.inf. I have always been able to copy files like this when I make MSI installs for GPO’s .. It is as if MS has made some type security update to not allow this.


Any input…
0
pjcrooks2000Commented:
This is a possibility and It seems to me to be the only logical solution or entity that could be causing the problem, that is:

If you have a file already on the network drive or even a registry entry for the given file on the system called autorun.inf and it is being used then it will not allow you to write over it, hence the message error your getting.  It's worth checking out.  Unhide all files on the network drive and have a gander.

Most probably a file is already there, by the way.  Just checking the network drive is not some form of media that cannot be written to such as a CD rom or something.  Perhaps it may have been mapped wrong, not by yourself of corse :)

Try those

pjcrooks2000
0
The_machineAuthor Commented:
Found it ,,, it was VirusScan 8.0I

Thanks
0
pjcrooks2000Commented:
Was there another autorun.inf file there ?
0
The_machineAuthor Commented:
No,,,
0
pjcrooks2000Commented:
What was the problem then?
0
The_machineAuthor Commented:
"Found it ,,, it was VirusScan 8.0I

Thanks"
0
pjcrooks2000Commented:
What does that mean?  What has the virus scan got to do with the inf file?
0
The_machineAuthor Commented:
A default policy in VS 8.0I is preventing autorun.inf files from being copied.
0
Crash2100Commented:
Well, I was close!  :-)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Crash2100Commented:
thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Installation

From novice to tech pro — start learning today.