Using Microsoft file and printer sharing through a connected switch and router

Hi there,

We are a small business running about 12 computers -- we have a 24-port Netgear 10/100 switch which is plugged into a 1mb cable modem connection.  Our office features two main areas, and I would like to connect 4 or 5 computers directly to the 24-port Netgear switch and then have a cable going across the office to a Belkin 4-port wireless router (connected in the "uplink" port) with 4 more computers hooked into that.  The key here is I want file sharing across all computers and also printer sharing, however, we have not been able to have the computers on the switch "see" the computers on the router, and vice versa.  You should also know that we have a dynamic IP address/DNS which is assigned by our ISP.

Thanks for your help on this.  Best, Jaeson
jaesonrosenfeldAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ViRoyCommented:

on the router... do you have the cable coming from the 24 port switch plugged into the WAN port or into one of the other ports.
if you have it connected to the WAN port then it might be firewalled... try connecting the cable into one of the other ports and leave the WAN port alone. this will make 1 big switch instead of a switch and router setup while still providing wireless..
0
ViRoyCommented:

ah i noticed you say it is in the 'uplink' port... swap that... it should work after that.
the reason you dont need to use the uplink port is because you can get enough ip adresses from the cable modem, all you need it for is wireless... no need for the router to split them up even more, that creates alot of overhead.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jaesonrosenfeldAuthor Commented:
Hi ViRoy,
Thanks for the fast feedback -- I did not totally understand, should I put it in the WAN port or just one of the 4 general ports.  And if it is the WAN port, does the firewall issue not concern you? Also, are there any setting that i might need to adjust on the routers configuration page?

Thanks again,
Jaeson
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

holger12345Commented:
The IP adress from your ISP is only interesting for the WAN port of the router... so dynamic or not, that doesnt matter. What LAN IP adresses do you use? It shoudl be adresses in the same network range for all PCs and the routers internal interface.

Try to choose this:
IP 192.168.0.1 with netmask 255.255.255.0 for the router

IP 192.168.0.2 with netmask 255.255.255.0 up to
IP 192.168.0.50 with netmask 255.255.255.0 for the PCs in the one building

IP 192.168.0.51+ with netmask 255.255.255.0 for the PCs in the other building

feel free to use other private network adress ranges, but these are some standards

If you want to activate DHCP on the router, feel free to do this... you have to setup the client PCs accordingly, so they can get dynamic IP adresses

regards
Holger

0
holger12345Commented:
The connection line from the switch MUST be put into a non-WAN-port ... these non-WAN-ports are standard switch-ports, so that you in effective extend the other switch into the second room
0
holger12345Commented:
If you don't use dynamic IP adresses for your LAN (DHCP) you'll have to assign the gateway adress (routers 192.168.0.1) and the DNS adress to the clients (it's more work for the beginning)
0
jaesonrosenfeldAuthor Commented:
Sorry still a little lost here.  I am a bit of a newbie at this.  So I get this much:

1. Need to hook the outgoing cable from the 24-port switch into any non-WAN, non-uplink port in the router.
2. My default gateway is 192.168.102.1 with subnet mask 255.255.255.0, and the ip addresses are 192.168.102.1xx.  This is what i get when I type cmd/ipconfig from a computer connected into the 24-port switch
3. My default gateway for a computer connected to the router is 192.168.2.1 with subnet mask 255.255.255.0 and ip addresses are 192.168.102.1xx. I assume the router default gateway will change to the same as the switch default gateway when i plug into the non-Wan, non-uplink port?

4. I am pasting the information that I get when i pull up the 192.168.102.1 in the Internet explorer window.

Parameter Status
WAN IP Address Assignment Dynamic  
      IP Address 10.39.215.179
      Subnet Mask 255.255.192.0
      Default Gateway 10.39.192.1
DNS Servers 10.36.16.4
10.36.16.3
 
DHCP Server/NAT Enabled  
Configured MAC Address 00:11:1A:51:C7:58
Factory MAC Address 00:11:1A:51:C7:58
Line 1
    Phone Number
    Caller ID  
1-617-395-7655
617-395-7655
Line 2
    Phone Number
    Caller ID  
1-269-978-6837
269-978-6837


So my question: do i need to make some manual adjustments in the configuration page for the switch, or can i just simply plug the cable into the non-WAN, non-uplink port and I should be fine?  Last stupid question, as a novice I would have assumed certain ports in a router are "in" ports (WAN, uplink) and certain ports are "out" ports (all others), but this is not the case?

Thanks,
Jaeson
0
jjk16Commented:
is the cable your only internet provider? t1, isdn?

the reason why your having trouble is not the wan etc...

the router is segmenting your network

i.e   192.168.102.xxx     and the router
       192.168.2.xxx

the reason why the computers cannot "see"
each other is that the netbios packets are not being passed through the router

so if you really wanted you can allow the packets through (bad idea, more complicated), you can manually network by ip address instead of UNC

simply turn off nat on your router and dhcp server,spi too if its blocking smb requests (your turning your wireless into an access point) better idea..  

is the cable/dsl your only internet conecction in the office?



setup the routers lan IP to be in the same range   192.168.102.xxx  



0
holger12345Commented:
Has any of your equipement the IP 192.168.102.1 or is this just entered as the gateway, but noone cares?
If the answer is Yes, just reconfigure the internal IP of the router to 192.168.102.1 and use this as the one and only default gateway.

The 24-port switch must be cross-connectet to the routers non-WAN-port.
You can achieve this by either ...
.... using ONE (and only one!) uplink port, of the switch OR the router with a standard cable
.... using a crossover cable and DON'T use any uplink port
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.