Cannot set active partition

Posted on 2004-11-04
Last Modified: 2012-08-14
I have a 20 GB harddrive that is recognized in the BIOS (as HDD 1) but which is not bootable.  

Initially it had win2k installed but after I edited the administrator profile I could not boot from it, the NTLDR was missing.  I backed up my files, did an fdisk with the drive hooked up to myLinux box and tried to boot with a Linux RH9 installation CD.  That did not work.  I tried to create a bootable CD for a linux/rh install from RedHat support page instructions but the instructions
>mkisofs -o file.iso -b isolinux.bin -c -no-emul-boot \  -boot-load-size 4 -boot-info-table -R -J -v -T isolinux/
are complicated and I get all kinds of errors, the first one being that the file does not exist.  I'm not sure which file (tried substitutions) so I could not create the iso file needed to boot in linux.

I now have the drive hooked up as a slave to a win98 HDD 0 because I thought it might be easier to work with a DOS-based system.  I have run fdisk on HDD 1 again.  The drive is still not bootable because I am unable to set an active partition for it, even when I set it as master and hook it up to the CDROM IDE connection (separately from HDD 0).  I have gone through two floppy drives, they both are bad and I would like to avoid buying another.  I tried copying win98 boot files to a CD, but on boot I get the error that the CD is not bootable.  The CDROM drive is recognized in the BIOS and in windows, it has the right files on it, and I have checked the contents of the autoexec.bat and config.sys files on my linux box.  So I don't understand why the CD is not bootable to a command prompt.

I had previously scanned HDD 1 and there were no errors on it.

When I typed, from win98,
C:\>sys D:
the response was "system transferred" so I may not have a corrupted mbr.  In desperation, I tried
D:\>fdisk /mbr
and got a warning that the D drive is trying to write to the C drive mbr, and
C:\>fdisk /mbr
gave me a warning that the C drive was trying to overwrite its own mbr I can't check/overwrite the mbr until I activate the HDD 1 partition and don't really want to do that anyway.
Finally, also in desperation, I tried other installation CDs (Win98, Win2K) after running an fdisk with the win98 HDD 0, just to see if I could find something bootable from the CDROM, and I always get a "CDROM failed on boot" message, telling me to insert a system disk.

I am trying to understand the boot process as I go along, so pls comment (as youalways do :)  If I can set an active partition on this drive without the benefit of the floppy drive, I should be able to solve this.  Help!

Question by:klukac
    LVL 69

    Expert Comment

    If you still have the Win2K drive, you should hook it up as the only drive (master) on the Primary IDE, and have your CDROM drive as master on the Secondary IDE.  Set your BIOS to boot from the CDROM, and insert your Win2K CD and boot into the recovery console.  Type FIXMBR, followed by FIXBOOT, followed by BOOTCFG /REBUILD, and then reboot.
    LVL 5

    Assisted Solution

    Let's see, with 98 on hdd0 and your 20gig on hdd1, restart to msdos or at least boot to a safe command prompt. Change the directory to C:\windows\command and run the FDISK. You must be able to see both drives when selecting option 4, view partitions. If you can't see hdd1 it is malfunctioning-replace it. If you see both drives, select the hdd1 20gig and delete all existing partitions. Restart the PC back into safe command prompt. Redo FDISK and select hdd1 and create the new partition. Once created reboot to your desktop in 98. Double click My Computer, right click on the new D drive (new partition you just created) and select format. If your hdd1 does not come up in My Computer you are having a hardware related failure.
    LVL 7

    Expert Comment

    Also, check your pc vendor website and download and update a new Bios for the pc.
    LVL 2

    Assisted Solution

    pop in a windows 98 start up disk, boot up, when the bios screen goes off start hitting F5 it should say windows is bypassing your startup files and give you an A:\ prompt. Type in "FDISK  /MBR". Eject the disk and reboot.
    LVL 32

    Expert Comment

    You have 2 reasonable options.  I would first try mlynch24's method since you already have drives installed in that configuration.

    Other method (which can be used on all IDE drives be they new or old).

    1. Connect hard drive as master on Primary IDE channel and optical drive as master on secondary IDE channel.
    2. Boot from Windows 98 CD.
    3. Select Start my Computer with CD ROM Support
    4. Type D: then Enter to change to CD drive
    5. Type CD\WIN98 then Enter to change to setup directory
    6. Type FDISK then Enter to run fdisk
    7. Delete all partitions on hard disk
    8. Reboot and repeat steps 2-6
    9. Create partition and set it as primary DOS
    10. Reboot and repeat steps 2-6
    11. Type Format C: /S then Enter to format hard disk and transfer system or Type SETUP then enter to install Windows 98.


    Expert Comment

    i would recommend low-level formatting the hdd.  check your mfgr. website for the proper utilities.  once low-level formatted, you can then fdisk, format (high-level), and install the os.  hope this helps!
    LVL 14

    Accepted Solution

    Just some info.  With FAT32, only 1 partition can be set active.  With HD0 already active, fdisk won't let you set HD1 as active.  You can have 2 disks set active if one of the disks was taken out of a working machine and it was the boot drive and the drive currently in the machine was already active, but you can't activate a partition if an active partition already exists.  In the case where you have 2 drives with 2 active partitions, the first active partition (usually primary master) will be the bootable one.  If you want to make the 20gb active, do as willcomp suggests.
    LVL 1

    Assisted Solution

    Under win98 you cannot set 2 active partitions from scratch. You MUST boot from floppy (or from a bootable CD if you don´t have your fdd working) with just 1 hard drive connected and set one of it´s partitions as active. Other option is to hook up the drive onto a system running win2000 or winXP and from the disk manager set your partition as active.

    Author Comment

    Thanks to all for terrific responses, and especially Johnny Canuck and Tarmin for the explanations.  Based on the initial feedback, I ordered 3 more floppy drives last night, the supplier looks good so at least one of them should work out.  Today my project was going to be to update the bios.  Unfortunately, it may be too late for anything now...the CMOS hung up when I tried to change the boot order, I got a sync error on screen, and then everything died.  I disconnected the non-bootable drive but even though it shows some effort to crank up, it doesn't pass the post test and there's no video output.  I'm going to need to rebuild a pc I guess, so I'll start shopping around for components, starting with a new motherboard.  I'll be doing this piecemeal due to budget constraints.  The one I have now is an ATA 100 with an Award 1998 PCI / PNP 686 BIOS and a 1 GHz processor.

    Author Comment

    I remember on some old NT machines that you could pop the battery to clear the CMOS and restart.  In my case the battery is glued in so it would take a little more work, but given the situation I just described I don't have much to lose.  Let me know what you think...I'll need a little recovery period before I award points here, patience pls thanks.
    LVL 14

    Assisted Solution

    Hmmm...there should be a jumper to clear the CMOS.  If that doesn't help then your motherboard is likely dead - unless you can find a new BIOS chip.

    Author Comment

    Thanks JohnnyCanuck, I cleared the CMOS and was able to do a cold reboot.  

    I ended up replacing the motherboard when I started seeing sync errors, but the problem was most likely my CPU fan, which I replaced, and I also replaced the floppy drive and an IDE cable.

    Did the fdisk /mbr, repartitioned the drive, set it active and formatted it (as FAT) to load Windows 98, just to make sure that I could load an OS on this hard drive.   I left it running for a while, the drive is fine.    

    Now I'm back to where I started, which is my original attempt to load Linux - in this case, RH9.  I had loaded RH9 and RH8 before that on an older PC, so I don't understand why it's not working this time.  I was told by someone who had problems attempting to load various Linux distributions that Linux often fails to install, and that it may be hardware-related.  What do you think?

    I've tried boot floppies  I had also used to load my last version of RH9, and a boot floppy that I created for this install using rawrite.  The floppy boots to the RH9 install screen and I have tried most of the options that you can access with F2... can't even get to the mediacheck or linux rescue features.  In each case, I get:
    >loading vmlinuz...
    >boot failed, change disks and press any key to continue
    I've also tried typing various parameters at the boot prompt, but all result in errors, mostly "boot failed" and also "could not find kernel image"  

    I've tried using another CD for disk 1 (of 3) of the RH9 install, same results.  The distribution I am using was downloaded from the Internet.  I finally bought a boxed set of SuSE Linux, PC-version to see if I have the same problem with a store-bought copy.  I should get that in a few days.  Is there anything here that points to a hardware problem/incompatibility?  Is loading Linux (to overwrite a FAT partition) often this difficult or is this an anomaly?

    LVL 14

    Expert Comment

    Did you verify the .ISOs that you downloaded with the md5sums?  This is a must for large downloads.

    Featured Post

    Highfive Gives IT Their Time Back

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Join & Write a Comment

    Suggested Solutions

    Title # Comments Views Activity
    Disk boot Failure 100 187
    Does core m3-6y30 support VT ? 6 59
    Acer server reboots randomly 6 40
    BSOD on VM Image restore from Hardware 27 11
    In this article you will get to know about pros and cons of storage drives HDD, SSD and SSHD.
    Does your iMac really need a hardware upgrade? Will upgrading RAM speed-up your computer? If yes, then how can you proceed? Upgrading RAM in your iMac is not as simple as it may seem. This article will help you in getting and installing right RA…
    Hi everyone! This is Experts Exchange customer support.  This quick video will show you how to change your primary email address.  If you have any questions, then please Write a Comment below!
    Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    25 Experts available now in Live!

    Get 1:1 Help Now